7.7 Отчет по удаленным строкам из чека ккм

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем SerzhM, 11 июл 2011.

  1. TopicStarter Overlay
    SerzhM
    Offline

    SerzhM Опытный в 1С

    Регистрация:
    26 окт 2009
    Сообщения:
    511
    Симпатии:
    3
    Баллы:
    29
    Как реализовать отчет по удаленным строкам за весь день из чека ккм.
    Принцип. Работает оператор ккм у него есть доступ к удалению строки( советы по запретить удаление строк из чека не вариант) мало ли случайно удалил, но что бы избежать вороства, нужно что бы удаленная строка помещалась в какой нить резерв а потом на основании этого резерва в конце дня сделать отчет по удаленным строкам за этот день
  2. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Ну я бы делал через дополнительный документ, который по структуре табличной части совпадает с ТЧ чека (ну может еще плюс 2 колонки: чек и номер строки этого чека). Далее отлавливаем удаление строки, записываем ее в этот документ, если записать не удалось, то строку не удаляем.
  3. TopicStarter Overlay
    SerzhM
    Offline

    SerzhM Опытный в 1С

    Регистрация:
    26 окт 2009
    Сообщения:
    511
    Симпатии:
    3
    Баллы:
    29
    А можно сделать так что все будет записываться в один документ? Пример можно как это будет выглядеть в коде. Создается первый чек ккм дальше должна следовать проверка есть ли сегодня такой документ(для сохранения удаленных строк). Как в коде проверка должна выглядеть

    Допустим буду реализововать так
    Заведу константу контроль удаления строк
    Код:
    Процедура ПриУдаленииСтроки()
    Если Константа.МДВУдалениеСтрокЧекККМ=1 <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда	</span>
    Если НазваниеНабораПрав()="Администратор" Тогда
    Иначе
    //Вот сюда надо код для сравнения и перетаскивания в документ
    
    КонецЕсли;
    КонецЕсли;
    КонецПроцедуры
    
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Правильно. Только доступ к константе должен быть только у администратора и документ фиксирующий удаляемые строки - 1 в течении дня
  5. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Не совсем понимаю, зачем трогать константы.

    По доступу - можно просто "обрубить" доступ к документу. Программно он будет доступен.

    Делай по одному документу на каждый день (хотя нужно смотреть по объему удаляемых строк, возможно и один к одному).
  6. TopicStarter Overlay
    SerzhM
    Offline

    SerzhM Опытный в 1С

    Регистрация:
    26 окт 2009
    Сообщения:
    511
    Симпатии:
    3
    Баллы:
    29
    Я и хочу один в день. Подскажите примерно как сравнить был ли создан документ уже, для переноса удаленных строк.
    Код:
    Процедура проверки есть ли за сегодня уже такой документ если да тогда переносим(вопрос как найти мне этот документ через код) иначе создать форма.документ.дляудаленных строк
    
  7. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Найти очень просто:
    Код:
    Док=СоздатьОбъект("Документ.РегистраторУдаления")
    Если Док.ВыбратьДокументы(ТекущаяДата(),ТекущаяДата())=0 Тогда
    Док.Новый();
    КонецЕсли;
    
    
  8. TopicStarter Overlay
    SerzhM
    Offline

    SerzhM Опытный в 1С

    Регистрация:
    26 окт 2009
    Сообщения:
    511
    Симпатии:
    3
    Баллы:
    29
    Будем пробывать. Если что я к вам за советом опять :)
  9. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Обращайтесь

Поделиться этой страницей