7.7 Отчет по счет-фактурам выданным

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем Steelrat72, 7 ноя 2014.

  1. TopicStarter Overlay
    Steelrat72
    Offline

    Steelrat72

    Регистрация:
    12 май 2013
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Создаю отчет в 1С- Предприятие 7.7 по выборке счетов - фактур за месяц по номенклатуре. Создал запрос, идет выборка, но в счетах фактурах имеющих больше одной строки выбирается только последняя строчка. Подскажите пожалуйста как в запросе просуммировать строки в счет-фактуре (интересуют столбцы количество и сумма).
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    запрос то покажите
  3. TopicStarter Overlay
    Steelrat72
    Offline

    Steelrat72

    Регистрация:
    12 май 2013
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    //*******************************************
    // Процедура генерации запроса Сформировать.
    //
    Процедура Сформировать()
    Перем Запрос, ТекстЗапроса, Счет,Таб,Н,Контрагент,Колво,Сумма;

    А1=0;А2=0;А3=0;А4=0;А5=0;А6=0;А7=0;А8=0;
    Б1=0;Б2=0;Б3=0;Б4=0;Б5=0;Б6=0;Б7=0;Б8=0;
    В1=0;В2=0;В3=0;В4=0;В5=0;В6=0;В7=0;В8=0;
    Г1=0;Г2=0;Г3=0;Г4=0;Г5=0;Г6=0;Г7=0;Г8=0;
    Д1=0;Д2=0;Д3=0;Д4=0;Д5=0;Д6=0;Д7=0;Д8=0;
    Ж1=0;Ж2=0;Ж3=0;Ж4=0;Ж5=0;Ж6=0;Ж7=0;Ж8=0;
    К1=0;К2=0;К3=0;К4=0;К5=0;К6=0;К7=0;К8=0;
    Л1=0;Л2=0;Л3=0;Л4=0;Л5=0;Л6=0;Л7=0;Л8=0;
    М1=0;М2=0;М3=0;М4=0;М5=0;М6=0;М7=0;М8=0;
    Н1=0;Н2=0;Н3=0;Н4=0;Н5=0;Н6=0;Н7=0;Н8=0;
    О1=0;О2=0;О3=0;О4=0;О5=0;О6=0;О7=0;О8=0;
    П1=0;П2=0;П3=0;П4=0;П5=0;П6=0;П7=0;П8=0;
    Р1=0;Р2=0;Р3=0;Р4=0;Р5=0;Р6=0;Р7=0;Р8=0;
    С1=0;С2=0;С3=0;С4=0;С5=0;С6=0;С7=0;С8=0;
    У1=0;У2=0;У3=0;У4=0;У5=0;У6=0;У7=0;У8=0;
    Ф1=0;Ф2=0;Ф3=0;Ф4=0;Ф5=0;Ф6=0;Ф7=0;Ф8=0;
    Т1=0;Т2=0;Т3=0;Т4=0;Т5=0;Т6=0;Т7=0;Т8=0;

    S=0;D=0;F=0;G=0;R=0;J=0;L=0;N=0;V=0;



    Код:
    ////Создание объекта типа Запрос
        Запрос = СоздатьОбъект("Запрос");
        ТекстЗапроса =
        "//{{ЗАПРОС(Сформировать)                                                                                    
        |Период с ВыбНачПериода по ВыбКонПериода;
        |СчетФактура = Документ.СчетФактура.ТекущийДокумент;
        |НомерДок = Документ.СчетФактура.НомерДок;
        |Контрагент = Документ.СчетФактура.Контрагент;
        |Товар = Документ.СчетФактура.Товар;
        |Колво = Документ.СчетФактура.Количество;
        |Сумма = Документ.СчетФактура.Сумма;
        |Всего = Документ.СчетФактура.Всего;
        |НДС = Документ.СчетФактура.НДС;
        |ВидОперации = Документ.СчетФактура.ВидОперации;
        |Группировка СчетФактура;
        |"//}}ЗАПРОС
        ;
     
        // Если ошибка в запросе, то выход из процедуры
        Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
            Возврат;
        КонецЕсли;
     
        Таб = СоздатьОбъект("Таблица");
        Таб.ИсходнаяТаблица("Сформировать");
        Таб.ВывестиСекцию("Заголовок");
        Состояние("Заполнение выходной таблицы...");
        Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
     
        //*****************************************************************************
        Пока Запрос.Группировка(1) = 1 Цикл
        Если Запрос.Контрагент.Родитель.Наименование = СокрЛП ("БЮДЖЕТ МЕСТНЫЙ") Тогда
        Если Запрос.Колво <> 0 Тогда
         
            S=S+1;
        //------------Отопление-------------------// 
            Если (Запрос.Товар.Родитель.Код = СокрЛП ("000003132")) ИЛИ
                (Запрос.Товар.Родитель.Код = СокрЛП ("000003136")) Тогда  
            А1=Запрос.Колво;
            А2=Запрос.Всего;
            Иначе
            А1="0";
            А2="0";
            КонецЕсли;
     
        //------------Потери по Отоплению-------------------//
        Если (Запрос.Товар.Родитель.Код = СокрЛП ("000003134")) ИЛИ
             (Запрос.Товар.Родитель.Код = СокрЛП ("000003139")) Тогда
            А3=Запрос.Колво;
            А4=Запрос.Всего;
            Иначе
            А3="0";
            А4="0";
            КонецЕсли;
        //------------Потери по Горячему водоснабжению----------------//
        Если (Запрос.Товар.Родитель.Код = СокрЛП ("000003135")) ИЛИ
            (Запрос.Товар.Родитель.Код = СокрЛП ("000003138")) Тогда
            А5=Запрос.Колво;
            А6=Запрос.Всего;
            Иначе
            А5="0";
            А6="0";
            КонецЕсли;
        //------------Горячее водоснабжение-------------------//
     
        Если (Запрос.Товар.Родитель.Код = СокрЛП ("000003133")) ИЛИ
             (Запрос.Товар.Родитель.Код = СокрЛП ("000003137")) Тогда
            А7=Запрос.Колво;
            А8=Запрос.Всего;
            Иначе
            А7="0";
            А8="0";
            КонецЕсли;
            Б1=Б1+А1;
            Б2=Б2+А2;
            Б3=Б3+А3;
            Б4=Б4+А4;
            Б5=Б5+А5;
            Б6=Б6+А6;
            Б7=Б7+А7;
            Б8=Б8+А8;
     
         
            Таб.ВывестиСекцию("Строка1");
    //    КонецЕсли;
        КонецЕсли;
        КонецЕсли; 
        КонецЦикла;
           Таб.ВывестиСекцию("Строка2");
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    |Период с ВыбНачПериода по ВыбКонПериода;
    |СчетФактура = Документ.СчетФактура.ТекущийДокумент;
    |НомерДок = Документ.СчетФактура.НомерДок;
    |Контрагент = Документ.СчетФактура.Контрагент;
    |Товар = Документ.СчетФактура.Товар;
    |Колво = Документ.СчетФактура.Количество;
    |Сумма = Документ.СчетФактура.Сумма;
    |Всего = Документ.СчетФактура.Всего;
    |НДС = Документ.СчетФактура.НДС;
    |ВидОперации = Документ.СчетФактура.ВидОперации;
    |Функция Сум = Сумма(Сумма);
    |Группировка СчетФактура;
    |"//}}ЗАПРОС
    ;

    Остальное сами добавите
  5. TopicStarter Overlay
    Steelrat72
    Offline

    Steelrat72

    Регистрация:
    12 май 2013
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Спасибо
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Не за что. Обращайтесь

Поделиться этой страницей