7.7 Отчет по проектам

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем BigAnn, 27 дек 2010.

  1. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Почти - вы должны ОБНУЛИТЬ значение суммы - документ-то сторнируется. Для этого мы и расчитываем временную таблицу
  2. TopicStarter Overlay
    BigAnn
    Offline

    BigAnn Опытный в 1С

    Регистрация:
    22 сен 2008
    Сообщения:
    73
    Симпатии:
    0
    Баллы:
    26
    Что-то не поняла. Если я обнулю сумму прихода в ПКО, как же эта сумма попадет в расход при сторнировании?
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Выложите что там у вас получилось сейчас
  4. TopicStarter Overlay
    BigAnn
    Offline

    BigAnn Опытный в 1С

    Регистрация:
    22 сен 2008
    Сообщения:
    73
    Симпатии:
    0
    Баллы:
    26
    Да собственно ничего почти еще не изменилось. Я пробовала номер строки даже числом проставлять, все равно ошибку выдет: Номер за пределами значения!

    Вложения:

  5. TopicStarter Overlay
    BigAnn
    Offline

    BigAnn Опытный в 1С

    Регистрация:
    22 сен 2008
    Сообщения:
    73
    Симпатии:
    0
    Баллы:
    26
    Решила сделать по-другому:
    Код:
    Тмп.ВыбратьСтроки();
    Пока Тмп.ПолучитьСтроку() = 1 Цикл
    
    Если Тмп.Док.Вид() = "Сторно" Тогда
    Если Тмп.Док.СторнируемыйДокумент.Вид() = "СтрокаВыпискиПриход" Тогда
    Тмп.СуммаРасх = Тмп.Док.СторнируемыйДокумент.СуммаВзаиморасчетов;
    КонецЕсли;
    
    Если Тмп.Док.СторнируемыйДокумент.Вид() = "ПКО" Тогда
    Тмп.СуммаРасх = Тмп.Док.СторнируемыйДокумент.СуммаВзаиморасчетов;
    КонецЕсли;  
    
    Если Тмп.Док.СторнируемыйДокумент.Вид() = "Реализация" Тогда
    Тмп.СуммаПрих = Тмп.Док.СторнируемыйДокумент.СуммаВзаиморасчетов;
    КонецЕсли;
    
    Если Тмп.Док.СторнируемыйДокумент.Вид() = "РеализацияРозница" Тогда
    Тмп.СуммаПрих = Тмп.Док.СторнируемыйДокумент.СуммаВзаиморасчетов;
    КонецЕсли;
    
    Дошла ло локумента ВводОстатков и снова не понимаю. Сумма документа почему-то равна 0.
    В таблице сумма выводится так:
    Код:
    глФрм(глПересчет(Запрос.ДокПрих.Итог("СуммаРуб"), глРубли, Запрос.ДокПрих.ДатаДок, Запрос.ДокПрих.Договор.ВалютаВзаиморасчетов, Запрос.ДокПрих.ДатаДок))
    
    Хотела сделать вот так:
    Код:
    Если Тмп.Док.СторнируемыйДокумент.Вид() = "ВводОстатковПокупателя" Тогда 
    Если Тмп.Док.СторнируемыйДокумент.ВидОперации = Перечисление.ВидыОперацийПоВводуОстатков.ОстаткиДолгаПокупателяНам Тогда
    Тмп.СуммаРасхВвод = Тмп.Док.СторнируемыйДокумент.СуммаРуб;
    Иначе
    Тмп.СуммаПрихВвод = Тмп.Док.СторнируемыйДокумент.СуммаРуб;
    КонецЕсли;
    КонецЕсли;
    
    суммы все по нулям. Как вытянуть сумму документа?

Поделиться этой страницей