7.7 Отчет по продажам

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем speed-x, 15 авг 2012.

  1. TopicStarter Overlay
    speed-x
    Offline

    speed-x Опытный в 1С

    Регистрация:
    13 май 2008
    Сообщения:
    84
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте, все! Меня попросили бухи сделать отчет пономенклатуре, точнее им нужно чтобы при формировании отчета они могли выбрать период и ГРУППУ номенклатуры, после чего сформировать отчет в котором получилось бы так Контрагент-Группа номенклатуры-дальше то что в этой группе нахоится, колличество купленного этим контрагентом той или иной номенклатуры и сумма. А уменя получается что я могу выбрать только один товар по которому он сможет мне сформировать отчет.


    Код:
    //*******************************************
    // Процедура генерации запроса Сформировать.
    //
    Процедура Сформировать()
    Перем Запрос, ТекстЗапроса, Таб;
    //Создание объекта типа Запрос
    
    
    
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса =
    "//{{ЗАПРОС(Сформировать)
    |Период с ВыбНачПериода по ВыбКонПериода;
    |Контрагент = Документ.Реализация.Контрагент;
    |МестоХранения = Документ.Реализация.МестоХранения;
    |Номенклатура = Документ.Реализация.Номенклатура;
    |Количество = Документ.Реализация.Количество;
    |Сумма = Документ.Реализация.Сумма;
    |ТекущийДокумент = Документ.Реализация.ТекущийДокумент;
    |ТипНоменклатуры = Документ.Реализация.Номенклатура.ТипНоменклатуры;
    |Функция СуммаСумма = Сумма(Сумма);
    |Функция КоличествоСумма = Сумма(Количество);
    |Условие (Номенклатура.ТипНоменклатуры<>Перечисление.ТипыНоменклатуры.Материал);
    |Группировка Контрагент;
    |Группировка Номенклатура;
    |"//}}ЗАПРОС
    ;
    
    Если ПустоеЗначение(ВыбГруппуНоменклатуры)=0 Тогда
    ТекстЗапроса = ТекстЗапроса+
    "Условие(Номенклатура= ВыбГруппуНоменклатуры);";
    КонецЕсли;
    
    // Если ошибка в запросе, то выход из процедуры
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Возврат;
    КонецЕсли;
    // Подготовка к заполнению выходных форм данными запроса   ЗначениеУпорядочивания(,)
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    // Заполнение полей "Заголовок"
    Таб.ВывестиСекцию("Шапка");
    Состояние("Заполнение выходной таблицы...");
    Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
    Пока Запрос.Группировка(1) = 1 Цикл
    // Заполнение полей Номенклатура
    Таб.ВывестиСекцию("Контрагент");
    
    Пока Запрос.Группировка(2) = 1 Цикл
    Если Запрос.Номенклатура.ЭтоГруппа()=1 Тогда
    Таб.ВывестиСекцию("Группа1");
    Иначе
    
    Таб.ВывестиСекцию("Строка");
    
    КонецЕсли;
    КонецЦикла;
    КонецЦикла;
    // Заполнение полей "Всего"
    // Таб.ВывестиСекцию("ИИтого");
    // Вывод заполненной формы
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать", "");
    КонецПроцедуры
    На первом рисунке я выбираю Группу и хотел чтобы получился отчет как на втором рисунке но на втором рисунке изображен отчет по конкретной номенклатуре.Подскажите пожалуйста как быть???
    Посмотреть вложение 11954 Посмотреть вложение 11955

    Вложения:

    • 1.JPG
      1.JPG
      Размер файла:
      76,4 КБ
      Просмотров:
      169
    • 2.JPG
      2.JPG
      Размер файла:
      109,1 КБ
      Просмотров:
      174
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    надо так
    Код:
    Условие(Номенклатура в ВыбГруппуНоменклатуры)
    В этом случае проверку на пустое значение можно убрать совсем
  3. TopicStarter Overlay
    speed-x
    Offline

    speed-x Опытный в 1С

    Регистрация:
    13 май 2008
    Сообщения:
    84
    Симпатии:
    0
    Баллы:
    26
    СПАСИБО БОЛЬШОЕ!!!!!!
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Не за что. Обращайтесь.

Поделиться этой страницей