7.7 Отчет по платежным документам

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Steelrat, 12 авг 2008.

  1. TopicStarter Overlay
    Steelrat
    Offline

    Steelrat

    Регистрация:
    20 апр 2006
    Сообщения:
    14
    Симпатии:
    0
    Баллы:
    1
    Господа помогите!
    Имеется отчет по платежным документам (Платежное требование)
    Подскажите как можно сделать выборку документов по банку, то есть какие платежные требования проходили по конкретному банку за месяц.
    Зарание благодарен!
    Текст запроса (Выводит все платежные требования)

    Код:
    Процедура Сформировать()
    Перем Запрос, ТекстЗапроса, Таб;
    //Создание объекта типа Запрос
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = 
    "//{{ЗАПРОС(Сформировать)
    |Период с ВыбНачПериода по ВыбКонПериода;
    |ОбрабатыватьДокументы все;
    |Обрабатывать НеПомеченныеНаУдаление;
    |Наименование = Документ.ПлатежноеТребование.РасчетныйСчет.БанкОрганизации.Наименование;
    |СчетБанк = Документ.ПлатежноеТребование.СчетКонтрагента.Номер;
    |Наименование1 = Документ.ПлатежноеТребование.Контрагент.Наименование;
    |Сумма = Документ.ПлатежноеТребование.Сумма;
    |ДатаДок = Документ.ПлатежноеТребование.ДатаДок;
    |НомерДок = Документ.ПлатежноеТребование.НомерДок;
    |Группировка НомерДок;
    |"//}}ЗАПРОС
    ;
    // Если ошибка в запросе, то выход из процедуры
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Возврат;
    КонецЕсли;
    
    // Подготовка к заполнению выходных форм данными запроса
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    // Заполнение полей "Заголовок"
    Таб.ВывестиСекцию("Заголовок");
    Состояние("Заполнение выходной таблицы...");
    Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
    S=0;
    
    Пока Запрос.Группировка(1) = 1 Цикл
    
    S=S+1;
    // Заполнение полей ТекущийДокумент
    Таб.ВывестиСекцию("Строка1");
    СуммаВсего=СуммаВсего+Запрос.Сумма; 
    КонецЦикла; 
    
    Таб.ВывестиСекцию("Подвал");
    Таб.ВывестиСекцию("Подпись");
    // Вывод заполненной формы
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать", "");
    КонецПроцедуры
    
  2. Stado_adama
    Offline

    Stado_adama Модераторы Модератор

    Регистрация:
    27 ноя 2007
    Сообщения:
    1.086
    Симпатии:
    0
    Баллы:
    26
    Код:
    |Банк= Документ.ПлатежноеТребование.РасчетныйСчет.БанкОрганизации
    |Условие Банк = ВыбБанк
    
    где ВыбБанк - элемент формы

Поделиться этой страницей