8.х Отчет по отгрузкам

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем ximera, 30 апр 2008.

  1. TopicStarter Overlay
    ximera
    Offline

    ximera Опытный в 1С

    Регистрация:
    5 фев 2008
    Сообщения:
    205
    Симпатии:
    0
    Баллы:
    26
    в таком случае выдается ошибка

    {Форма.Форма(95)}: Ошибка при вызове метода контекста (Выполнить): {(7, 44)}: Поле не найдено "ВзаиморасчетыСПокупателямиОстаткиИОбороты.Период"
    ВзаиморасчетыСПокупателямиОстаткиИОбороты.<<?>>Период КАК ВыбМесяц
    Выборка = Запрос.Выполнить().Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
    по причине:
    {(7, 44)}: Поле не найдено "ВзаиморасчетыСПокупателямиОстаткиИОбороты.Период"
    ВзаиморасчетыСПокупателямиОстаткиИОбороты.<<?>>Период КАК ВыбМесяц
  2. LordKim
    Offline

    LordKim Опытный в 1С

    Регистрация:
    11 мар 2008
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    А при детализации по записи чем поле заполняется?
  3. TopicStarter Overlay
    ximera
    Offline

    ximera Опытный в 1С

    Регистрация:
    5 фев 2008
    Сообщения:
    205
    Симпатии:
    0
    Баллы:
    26
    при детализации по записи - поле остается незаполненным
  4. LordKim
    Offline

    LordKim Опытный в 1С

    Регистрация:
    11 мар 2008
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    не могет быть :unsure:
    А в записях регистра есть Период? Заполнен?
  5. TopicStarter Overlay
    ximera
    Offline

    ximera Опытный в 1С

    Регистрация:
    5 фев 2008
    Сообщения:
    205
    Симпатии:
    0
    Баллы:
    26
    период имеется и заполнен. Такое ощущение что я какую то элементарную ошибку допустил, в макете в пересечении строка и месяц должен быть какой то параметр??
  6. LordKim
    Offline

    LordKim Опытный в 1С

    Регистрация:
    11 мар 2008
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    В пересечении у тебя должны быть две ячейки с параметрами
    Сумма и Отгрузка...

    Кстати итог по месяцам должен идти наверно перед детальными записями, то есть
    | ИТОГИ
    | СУММА(Отгрузка),
    | СУММА(Сумма)
    | ПО
    | ОБЩИЕ,
    | Менеджер,
    | Контрагент,
    |ВыбМесяц";
  7. TopicStarter Overlay
    ximera
    Offline

    ximera Опытный в 1С

    Регистрация:
    5 фев 2008
    Сообщения:
    205
    Симпатии:
    0
    Баллы:
    26
    приведу куски кода вывода и запроса

    Код:
    Пока Выборка.Следующий() Цикл
    Если Выборка.ТипЗаписи() = ТипЗаписиЗапроса.ДетальнаяЗапись Тогда
    //    Если ПараметрыОтчета["ТолькоИтоги"] Тогда Продолжить;
    //    КонецЕсли;
    Область = ТекМакет.ПолучитьОбласть("Строка");
    Область.Параметры.Контрагент = Выборка.Контрагент;
    Область.Параметры.Отгрузка = Выборка.Отгрузка;
    Область.Параметры.Сумма = Выборка.Сумма;
    ТекТаб.Вывести(Область, Выборка.Уровень());
    
    ОбластьПоле = ТекМакет.ПолучитьОбласть("Строка | Месяц");
    Для каждого ВыбПериод Из СписокПериодов Цикл
    ОбластьПоле.Параметры.Заполнить(Выборка);
    ТекТаб.Присоединить(ОбластьПоле);
    КонецЦикла;
    
    Иначе
    Область = ТекМакет.ПолучитьОбласть("Группировка");
    Область.Параметры.Отгрузка = Выборка.Отгрузка;
    Область.Параметры.Сумма = Выборка.Сумма;
    Область.Параметры.ПечГруппировка = Выборка[Выборка.Группировка()];
    НовШрифт = Новый Шрифт(Область.Области.Группировка.Шрифт,, Макс(12 - Выборка.Уровень(), 8), Ложь);
    Область.Области.Группировка.Шрифт = НовШрифт;
    ТекТаб.Вывести(Область, Выборка.Уровень());
    КонецЕсли;
    Если Не(Выборка.ТипЗаписи() = ТипЗаписиЗапроса.ДетальнаяЗапись) Тогда
    ВыводРезультатовЗапроса(ТекТаб, ТекМакет, Выборка, СписокПериодов);
    КонецЕсли;
    
    
    
    Код:
    Запрос.Текст    = "
    | ВЫБРАТЬ
    | ВзаиморасчетыСПокупателямиОстаткиИОбороты.Сделка.Менеджер КАК Менеджер,
    | ВзаиморасчетыСПокупателямиОстаткиИОбороты.Сделка.Контрагент КАК Контрагент,
    | ВзаиморасчетыСПокупателямиОстаткиИОбороты.Сделка.КоличествоДокумента КАК Отгрузка,
    | ВзаиморасчетыСПокупателямиОстаткиИОбороты.СуммаОборот КАК Сумма,
    | ВзаиморасчетыСПокупателямиОстаткиИОбороты.Период КАК ВыбМесяц
    | ИЗ
    | РегистрНакопления.ВзаиморасчетыСПокупателями.ОстаткиИОбороты(&НачПериода, &КонПериода, Месяц, , ) КАК ВзаиморасчетыСПокупателямиОстаткиИОбороты
    | ИТОГИ
    | СУММА(Отгрузка),
    | СУММА(Сумма)
    | ПО
    | ОБЩИЕ,
    | Менеджер,
    | Контрагент,
    | ВыбМесяц";
    
    
    
    ______________________________________________________________
    |_________________Основная________|________Месяц______________| - имена столбцов
    |шапка______|_____Менеджер_______|___Тн___________|__Сумма____|
    |группировка_|____<ПечГруппировка>|____<отгрузка>__|__<Сумма>_|
    |строка______|_____<Контрагент>____|____<отгрузка>__|__<Сумма>_|


    при таких параметрах происходит дублирование значенией сумма и отгрузка 24 раза, т.е. идет чередование. Причем выводится только общая сумма, без разбивки по месяцам. Период - 1 месяц
  8. LordKim
    Offline

    LordKim Опытный в 1С

    Регистрация:
    11 мар 2008
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    Столкнулся с аналогичным отчетом,
    если решил - выложи свое решение.

    Если нет, то как закончу выложу свое)))

Поделиться этой страницей