8.х Отчет по отгрузкам

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем ximera, 30 апр 2008.

  1. TopicStarter Overlay
    ximera
    Offline

    ximera Опытный в 1С

    Регистрация:
    5 фев 2008
    Сообщения:
    205
    Симпатии:
    0
    Баллы:
    26
    Добрый день.
    Пишу отчет в котором показывается количество отгрузок по каждому контрагенту с начала года по текущую дату, причем разбивка идет отдельно по месяцам. А отгрузка показывается по контрагенту отдельной цифрой без разбивки по документам. В отгрузке показывается общий тоннаж по документам реализации. Помогите пожалуйста с запросом кто чем может :unsure:
  2. AlexFF
    Offline

    AlexFF Разбирающийся

    Регистрация:
    6 мар 2007
    Сообщения:
    565
    Симпатии:
    1
    Баллы:
    26
    Выложите свой запрос - поправим.
  3. TopicStarter Overlay
    ximera
    Offline

    ximera Опытный в 1С

    Регистрация:
    5 фев 2008
    Сообщения:
    205
    Симпатии:
    0
    Баллы:
    26
    Код:
        Запрос.Текст    = "
    |ВЫБРАТЬ
    |    времзапрос.Сделка.Организация КАК СделкаОрганизация,
    |    времзапрос.Сделка.Менеджер КАК СделкаОтветственный,
    |    времзапрос.Сделка КАК Сделка,
    |    СУММА(времзапрос.СуммаКонечныйОстаток) КАК СуммаКонечныйОстаток
    |ИЗ
    |    (ВЫБРАТЬ
    |        ВзаиморасчетыСПокупателямиОстаткиИОбороты.Регистратор КАК Сделка,
    |        СУММА(ВзаиморасчетыСПокупателямиОстаткиИОбороты.СуммаКонечныйОстаток) КАК СуммаКонечныйОстаток
    |    ИЗ
    |        РегистрНакопления.ВзаиморасчетыСПокупателями.ОстаткиИОбороты(&НачПериода, 
    |                      &КонПериода, Регистратор, , ) КАК ВзаиморасчетыСПокупателямиОстаткиИОбороты
    |    ГДЕ
    |        ВзаиморасчетыСПокупателямиОстаткиИОбороты.Регистратор ССЫЛКА Документ.РеализацияТоваровУслуг
    |    
    |    СГРУППИРОВАТЬ ПО
    |        ВзаиморасчетыСПокупателямиОстаткиИОбороты.Регистратор
    |    
    |    ОБЪЕДИНИТЬ ВСЕ
    |    
    |    ВЫБРАТЬ
    |        ВзаиморасчетыСПокупателямиОстаткиИОбороты.Сделка,
    |        СУММА(ВзаиморасчетыСПокупателямиОстаткиИОбороты.СуммаКонечныйОстаток)
    |    ИЗ
    |        РегистрНакопления.ВзаиморасчетыСПокупателями.ОстаткиИОбороты(&НачПериода, &КонПериода, , , ) 
    |                                             КАК ВзаиморасчетыСПокупателямиОстаткиИОбороты
    |    ГДЕ
    |        ВзаиморасчетыСПокупателямиОстаткиИОбороты.Сделка ССЫЛКА Документ.РеализацияТоваровУслуг
    |    
    |    СГРУППИРОВАТЬ ПО
    |        ВзаиморасчетыСПокупателямиОстаткиИОбороты.Сделка) КАК времзапрос
    |ГДЕ
    |    (1 = 1)
    |"+УсловиеМенеджер+"
    |"+УсловиеОрганизация+"
    |СГРУППИРОВАТЬ ПО
    |    времзапрос.Сделка.Менеджер,
    |    времзапрос.Сделка,
    |    времзапрос.Сделка.Организация
    |
    |УПОРЯДОЧИТЬ ПО
    |    СделкаОтветственный,
    |    Сделка
    |ИТОГИ
    |    СУММА(СуммаКонечныйОстаток),
    |   Сумма (Колво)
    |ПО
    |    СделкаОтветственный,
    |    Сделка";
    
    этот запрос производит необходимую выборку, однако необходимо чтобы к примеру если было две отгрузки Иванову И.И. не высвечивалось две строки с значениями 10 и 20, а одна со значением 30.
  4. LordKim
    Offline

    LordKim Опытный в 1С

    Регистрация:
    11 мар 2008
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    А Менеджер одинаковый по этим двум отгрузкам?
    Исключите из запроса вот эту строку
    "| времзапрос.Сделка КАК Сделка,"

    Это регистратор, он мешает строкам сворачиваться.
  5. TopicStarter Overlay
    ximera
    Offline

    ximera Опытный в 1С

    Регистрация:
    5 фев 2008
    Сообщения:
    205
    Симпатии:
    0
    Баллы:
    26
    Да, менеджер один и тот же. Попробовал я убоать данную строку, однако она дальше в коде используется. Что делать??

    Код:
    <pre><FONT COLOR="blue"><FONT FACE="Courier">
    Запрос            [color=red]=[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/новый')">Новый</span> Запрос[color=red];[/color]
    Запрос[color=red].[/color]УстановитьПараметр[color=red]([/color][color=black]"НачПериода"[/color][color=red],[/color]    НачалоДня[color=red]([/color]НачПериода[color=red])[/color][color=red])[/color][color=red];[/color]
    Запрос[color=red].[/color]УстановитьПараметр[color=red]([/color][color=black]"КонПериода"[/color][color=red],[/color]    КонецДня[color=red]([/color] КонПериода[color=red])[/color][color=red])[/color][color=red];[/color]
    
    МенеджерОтбор                [color=red]=[/color] ОтчетОбъект[color=red].[/color]Отбор[color=red].[/color]Менеджер[color=red].[/color]Использование[color=red];[/color]
    МенеджерВидОтбора            [color=red]=[/color] ОтчетОбъект[color=red].[/color]Отбор[color=red].[/color]Менеджер[color=red].[/color]ВидСравнения[color=red];[/color]
    МенеджерЗначениеОтбора        [color=red]=[/color] ОтчетОбъект[color=red].[/color]Отбор[color=red].[/color]Менеджер[color=red].[/color]Значение[color=red];[/color]
    
    ОрганизацияОтбор            [color=red]=[/color] ОтчетОбъект[color=red].[/color]Отбор[color=red].[/color]Организация[color=red].[/color]Использование[color=red];[/color]
    ОрганизацияВидОтбора        [color=red]=[/color] ОтчетОбъект[color=red].[/color]Отбор[color=red].[/color]Организация[color=red].[/color]ВидСравнения[color=red];[/color]
    ОрганизацияЗначениеОтбора    [color=red]=[/color] ОтчетОбъект[color=red].[/color]Отбор[color=red].[/color]Организация[color=red].[/color]Значение[color=red];[/color]
    
    УсловиеОрганизация    [color=red]=[/color] [color=black]""[/color][color=red];[/color]
    УсловиеМенеджер        [color=red]=[/color] [color=black]""[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> ОрганизацияОтбор <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/не')">НЕ</span> ЗначениеНеЗаполнено[color=red]([/color]ОрганизацияЗначениеОтбора[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Запрос[color=red].[/color]УстановитьПараметр[color=red]([/color][color=black]"ВыбОрганизация"[/color][color=red],[/color]    ОрганизацияЗначениеОтбора[color=red])[/color][color=red];[/color]
    УсловиеОрганизация    [color=red]=[/color] СформироватьУсловие[color=red]([/color][color=black]"времзапрос.Сделка.Организация"[/color][color=red],[/color]
    ОрганизацияВидОтбора[color=red],[/color] [color=black]"ВыбОрганизация"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> МенеджерОтбор <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/не')">НЕ</span> ЗначениеНеЗаполнено[color=red]([/color]МенеджерЗначениеОтбора[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Запрос[color=red].[/color]УстановитьПараметр[color=red]([/color][color=black]"ВыбМенеджер"[/color][color=red],[/color]    МенеджерЗначениеОтбора[color=red])[/color][color=red];[/color]
    УсловиеМенеджер    [color=red]=[/color] СформироватьУсловие[color=red]([/color][color=black]"времзапрос.Сделка.Менеджер"[/color][color=red],[/color] 
    МенеджерВидОтбора[color=red],[/color] [color=black]"ВыбМенеджер"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    
    Запрос[color=red].[/color]Текст    [color=red]=[/color] [color=black]"[/color]
    [color=black]        |ВЫБРАТЬ[/color]
    [color=black]        |    времзапрос.Сделка.Организация КАК СделкаОрганизация,[/color]
    [color=black]        |    времзапрос.Сделка.Менеджер КАК СделкаОтветственный,[/color]
    [color=black]        |    времзапрос.Сделка КАК Сделка,[/color]
    [color=black]        |    СУММА(времзапрос.СуммаКонечныйОстаток) КАК СуммаКонечныйОстаток[/color]
    [color=black]        |ИЗ[/color]
    [color=black]        |    (ВЫБРАТЬ[/color]
    [color=black]        |        ВзаиморасчетыСПокупателямиОстаткиИОбороты.Регистратор КАК Сделка,[/color]
    [color=black]        |        СУММА(ВзаиморасчетыСПокупателямиОстаткиИОбороты.СуммаКонечныйОстаток) КАК СуммаКонечныйОстаток[/color]
    [color=black]        |    ИЗ[/color]
    [color=black]        |        РегистрНакопления.ВзаиморасчетыСПокупателями.ОстаткиИОбороты(&НачПериода, &КонПериода, Регистратор, , ) [/color]
    [color=black]        |                               КАК ВзаиморасчетыСПокупателямиОстаткиИОбороты[/color]
    [color=black]        |    ГДЕ[/color]
    [color=black]        |        ВзаиморасчетыСПокупателямиОстаткиИОбороты.Регистратор ССЫЛКА Документ.РеализацияТоваровУслуг[/color]
    [color=black]        |    [/color]
    [color=black]        |    СГРУППИРОВАТЬ ПО[/color]
    [color=black]        |        ВзаиморасчетыСПокупателямиОстаткиИОбороты.Регистратор[/color]
    [color=black]        |    [/color]
    [color=black]        |    ОБЪЕДИНИТЬ ВСЕ[/color]
    [color=black]        |    [/color]
    [color=black]        |    ВЫБРАТЬ[/color]
    [color=black]        |        ВзаиморасчетыСПокупателямиОстаткиИОбороты.Сделка,[/color]
    [color=black]        |        СУММА(ВзаиморасчетыСПокупателямиОстаткиИОбороты.СуммаКонечныйОстаток)[/color]
    [color=black]        |    ИЗ[/color]
    [color=black]        |        РегистрНакопления.ВзаиморасчетыСПокупателями.ОстаткиИОбороты(&НачПериода, &КонПериода, , , ) [/color]
    [color=black]        |                               КАК ВзаиморасчетыСПокупателямиОстаткиИОбороты[/color]
    [color=black]        |    ГДЕ[/color]
    [color=black]        |        ВзаиморасчетыСПокупателямиОстаткиИОбороты.Сделка ССЫЛКА Документ.РеализацияТоваровУслуг[/color]
    [color=black]        |    [/color]
    [color=black]        |    СГРУППИРОВАТЬ ПО[/color]
    [color=black]        |        ВзаиморасчетыСПокупателямиОстаткиИОбороты.Сделка) КАК времзапрос[/color]
    [color=black]        |ГДЕ[/color]
    [color=black]        |    (1 = 1)[/color]
    [color=black]        |"[/color][color=red]+[/color]УсловиеМенеджер[color=red]+[/color][color=black]"[/color]
    [color=black]        |"[/color][color=red]+[/color]УсловиеОрганизация[color=red]+[/color][color=black]"[/color]
    [color=black]        |СГРУППИРОВАТЬ ПО[/color]
    [color=black]        |    времзапрос.Сделка.Менеджер,[/color]
    [color=black]        |    времзапрос.Сделка,[/color]
    [color=black]        |    времзапрос.Сделка.Организация[/color]
    [color=black]        |[/color]
    [color=black]        |УПОРЯДОЧИТЬ ПО[/color]
    [color=black]        |    СделкаОтветственный,[/color]
    [color=black]        |    Сделка[/color]
    [color=black]        |ИТОГИ[/color]
    [color=black]        |    СУММА(СуммаКонечныйОстаток)[/color]
    [color=black]        |ПО[/color]
    [color=black]        |    СделкаОтветственный,[/color]
    [color=black]        |    Сделка"[/color][color=red];[/color]
    
    рез    [color=red]=[/color] Запрос[color=red].[/color]<span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/выполнить')">Выполнить</span>[color=red]([/color][color=red])[/color][color=red];[/color]
    
    Запрос            [color=red]=[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/новый')">Новый</span> Запрос[color=red];[/color]
    Запрос[color=red].[/color]УстановитьПараметр[color=red]([/color][color=black]"КонПериода"[/color][color=red],[/color]    КонецДня[color=red]([/color] КонПериода[color=red])[/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> ОрганизацияОтбор <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/не')">НЕ</span> ЗначениеНеЗаполнено[color=red]([/color]ОрганизацияЗначениеОтбора[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Запрос[color=red].[/color]УстановитьПараметр[color=red]([/color][color=black]"ВыбОрганизация"[/color][color=red],[/color]    ОрганизацияЗначениеОтбора[color=red])[/color][color=red];[/color]
    УсловиеОрганизация    [color=red]=[/color] СформироватьУсловие[color=red]([/color][color=black]"ВзаиморасчетыСПокупателямиОстатки.Сделка.Организация"[/color][color=red],[/color] 
    ОрганизацияВидОтбора[color=red],[/color] [color=black]"ВыбОрганизация"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> МенеджерОтбор <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/не')">НЕ</span> ЗначениеНеЗаполнено[color=red]([/color]МенеджерЗначениеОтбора[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Запрос[color=red].[/color]УстановитьПараметр[color=red]([/color][color=black]"ВыбМенеджер"[/color][color=red],[/color]    МенеджерЗначениеОтбора[color=red])[/color][color=red];[/color]
    УсловиеМенеджер    [color=red]=[/color] СформироватьУсловие[color=red]([/color][color=black]"ВзаиморасчетыСПокупателямиОстатки.Сделка.Ответственный"[/color][color=red],[/color]  
    МенеджерВидОтбора[color=red],[/color] [color=black]"ВыбМенеджер"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    
    запрос[color=red].[/color]Текст    [color=red]=[/color] [color=black]"[/color]
    [color=black]        |ВЫБРАТЬ[/color]
    [color=black]        |    ВзаиморасчетыСПокупателямиОстатки.Сделка КАК Сделка,[/color]
    [color=black]        |    ВзаиморасчетыСПокупателямиОстатки.Сделка.Менеджер,[/color]
    [color=black]        |    ВзаиморасчетыСПокупателямиОстатки.Сделка.Организация,[/color]
    [color=black]        |    СУММА(ВзаиморасчетыСПокупателямиОстатки.СуммаОстаток) КАК СуммаОстаток[/color]
    [color=black]        |ИЗ[/color]
    [color=black]        |    РегистрНакопления.ВзаиморасчетыСПокупателями.Остатки(&КонПериода) КАК ВзаиморасчетыСПокупателямиОстатки[/color]
    [color=black]        |[/color]
    [color=black]        |ГДЕ[/color]
    [color=black]        |    (1 = 1)[/color]
    [color=black]        |"[/color][color=red]+[/color]УсловиеМенеджер[color=red]+[/color][color=black]"[/color]
    [color=black]        |"[/color][color=red]+[/color]УсловиеОрганизация[color=red]+[/color][color=black]"[/color]
    [color=black]        |СГРУППИРОВАТЬ ПО[/color]
    [color=black]        |    ВзаиморасчетыСПокупателямиОстатки.Сделка,[/color]
    [color=black]        |    ВзаиморасчетыСПокупателямиОстатки.Сделка.Менеджер,[/color]
    [color=black]        |    ВзаиморасчетыСПокупателямиОстатки.Сделка.Организация[/color]
    [color=black]        |[/color]
    [color=black]        |УПОРЯДОЧИТЬ ПО[/color]
    [color=black]        |    Сделка[/color]
    [color=black]        |ИТОГИ[/color]
    [color=black]        |    СУММА(СуммаОстаток)[/color]
    [color=black]        |ПО[/color]
    [color=black]        |    Сделка"[/color][color=red];[/color]
    расч    [color=red]=[/color] запрос[color=red].[/color]<span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/выполнить')">Выполнить</span>[color=red]([/color][color=red])[/color][color=red].[/color]Выгрузить[color=red]([/color][color=red])[/color][color=red];[/color]
    
    таб    [color=red]=[/color] ЭлементыФормы[color=red].[/color]ПолеОтчета[color=red];[/color]
    таб[color=red].[/color]Очистить[color=red]([/color][color=red])[/color][color=red];[/color]
    
    макет    [color=red]=[/color] ПолучитьМакет[color=red]([/color][color=black]"Менеджеры"[/color][color=red])[/color][color=red];[/color]
    
    шапка    [color=red]=[/color] макет[color=red].[/color]ПолучитьОбласть[color=red]([/color][color=black]"Шапка"[/color][color=red])[/color][color=red];[/color]
    шапка[color=red].[/color]Параметры[color=red].[/color]ОписаниеПериода    [color=red]=[/color] ПредставлениеПериода[color=red]([/color]НачалоДня[color=red]([/color]НачПериода[color=red])[/color][color=red],[/color] КонецДня[color=red]([/color]КонПериода[color=red])[/color][color=red])[/color][color=red];[/color]
    таб[color=red].[/color]Вывести[color=red]([/color]шапка[color=red])[/color][color=red];[/color]
    
    таб[color=red].[/color]НачатьАвтогруппировкуСтрок[color=red]([/color][color=red])[/color][color=red];[/color]
    
    сч    [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    сп    [color=red]=[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/новый')">Новый</span> СписокЗначений[color=red];[/color]
    
    стрМенеджер    [color=red]=[/color] Макет[color=red].[/color]ПолучитьОбласть[color=red]([/color][color=black]"Менеджер"[/color][color=red])[/color][color=red];[/color]
    стрСделка    [color=red]=[/color] Макет[color=red].[/color]ПолучитьОбласть[color=red]([/color][color=black]"Накладная"[/color][color=red])[/color][color=red];[/color]
    
    выбМенеджеры[color=red]=[/color] рез[color=red].[/color]Выбрать[color=red]([/color]ОбходРезультатаЗапроса[color=red].[/color]ПоГруппировкам[color=red],[/color] [color=black]"СделкаОтветственный"[/color][color=red])[/color][color=red];[/color]
    выбСделки    [color=red]=[/color] рез[color=red].[/color]Выбрать[color=red]([/color]ОбходРезультатаЗапроса[color=red].[/color]ПоГруппировкам[color=red],[/color] [color=black]"Сделка"[/color][color=red])[/color][color=red];[/color]
    
    ЭлементыФормы[color=red].[/color]Индикатор1[color=red].[/color]Видимость                [color=red]=[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/истина')">Истина</span>[color=red];[/color]
    ЭлементыФормы[color=red].[/color]Индикатор1[color=red].[/color]МинимальноеЗначение    [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    ЭлементыФормы[color=red].[/color]Индикатор1[color=red].[/color]МаксимальноеЗначение    [color=red]=[/color] выбСделки[color=red].[/color]Количество[color=red]([/color][color=red])[/color][color=red];[/color]
    __сч    [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    
    партии    [color=red]=[/color] РегистрыНакопления[color=red].[/color]ПартииТоваровНаСкладах[color=red];[/color]
    допрасх    [color=red]=[/color] РегистрыНакопления[color=red].[/color]ДопРасходыНаПродажу[color=red];[/color]
    
    всКолво            [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    всСумма            [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    всСтоимость        [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    всДопРасходы    [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    всНаценка        [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    всТекОплата        [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    всПредОплата    [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    всТекНаценка    [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    всПредНаценка    [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    всОплата        [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    всОплНаценка    [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    всДебиторка        [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    всПрДебиторка    [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">Пока</span> выбМенеджеры[color=red].[/color]Следующий[color=red]([/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    
    стрМенеджер[color=red].[/color]Параметры[color=red].[/color]Менеджер    [color=red]=[/color] выбМенеджеры[color=red].[/color]СделкаОтветственный[color=red];[/color]
    таб[color=red].[/color]Вывести[color=red]([/color]стрМенеджер[color=red],[/color] выбМенеджеры[color=red].[/color]Уровень[color=red]([/color][color=red])[/color][color=red])[/color][color=red];[/color]
    тсМенеджер    [color=red]=[/color] таб[color=red].[/color]ВысотаТаблицы[color=red];[/color]
    
    мКолво            [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    мСумма            [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    мСтоимость        [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    мДопРасходы        [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    мНаценка        [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    мТекОплата        [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    мПредОплата        [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    мТекНаценка        [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    мПредНаценка    [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    мОплата            [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    мОплНаценка        [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    мДебиторка        [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    мПрДебиторка    [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    
    выбСделки    [color=red]=[/color] выбменеджеры[color=red].[/color]Выбрать[color=red]([/color]ОбходРезультатаЗапроса[color=red].[/color]ПоГруппировкам[color=red],[/color] [color=black]"Сделка"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">Пока</span> выбСделки[color=red].[/color]Следующий[color=red]([/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    
    сделка        [color=red]=[/color] выбСделки[color=red].[/color]Сделка[color=red];[/color]
    Количество    [color=red]=[/color] сделка[color=red].[/color]Товары[color=red].[/color]Итог[color=red]([/color][color=black]"Количество"[/color][color=red])[/color][color=red];[/color]
    Сумма        [color=red]=[/color] сделка[color=red].[/color]Товары[color=red].[/color]Итог[color=red]([/color][color=black]"Сумма"[/color][color=red])[/color][color=red];[/color]
    СуммаНДС    [color=red]=[/color] сделка[color=red].[/color]Товары[color=red].[/color]Итог[color=red]([/color][color=black]"СуммаНДС"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> сделка[color=red].[/color]СуммаВключаетНДС <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    СуммаБезНДС    [color=red]=[/color] Сумма [color=red]-[/color] СуммаНДС[color=red];[/color]
    СуммаСНДС    [color=red]=[/color] Сумма[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">Иначе</span>
    СуммаБезНДС    [color=red]=[/color] Сумма[color=red];[/color]
    СуммаСНДС    [color=red]=[/color] Сумма [color=red]+[/color] СуммаНДС[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    
    Стоимость    [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    СуммаПроц    [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    выб    [color=red]=[/color] партии[color=red].[/color]ВыбратьПоРегистратору[color=red]([/color]сделка[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">Пока</span> выб[color=red].[/color]Следующий[color=red]([/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/попытка')">Попытка</span>
    Поставщик    [color=red]=[/color] выб[color=red].[/color]СерияНоменклатуры[color=red].[/color]Документ[color=red].[/color]Контрагент[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/исключение')">Исключение</span>
    Поставщик    [color=red]=[/color] [color=black]""[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпопытки')">КонецПопытки</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/не')">НЕ</span> ЗначениеНеЗаполнено[color=red]([/color]Поставщик[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ОтборНастроек [color=red]=[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/новый')">Новый</span> Структура[color=red]([/color][color=black]"Пользователь,Настройка"[/color][color=red])[/color][color=red];[/color]
    ОтборНастроек[color=red].[/color]Вставить[color=red]([/color][color=black]"Пользователь"[/color][color=red],[/color] выбменеджеры[color=red].[/color]СделкаОтветственный[color=red].[/color]ссылка[color=red])[/color][color=red];[/color]
    ОтборНастроек[color=red].[/color]Вставить[color=red]([/color][color=black]"Настройка"[/color][color=red],[/color] ПланыВидовХарактеристик[color=red].[/color]НастройкиПользователей[color=red].[/color]ОсновноеПодразделение[color=red])[/color][color=red];[/color]
    
    СтруктураОтбора [color=red]=[/color]РегистрыСведений[color=red].[/color]НастройкиПользователей[color=red].[/color]Получить[color=red]([/color]ОтборНастроек[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/не')">НЕ</span> ЗначениеНеЗаполнено[color=red]([/color]СтруктураОтбора[color=red].[/color]Значение[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> СтруктураОтбора[color=red].[/color]Значение [color=red]=[/color] Поставщик[color=red].[/color]Подразделение <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    СуммаПроц    [color=red]=[/color] СуммаПроц [color=red]+[/color] выб[color=red].[/color]СтоимостьБезНДС [color=red]*[/color] Поставщик[color=red].[/color]УменьшатьСебестоимость [color=red]/[/color] [color=black]100[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">ИначеЕсли</span>  СтруктураОтбора[color=red].[/color]Значение [color=red]=[/color] Поставщик[color=red].[/color]Подразделение2 <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    СуммаПроц    [color=red]=[/color] СуммаПроц [color=red]+[/color] выб[color=red].[/color]СтоимостьБезНДС [color=red]*[/color] Поставщик[color=red].[/color]УменьшатьСебестоимость2 [color=red]/[/color] [color=black]100[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    Стоимость    [color=red]=[/color] Стоимость [color=red]+[/color] выб[color=red].[/color]СтоимостьБезНДС[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">КонецЦикла</span>[color=red];[/color]
    
    доп        [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    СтрОтбор    [color=red]=[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/новый')">Новый</span> Структура[color=red]([/color][color=black]"ПоНакладной"[/color][color=red],[/color] сделка[color=red])[/color][color=red];[/color]
    
    выб        [color=red]=[/color] допрасх[color=red].[/color]Выбрать[color=red]([/color]НачалоДня[color=red]([/color]сделка[color=red].[/color]Дата[color=red])[/color][color=red],[/color] КонецДня[color=red]([/color]сделка[color=red].[/color]Дата[color=red])[/color][color=red],[/color] СтрОтбор[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">Пока</span> выб[color=red].[/color]Следующий[color=red]([/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    доп    [color=red]=[/color] доп [color=red]+[/color] выб[color=red].[/color]Стоимость[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">КонецЦикла</span>[color=red];[/color]
    
    Наценка    [color=red]=[/color] СуммаБезНДС [color=red]-[/color] Стоимость [color=red]-[/color] доп [color=red]+[/color] СуммаПроц[color=red];[/color]
    
    СтрОтбор    [color=red]=[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/новый')">Новый</span> Структура[color=red]([/color][color=black]"Сделка"[/color][color=red],[/color] сделка[color=red])[/color][color=red];[/color]
    строки    [color=red]=[/color] расч[color=red].[/color]НайтиСтроки[color=red]([/color]СтрОтбор[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> строки[color=red].[/color]Количество[color=red]([/color][color=red])[/color] [color=red]=[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    НеОплачено    [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">Иначе</span>
    НеОплачено    [color=red]=[/color] строки[color=red][[/color][color=black]0[/color][color=red]][/color][color=red].[/color]СуммаОстаток[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> НеОплачено [color=red]=[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> сделка[color=red].[/color]Дата [color=red]>[/color][color=red]=[/color] НачПериода <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ТекОплата    [color=red]=[/color] СуммаБезНДС[color=red];[/color]
    ПредОплата    [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    ПредНаценка    [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    ТекНаценка    [color=red]=[/color] Наценка[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">Иначе</span>
    ТекОплата    [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    ПредОплата    [color=red]=[/color] СуммаБезНДС[color=red];[/color]
    ПредНаценка    [color=red]=[/color] Наценка[color=red];[/color]
    ТекНаценка    [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    ОплНаценка    [color=red]=[/color] Наценка[color=red];[/color]
    Дебиторка    [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    ПрДебиторка    [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">Иначе</span>
    ТекОплата    [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    ПредОплата    [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    ТекНаценка    [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    ПредНаценка    [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    ОплНаценка    [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    Дебиторка    [color=red]=[/color] НеОплачено[color=red];[/color][color=green]//?(СуммаСНДС=0, 0, НеОплачено * СуммаБезНДС / СуммаСНДС);[/color]
    ср            [color=red]=[/color] НачалоДня[color=red]([/color]сделка[color=red].[/color]Дата[color=red])[/color] [color=red]+[/color] [color=black]86400[/color] [color=red]*[/color] [color=red]([/color][color=black]30[/color] [color=red]+[/color] сделка[color=red].[/color]ДоговорКонтрагента[color=red].[/color]СрокОплатыПоДоговору[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> ср [color=red]>[/color] НачалоДня[color=red]([/color]КонПериода[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ПрДебиторка    [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">Иначе</span>
    ПрДебиторка    [color=red]=[/color] Дебиторка[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    Оплата    [color=red]=[/color] ТекОплата [color=red]+[/color] ПредОплата[color=red];[/color]
    
    стрСделка[color=red].[/color]Параметры[color=red].[/color]Сделка        [color=red]=[/color] сделка[color=red];[/color]
    стрСделка[color=red].[/color]Параметры[color=red].[/color]Дата        [color=red]=[/color] сделка[color=red].[/color]Дата[color=red];[/color]
    стрСделка[color=red].[/color]Параметры[color=red].[/color]Накладная    [color=red]=[/color] сделка[color=red].[/color]Номер[color=red];[/color]
    стрСделка[color=red].[/color]Параметры[color=red].[/color]Контра        [color=red]=[/color] сделка[color=red].[/color]Контрагент[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> сделка[color=red].[/color]Дата [color=red]>[/color][color=red]=[/color] НачПериода <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    стрСделка[color=red].[/color]Параметры[color=red].[/color]Колво        [color=red]=[/color] Количество[color=red];[/color]
    стрСделка[color=red].[/color]Параметры[color=red].[/color]Сумма        [color=red]=[/color] СуммаБезНДС[color=red];[/color]
    стрСделка[color=red].[/color]Параметры[color=red].[/color]Стоимость    [color=red]=[/color] Стоимость[color=red];[/color]
    стрСделка[color=red].[/color]Параметры[color=red].[/color]ДопРасходы    [color=red]=[/color] доп[color=red];[/color]
    стрСделка[color=red].[/color]Параметры[color=red].[/color]Наценка        [color=red]=[/color] Наценка[color=red];[/color]
    стрСделка[color=red].[/color]Параметры[color=red].[/color]НаценкаПр    [color=red]=[/color] [color=red]?[/color][color=red]([/color]Стоимость[color=red]=[/color][color=black]0[/color][color=red],[/color][color=black]0[/color][color=red],[/color][color=black]100[/color] [color=red]*[/color] Наценка [color=red]/[/color] Стоимость[color=red])[/color][color=red];[/color]
    
    мКолво            [color=red]=[/color] мКолво        [color=red]+[/color] Количество[color=red];[/color]
    мСумма            [color=red]=[/color] мСумма        [color=red]+[/color] СуммаБезНДС[color=red];[/color]
    мСтоимость        [color=red]=[/color] мСтоимость    [color=red]+[/color] Стоимость[color=red];[/color]
    мДопРасходы        [color=red]=[/color] мДопРасходы    [color=red]+[/color] доп[color=red];[/color]
    мНаценка        [color=red]=[/color] мНаценка        [color=red]+[/color] Наценка[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">Иначе</span>
    стрСделка[color=red].[/color]Параметры[color=red].[/color]Колво        [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    стрСделка[color=red].[/color]Параметры[color=red].[/color]Сумма        [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    стрСделка[color=red].[/color]Параметры[color=red].[/color]Стоимость    [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    стрСделка[color=red].[/color]Параметры[color=red].[/color]ДопРасходы    [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    стрСделка[color=red].[/color]Параметры[color=red].[/color]Наценка        [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    стрСделка[color=red].[/color]Параметры[color=red].[/color]ТекОплата    [color=red]=[/color] ТекОплата[color=red];[/color]
    стрСделка[color=red].[/color]Параметры[color=red].[/color]ПредОплата    [color=red]=[/color] ПредОплата[color=red];[/color]
    стрСделка[color=red].[/color]Параметры[color=red].[/color]ТекНаценка    [color=red]=[/color] ТекНаценка[color=red];[/color]
    стрСделка[color=red].[/color]Параметры[color=red].[/color]ПредНаценка    [color=red]=[/color] ПредНаценка[color=red];[/color]
    стрСделка[color=red].[/color]Параметры[color=red].[/color]Оплата        [color=red]=[/color] Оплата[color=red];[/color]
    стрСделка[color=red].[/color]Параметры[color=red].[/color]ОплНаценка    [color=red]=[/color] ОплНаценка[color=red];[/color]
    стрСделка[color=red].[/color]Параметры[color=red].[/color]Дебиторка    [color=red]=[/color] Дебиторка[color=red];[/color]
    стрСделка[color=red].[/color]Параметры[color=red].[/color]ПрДебиторка    [color=red]=[/color] ПрДебиторка[color=red];[/color]
    
    мТекОплата        [color=red]=[/color] мТекОплата    [color=red]+[/color] ТекОплата[color=red];[/color]
    мПредОплата        [color=red]=[/color] мПредОплата    [color=red]+[/color] ПредОплата[color=red];[/color]
    мТекНаценка        [color=red]=[/color] мТекНаценка    [color=red]+[/color] ТекНаценка[color=red];[/color]
    мПредНаценка    [color=red]=[/color] мПредНаценка    [color=red]+[/color] ПредНаценка[color=red];[/color]
    мОплата            [color=red]=[/color] мОплата        [color=red]+[/color] Оплата[color=red];[/color]
    мОплНаценка        [color=red]=[/color] мОплНаценка    [color=red]+[/color] ОплНаценка[color=red];[/color]
    мДебиторка        [color=red]=[/color] мДебиторка    [color=red]+[/color] Дебиторка[color=red];[/color]
    мПрДебиторка    [color=red]=[/color] мПрДебиторка    [color=red]+[/color] ПрДебиторка[color=red];[/color]
    
    таб[color=red].[/color]Вывести[color=red]([/color]стрСделка[color=red],[/color] выбСделки[color=red].[/color]Уровень[color=red]([/color][color=red])[/color][color=red])[/color][color=red];[/color]
    
    __сч    [color=red]=[/color] __сч [color=red]+[/color] [color=black]1[/color][color=red];[/color]
    ЭлементыФормы[color=red].[/color]Индикатор1[color=red].[/color]Значение    [color=red]=[/color] __сч[color=red];[/color]
    Обновить[color=red]([/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">КонецЦикла</span>[color=red];[/color]
    
    таб[color=red].[/color]Область[color=red]([/color]тсМенеджер[color=red],[/color]    [color=black]4[/color][color=red],[/color] тсМенеджер[color=red],[/color]    [color=black]4[/color][color=red])[/color][color=red].[/color]Параметр        [color=red]=[/color] мКолво[color=red];[/color]
    таб[color=red].[/color]Область[color=red]([/color]тсМенеджер[color=red],[/color]    [color=black]5[/color][color=red],[/color] тсМенеджер[color=red],[/color]    [color=black]5[/color][color=red])[/color][color=red].[/color]Параметр        [color=red]=[/color] мСумма[color=red];[/color]
    таб[color=red].[/color]Область[color=red]([/color]тсМенеджер[color=red],[/color]    [color=black]6[/color][color=red],[/color] тсМенеджер[color=red],[/color]    [color=black]6[/color][color=red])[/color][color=red].[/color]Параметр        [color=red]=[/color] мСтоимость[color=red];[/color]
    таб[color=red].[/color]Область[color=red]([/color]тсМенеджер[color=red],[/color]    [color=black]7[/color][color=red],[/color] тсМенеджер[color=red],[/color]    [color=black]7[/color][color=red])[/color][color=red].[/color]Параметр        [color=red]=[/color] мДопРасходы[color=red];[/color]
    таб[color=red].[/color]Область[color=red]([/color]тсМенеджер[color=red],[/color]    [color=black]8[/color][color=red],[/color] тсМенеджер[color=red],[/color]    [color=black]8[/color][color=red])[/color][color=red].[/color]Параметр        [color=red]=[/color] мНаценка[color=red];[/color]
    таб[color=red].[/color]Область[color=red]([/color]тсМенеджер[color=red],[/color]    [color=black]9[/color][color=red],[/color] тсМенеджер[color=red],[/color]    [color=black]9[/color][color=red])[/color][color=red].[/color]Параметр        [color=red]=[/color] Формат[color=red]([/color][color=red]?[/color][color=red]([/color]мСтоимость[color=red]=[/color][color=black]0[/color][color=red],[/color][color=black]0[/color][color=red],[/color][color=black]100[/color] [color=red]*[/color] мНаценка [color=red]/[/color] мСтоимость[color=red])[/color][color=red],[/color][color=black]"ЧЦ=5; ЧДЦ=2"[/color][color=red])[/color][color=red];[/color]
    
    таб[color=red].[/color]Область[color=red]([/color]тсМенеджер[color=red],[/color]    [color=black]10[/color][color=red],[/color] тсМенеджер[color=red],[/color]    [color=black]10[/color][color=red])[/color][color=red].[/color]Параметр        [color=red]=[/color] мТекОплата[color=red];[/color]
    таб[color=red].[/color]Область[color=red]([/color]тсМенеджер[color=red],[/color]    [color=black]11[/color][color=red],[/color] тсМенеджер[color=red],[/color]    [color=black]11[/color][color=red])[/color][color=red].[/color]Параметр    [color=red]=[/color] мТекНаценка[color=red];[/color]
    таб[color=red].[/color]Область[color=red]([/color]тсМенеджер[color=red],[/color]    [color=black]12[/color][color=red],[/color] тсМенеджер[color=red],[/color]    [color=black]12[/color][color=red])[/color][color=red].[/color]Параметр    [color=red]=[/color] мПредОплата[color=red];[/color]
    таб[color=red].[/color]Область[color=red]([/color]тсМенеджер[color=red],[/color]    [color=black]13[/color][color=red],[/color] тсМенеджер[color=red],[/color]    [color=black]13[/color][color=red])[/color][color=red].[/color]Параметр    [color=red]=[/color] мПредНаценка[color=red];[/color]
    таб[color=red].[/color]Область[color=red]([/color]тсМенеджер[color=red],[/color]    [color=black]14[/color][color=red],[/color] тсМенеджер[color=red],[/color]    [color=black]14[/color][color=red])[/color][color=red].[/color]Параметр    [color=red]=[/color] мОплата[color=red];[/color]
    таб[color=red].[/color]Область[color=red]([/color]тсМенеджер[color=red],[/color]    [color=black]15[/color][color=red],[/color] тсМенеджер[color=red],[/color]    [color=black]15[/color][color=red])[/color][color=red].[/color]Параметр    [color=red]=[/color] мОплНаценка[color=red];[/color]
    таб[color=red].[/color]Область[color=red]([/color]тсМенеджер[color=red],[/color]    [color=black]16[/color][color=red],[/color] тсМенеджер[color=red],[/color]    [color=black]16[/color][color=red])[/color][color=red].[/color]Параметр    [color=red]=[/color] мДебиторка[color=red];[/color]
    таб[color=red].[/color]Область[color=red]([/color]тсМенеджер[color=red],[/color]    [color=black]17[/color][color=red],[/color] тсМенеджер[color=red],[/color]    [color=black]17[/color][color=red])[/color][color=red].[/color]Параметр    [color=red]=[/color] мПрДебиторка[color=red];[/color]
    
    
    всКолво            [color=red]=[/color] мКолво        [color=red]+[/color] всКолво[color=red];[/color]
    всСумма            [color=red]=[/color] мСумма        [color=red]+[/color] всСумма[color=red];[/color]
    всСтоимость        [color=red]=[/color] мСтоимость    [color=red]+[/color] всСтоимость[color=red];[/color]
    всДопРасходы    [color=red]=[/color] мДопРасходы    [color=red]+[/color] всДопРасходы[color=red];[/color]
    всНаценка        [color=red]=[/color] мНаценка        [color=red]+[/color] всНаценка[color=red];[/color]
    всТекОплата        [color=red]=[/color] мТекОплата    [color=red]+[/color] всТекОплата[color=red];[/color]
    всПредНаценка    [color=red]=[/color] мПредНаценка    [color=red]+[/color] всПредНаценка[color=red];[/color]
    всТекНаценка    [color=red]=[/color] мТекНаценка    [color=red]+[/color] всТекНаценка[color=red];[/color]
    всПредОплата    [color=red]=[/color] мПредОплата    [color=red]+[/color] всПредОплата[color=red];[/color]
    всОплата        [color=red]=[/color] мОплата        [color=red]+[/color] всОплата[color=red];[/color]
    всОплНаценка    [color=red]=[/color] мОплНаценка    [color=red]+[/color] всОплНаценка[color=red];[/color]
    всДебиторка        [color=red]=[/color] мДебиторка    [color=red]+[/color] всДебиторка[color=red];[/color]
    всПрДебиторка    [color=red]=[/color] мПрДебиторка    [color=red]+[/color] всПрДебиторка[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">КонецЦикла</span>[color=red];[/color]
    
    таб[color=red].[/color]ЗакончитьАвтогруппировкуСтрок[color=red]([/color][color=red])[/color][color=red];[/color]
    
    подвал    [color=red]=[/color] макет[color=red].[/color]ПолучитьОбласть[color=red]([/color][color=black]"Подвал"[/color][color=red])[/color][color=red];[/color]    
    
    подвал[color=red].[/color]Параметры[color=red].[/color]Колво            [color=red]=[/color] всКолво[color=red];[/color]
    подвал[color=red].[/color]Параметры[color=red].[/color]Сумма            [color=red]=[/color] всСумма[color=red];[/color]
    подвал[color=red].[/color]Параметры[color=red].[/color]Стоимость        [color=red]=[/color] всСтоимость[color=red];[/color]
    подвал[color=red].[/color]Параметры[color=red].[/color]ДопРасходы        [color=red]=[/color] всДопРасходы[color=red];[/color]
    подвал[color=red].[/color]Параметры[color=red].[/color]Наценка        [color=red]=[/color] всНаценка[color=red];[/color]
    подвал[color=red].[/color]Параметры[color=red].[/color]НаценкаПр        [color=red]=[/color] [color=red]?[/color][color=red]([/color]всСтоимость[color=red]=[/color][color=black]0[/color][color=red],[/color][color=black]0[/color][color=red],[/color][color=black]100[/color] [color=red]*[/color] всНаценка [color=red]/[/color] всСтоимость[color=red])[/color][color=red];[/color]
    подвал[color=red].[/color]Параметры[color=red].[/color]ТекОплата        [color=red]=[/color] всТекОплата[color=red];[/color]
    подвал[color=red].[/color]Параметры[color=red].[/color]ПредОплата        [color=red]=[/color] всПредОплата[color=red];[/color]
    подв
  6. LordKim
    Offline

    LordKim Опытный в 1С

    Регистрация:
    11 мар 2008
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    1)
    Это:
    Код:
    сделка		= выбСделки.Сделка;
    Количество	= сделка.Товары.Итог("Количество");
    Сумма		= сделка.Товары.Итог("Сумма");
    СуммаНДС	= сделка.Товары.Итог("СуммаНДС");
    Если сделка.СуммаВключаетНДС Тогда
    СуммаБезНДС	= Сумма - СуммаНДС;				СуммаСНДС	= Сумма;
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">Иначе	</span>
    СуммаБезНДС	= Сумма;
    СуммаСНДС	= Сумма + СуммаНДС;
    КонецЕсли;
    
    ...можно воткнуть в запрос, так:
    Код:
    "
    |Выбор Когда сделка.СуммаВключаетНДС Тогда
    |"Здесь нужно написать получение из табличной части Суммы без НДС" (например Товары.Сумма - Товары.СуммаНДС)
    |Иначе 
    |"Здесь нужно написать получение из табличной части Суммы без НДС"
    |Конец КАК СуммаБезНДС
    </span>
    |Выбор Когда сделка.СуммаВключаетНДС Тогда
    |"Здесь нужно написать получение <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/из')">из табличной части Суммы с НДС" (например Товары.Сумма)
    |Иначе 
    |"Здесь нужно написать получение из табличной части Суммы с НДС"
    |Конец КАК СуммаСНДС"
    
    Табличная часть "Товары" присоединяется внутренним соединением по Товары.Ссылка = Ссылка,
    таким образом считать итоги по документу будет запрос.

    2)
    Отсюда вопрос, зачем считается наценка, и зачем считается оплата?
    Если без разбивки по документам, то надо обобщать, делать запрос к регистру партий, правда монстр получится...

    3)
    А в регистр Партий вы лезете что бы себестоимость посчитать?
    А почему не запросом? Лефт джоин по регистратору...

    4)
    Добавьте итоги по Организации.
    Тогда при группровке строк можно вывести строки свернутыми до Организаций, и, при необходимости, разворачивать.
  7. TopicStarter Overlay
    ximera
    Offline

    ximera Опытный в 1С

    Регистрация:
    5 фев 2008
    Сообщения:
    205
    Симпатии:
    0
    Баллы:
    26
    Извините, неправильно выразился - есть готовая обработка в ней показывается отчет по менеджерам просто нет общей суммы по тоннам по реализации за конкретный период. Я ее передалать решил. Остальной мусор такой как ндс и пр не нужен. Подскажите с запросом. Наверняка он умещается в пару строк
  8. LordKim
    Offline

    LordKim Опытный в 1С

    Регистрация:
    11 мар 2008
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    Уберите это
    "времзапрос.Сделка КАК Сделка,"
    из верхнего запроса.

    Во вложенном запросе добавьте табличную часть Товары, свяжите по регистратору

    Для первого подзапроса
    "Внутреннее Соединение Документ.РеализацияТоваровУслуг.Товары КАК ДокТовары По ДокТовары.Ссылка = ВзаиморасчетыСПокупателямиОстаткиИОбороты.Регистратор.Ссылка"


    Для второго подзапроса
    "Внутреннее Соединение Документ.РеализацияТоваровУслуг.Товары КАК ДокТовары По ДокТовары.Ссылка = ВзаиморасчетыСПокупателямиОстаткиИОбороты.Сделака.Ссылка"


    Добавьте в оба подзапроса выбор интересующих вас ресурсов.
    Выбирайте Организации и Менеджеров во вложенных подзапросах.

    Группируйте верхний запрос по Менеджерам и Организациям.

    К сожалению у меня нет этой конфы, то бы я вам целиком запрос набросал)
  9. TopicStarter Overlay
    ximera
    Offline

    ximera Опытный в 1С

    Регистрация:
    5 фев 2008
    Сообщения:
    205
    Симпатии:
    0
    Баллы:
    26
    спасибо большое. Я правда написал несколько другой запрос:
    Код:
    Запрос.Текст    = "
    | ВЫБРАТЬ
    | ВзаиморасчетыСПокупателямиОстаткиИОбороты.Сделка.Менеджер КАК СделкаМенеджер,
    | ВзаиморасчетыСПокупателямиОстаткиИОбороты.Сделка.Контрагент КАК СделкаКонтрагент,
    | ВзаиморасчетыСПокупателямиОстаткиИОбороты.Сделка.КоличествоДокумента КАК СделкаКоличествоДокумента,
    | ВзаиморасчетыСПокупателямиОстаткиИОбороты.СуммаОборот КАК СуммаОборот
    | ИЗ
    | РегистрНакопления.ВзаиморасчетыСПокупателями.ОстаткиИОбороты КАК ВзаиморасчетыСПокупателямиОстаткиИОбороты
    | ИТОГИ
    | СУММА(СделкаКоличествоДокумента),
    | СУММА(СуммаОборот)
    | ПО
    | ОБЩИЕ,
    | СделкаМенеджер,
    | СделкаКонтрагент";
    
    
    
    Создал макет. В нем следующие строки (Иванов и Петров - менеджеры)

    - Иванов И.И. 1000
    ООО "Рога" 300
    ООО "Копыта" 700

    + Петров 2000

    Как организовать подобный вывод? Желательно чтобы можно было еще и раскрывать ООО "Рога" и ООО "Копыта"
  10. LordKim
    Offline

    LordKim Опытный в 1С

    Регистрация:
    11 мар 2008
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    Я бы это сделал так:

    Это кусок процедуры печати
    Код:
    // Выборка
    Выборка = Запрос.Выполнить().Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
    Если Выборка.Количество() = 0 Тогда Возврат; КонецЕсли;
    Выборка.Сбросить(); Выборка.Следующий();
    
    // Вывод результатов запроса - рекурсия)))
    Таб.НачатьАвтогруппировкуСтрок();
    ВыводРезультатовЗапроса(Таб, Макет, Выборка);
    Таб.ЗакончитьАвтогруппировкуСтрок();
    
    Область = Макет.ПолучитьОбласть("Подвал");
    *Заполнение параметров области "Подвал"*
    
    
    
    
    Это процедура рекурсии
    Код:
    //*************************************************************************
    // Процедура ВыводРезультатовЗапроса(ТекТаб, ТекМакет, ТекВыборка)
    //
    // Параметры:
    //    ТекТаб - Текущая таблица.
    //    ТекМакет - Макет таблицы.
    //    ТекВыборка - Родительский уровень выборки для текущей итерации.
    //
    // Описание:
    //    Рекурсивная процедура вывода печатной таблицы на основании результатов выполнения запроса ПостроителяОтчета.
    //
    Процедура ВыводРезультатовЗапроса(ТекТаб, ТекМакет, ТекВыборка)
    // Выбираем следующий уровень обхода результатов запроса
    Выборка = ТекВыборка.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
    // Обход уровня итогов
    Пока Выборка.Следующий() Цикл
    Если Выборка.ТипЗаписи() = ТипЗаписиЗапроса.ДетальнаяЗапись Тогда
    Если ПараметрыОтчета["ТолькоИтоги"] Тогда Продолжить; КонецЕсли;
    Область = ТекМакет.ПолучитьОбласть("Строка");
    *Тут пишем заполнение переменных области "Строка"*
    ТекТаб.Вывести(Область, Выборка.Уровень());
    Иначе
    Область = ТекМакет.ПолучитьОбласть("Группировка");
    *Тут пишем заполнение переменных области "Группировка"*
    Область.Параметры.ПечГруппировка = Выборка[Выборка.Группировка()];
    НовШрифт = Новый Шрифт(Область.Области.Группировка.Шрифт,, Макс(12 - Выборка.Уровень(), 8), Ложь);
    Область.Области.Группировка.Шрифт = НовШрифт;
    ТекТаб.Вывести(Область, Выборка.Уровень());
    КонецЕсли;
    Если Не(Выборка.ТипЗаписи() = ТипЗаписиЗапроса.ДетальнаяЗапись) Тогда
    ВыводРезультатовЗапроса(ТекТаб, ТекМакет, Выборка);
    КонецЕсли;
    КонецЦикла; 
    КонецПроцедуры // ВыводРезультатовЗапроса(ТекТаб, ТекМакет, ТекВыборка)
    
    
    
    Что бы разворачивать организацию добавь выбор регистратора в запрос.
    В таком случае регистратор будет детальной записью.
  11. TopicStarter Overlay
    ximera
    Offline

    ximera Опытный в 1С

    Регистрация:
    5 фев 2008
    Сообщения:
    205
    Симпатии:
    0
    Баллы:
    26
    спасибо большое, заработало. Еще небольшой вопрос. Каким образом можно сделать следующее:
    январь февраль март апрель .... декабрь
    - Иванов И.И.
    + ООО Рога 10 1 2 15 0
    + ООО Копыта 0 0 0 14 14

    Т.е. разбивка должна идти по месяцам, начиная с начала года
  12. LordKim
    Offline

    LordKim Опытный в 1С

    Регистрация:
    11 мар 2008
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    Вертикальное расширение таблицы... :unsure: кака.
    в принципе построитель отчета позволяет использовать ИзмеренияКолонки...

    Код:
    ОбластьПоле = Макет.ПолучитьОбласть("Строка|Месяц");
    Для каждого ВыбПериод Из СписокПериодов Цикл
    ОбластьПоле.Параметры.Заполнить(Выборка);
    ТекТаб.Присоединить(ОбластьПоле);
    КонецЦикла;
    
    
    Где СписокПериодов = список значений хранящий месяцы. В числовом их представлении.
  13. TopicStarter Overlay
    ximera
    Offline

    ximera Опытный в 1С

    Регистрация:
    5 фев 2008
    Сообщения:
    205
    Симпатии:
    0
    Баллы:
    26
    там по сути дела будет 13 колонок - 1 строка - менеджер, 2 строка - организация и реализация по месяцам (с января по декабрь). Каким образом нужно предыдущие запросы модифицировать?
  14. LordKim
    Offline

    LordKim Опытный в 1С

    Регистрация:
    11 мар 2008
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    А если период в отчете не год?)
    А, допустим, первое полугодие)
    Тогда колонок месяцев будет 6.

    Создаешь список исходя из заданного периода
    Потом делаешь итоги по месяцам
    Код:
    "|МЕСЯЦ(ВзаиморасчетыСПокупателямиОстаткиИОбороты.Период) КАК ВыбМесяц
    ...
    |Итоги по 
    ...
    |ВыбМесяц"
    
    
    И выводишь тем циклом что я написал выше, после группировки Организации
    Таким образом у тебя по организациям будет разбивка помесячно.
    Сделать помесячную разбивку для всего запроса будет сложнее.

    з.ы.
    цикл выше немного изменил.
  15. TopicStarter Overlay
    ximera
    Offline

    ximera Опытный в 1С

    Регистрация:
    5 фев 2008
    Сообщения:
    205
    Симпатии:
    0
    Баллы:
    26
    немного не понял насчет этого "Строка|Месяц" - это в макете каким образом реализуется?
    и насчет этого: Где СписокПериодов = список значений хранящий месяцы. В числовом их представлении. - каким образом это реализовано. Если отчет будет за полугодие, то пускай остальные столбцы пустыми будут, это не принципиально
  16. LordKim
    Offline

    LordKim Опытный в 1С

    Регистрация:
    11 мар 2008
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    "Строка|Месяц"
    Строка - горизонтальная секция
    Месяц - вертикальная секция
    Область = Макет.ПолучитьОбласть("Строка|Месяц"); - их пересечение

    То есть ты создаешь вертикальную секцию "Основная" и вертикальную секцию "Месяц"
    Область ("Строка|Основная") выводишь командой Вывести
    А область ("Строка|Месяц") выводишь командой Присоединить

    СписокПериодов это список значений
    где элемент списка имеет
    Значение = от 1 до 12 (число)
    Представления соответственно числам 1 = Январь и тп
  17. TopicStarter Overlay
    ximera
    Offline

    ximera Опытный в 1С

    Регистрация:
    5 фев 2008
    Сообщения:
    205
    Симпатии:
    0
    Баллы:
    26
    где этот список описывается - в коде? или реквизит создается перечисляемого типа?

    кстати выдается ошибка при формировании отчета

    ВзаиморасчетыСПокупателямиОстаткиИОбороты.<<?>>Период КАК ВыбМесяц
    Выборка = Запрос.Выполнить().Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
    по причине:
    {(7, 44)}: Поле не найдено "ВзаиморасчетыСПокупателямиОстаткиИОбороты.Период"
    ВзаиморасчетыСПокупателямиОстаткиИОбороты.<<?>>Период КАК ВыбМесяц
  18. LordKim
    Offline

    LordKim Опытный в 1С

    Регистрация:
    11 мар 2008
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    СписокПериодов = Новый СписокЗначений;
    СписокПериодов.Добавить(1, "Январь");
    ...
    СписокПериодов.Добавить(12, "Декабрь");

    Ошибка выдается потому что запрос не детализирован по Периоду.
    Попробуйте дату регистратора(если он оперативный) или детализировать таблицу по Периоду.
    Период - это дата записи в регистре.
  19. TopicStarter Overlay
    ximera
    Offline

    ximera Опытный в 1С

    Регистрация:
    5 фев 2008
    Сообщения:
    205
    Симпатии:
    0
    Баллы:
    26
    Не происходит заполнение столбца месяц. Выложу полный код обработки.
    Код:
    
    Процедура ВыводРезультатовЗапроса(ТекТаб,ТекМакет,ТекВыборка, СписокПериодов)
    
    Выборка = ТекВыборка.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
    
    Пока Выборка.Следующий() Цикл
    Если Выборка.ТипЗаписи() = ТипЗаписиЗапроса.ДетальнаяЗапись Тогда
    //	Если ПараметрыОтчета["ТолькоИтоги"] Тогда Продолжить;
    //	КонецЕсли;
    Область = ТекМакет.ПолучитьОбласть("Строка");
    Область.Параметры.Контрагент = Выборка.Контрагент;
    Область.Параметры.Отгрузка = Выборка.Отгрузка;
    Область.Параметры.Сумма = Выборка.Сумма;
    ТекТаб.Вывести(Область, Выборка.Уровень());
    
    ОбластьПоле = ТекМакет.ПолучитьОбласть("Строка | Месяц");
    Для каждого ВыбПериод Из СписокПериодов Цикл
    ОбластьПоле.Параметры.Заполнить(Выборка);
    ТекТаб.Присоединить(ОбластьПоле);
    КонецЦикла;
    
    Иначе
    Область = ТекМакет.ПолучитьОбласть("Группировка");
    Область.Параметры.Отгрузка = Выборка.Отгрузка;
    Область.Параметры.Сумма = Выборка.Сумма;
    Область.Параметры.ПечГруппировка = Выборка[Выборка.Группировка()];
    НовШрифт = Новый Шрифт(Область.Области.Группировка.Шрифт,, Макс(12 - Выборка.Уровень(), 8), Ложь);
    Область.Области.Группировка.Шрифт = НовШрифт;
    ТекТаб.Вывести(Область, Выборка.Уровень());
    КонецЕсли;
    Если Не(Выборка.ТипЗаписи() = ТипЗаписиЗапроса.ДетальнаяЗапись) Тогда
    ВыводРезультатовЗапроса(ТекТаб, ТекМакет, Выборка, СписокПериодов);
    КонецЕсли;
    
    КонецЦикла; 
    КонецПроцедуры 
    
    Процедура КнопкаВыполнитьНажатие(Кнопка)
    Запрос =  Новый Запрос;
    
    СписокПериодов = Новый СписокЗначений;
    СписокПериодов.Добавить(1, "Январь");
    СписокПериодов.Добавить(2, "Февраль");
    СписокПериодов.Добавить(3, "Март");
    СписокПериодов.Добавить(4, "Апрель");
    СписокПериодов.Добавить(5, "Май");
    СписокПериодов.Добавить(6, "Июнь");
    СписокПериодов.Добавить(7, "Июль");
    СписокПериодов.Добавить(8, "Август");
    СписокПериодов.Добавить(9, "Сентябрь");
    СписокПериодов.Добавить(10, "Октябрь");
    СписокПериодов.Добавить(11, "Ноябрь");
    СписокПериодов.Добавить(12, "Декабрь");
    
    
    
    Запрос.УстановитьПараметр("НачПериода",	НачалоДня(НачПериода));
    Запрос.УстановитьПараметр("КонПериода",	КонецДня(КонПериода));
    
    Если ОтборОрганизация Тогда
    Запрос.УстановитьПараметр("ВыбОрганизация",	ОрганизацияНаименование);
    КонецЕсли;
    
    Если ОтборМенеджер Тогда
    Запрос.УстановитьПараметр("ВыбМенеджер",	МенеджерНаименование);
    КонецЕсли;
    Запрос.Текст	= "
    | ВЫБРАТЬ
    | ВзаиморасчетыСПокупателямиОстаткиИОбороты.Сделка.Менеджер КАК Менеджер,
    | ВзаиморасчетыСПокупателямиОстаткиИОбороты.Сделка.Контрагент КАК Контрагент,
    | ВзаиморасчетыСПокупателямиОстаткиИОбороты.Сделка.КоличествоДокумента КАК Отгрузка,
    | ВзаиморасчетыСПокупателямиОстаткиИОбороты.СуммаОборот КАК Сумма,
    | МЕСЯЦ(ВзаиморасчетыСПокупателямиОстаткиИОбороты.Период) КАК ВыбМесяц
    | ИЗ
    | РегистрНакопления.ВзаиморасчетыСПокупателями.ОстаткиИОбороты(&НачПериода, &КонПериода, Месяц, , ) КАК ВзаиморасчетыСПокупателямиОстаткиИОбороты
    | ИТОГИ
    | СУММА(Отгрузка),
    | СУММА(Сумма)
    | ПО
    | ОБЩИЕ,
    | Менеджер,
    |ВыбМесяц,
    | Контрагент";
    
    Выборка = Запрос.Выполнить().Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
    Если Выборка.Количество() = 0 Тогда Возврат; КонецЕсли;
    Выборка.Сбросить(); Выборка.Следующий();
    таб	= ЭлементыФормы.ПолеОтчета;
    Макет = ПолучитьМакет("Отчет");
    Область = Макет.ПолучитьОбласть("Заголовок");
    таб.Вывести(Область);
    Область = Макет.ПолучитьОбласть("Шапка");
    таб.Вывести(Область);
    
    Таб.НачатьАвтогруппировкуСтрок();
    ВыводРезультатовЗапроса(Таб, Макет, Выборка, СписокПериодов);
    Таб.ЗакончитьАвтогруппировкуСтрок();
    
    ОбластьПоле = Макет.ПолучитьОбласть("Строка | Месяц");
    Для каждого ВыбПериод Из СписокПериодов Цикл
    ОбластьПоле.Параметры.Заполнить(Выборка);
    Таб.Присоединить(ОбластьПоле);
    КонецЦикла;
    
    КонецПроцедуры
    
    Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
    НачПериода = НачалоМесяца(ТекущаяДата());
    КонПериода = КонецМесяца(ТекущаяДата());
    КонецПроцедуры
    
    
  20. LordKim
    Offline

    LordKim Опытный в 1С

    Регистрация:
    11 мар 2008
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    В этом случае у вас поле Период по идее уже равняется месяцу.
    Попробуйте выбрать просто
    |ВзаиморасчетыСПокупателямиОстаткиИОбороты.Период КАК ВыбМесяц

    Или сделать детализацию по Записи, так:
    РегистрНакопления.ВзаиморасчетыСПокупателями.ОстаткиИОбороты(&НачПериода, &КонПериода, Запись, , ) КАК

Поделиться этой страницей