7.7 Отчет по конкретному документу

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем andrey-ekt78, 25 авг 2014.

  1. TopicStarter Overlay
    andrey-ekt78
    Offline

    andrey-ekt78

    Регистрация:
    6 авг 2014
    Сообщения:
    21
    Симпатии:
    0
    Баллы:
    1
    Добрый день! Подскажите пожалуйста как сделать отчет куда будут попадать все документы конкретного вида за выбранный период для выбранной фирмы?
    Пробовал
    Код:
    Док = СоздатьОбъект("Документ.ПутевойЛист");
    Док.ВыбратьПоЗначению(ДатаНачала,ДатаКонца,"Фирма",     ВыбФирма);
    но так не получается т.к. Документ не должен быть конкретного вида
  2. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.443
    Симпатии:
    375
    Баллы:
    104
    Запросом? примерно так, конструктором делается на раз
    Код:
    Процедура Сформировать()
        Перем Запрос, ТекстЗапроса, Таб;
        //Создание объекта типа Запрос
        Запрос = СоздатьОбъект("Запрос");
        ТекстЗапроса =
        "//{{ЗАПРОС(Сформировать)
        |Период с ВыбНачПериода по ВыбКонПериода;
        |Докс = Документ.ПриходнаяНакладная.ТекущийДокумент;
        |Клиент = Документ.ПриходнаяНакладная.Клиент;
        |Фирма = Документ.ПриходнаяНакладная.Фирма;
        | //вписать здесь нужное вам по коду//
        |Группировка Докс;
        |Условие(Фирма = ВыбФирма);
        |Условие(Клиент = ВыбКлиент);
        |"//}}ЗАПРОС
        ;
        // Если ошибка в запросе, то выход из процедуры
        Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
            Возврат;
        КонецЕсли;
    
        // Подготовка к заполнению выходных форм данными запроса
        Таб = СоздатьОбъект("Таблица");
        Таб.ИсходнаяТаблица("Сформировать");
        // Заполнение полей "Заголовок"
        Таб.ВывестиСекцию("Заголовок");
        Состояние("Заполнение выходной таблицы...");
        Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
        Пока Запрос.Группировка(1) = 1 Цикл
            // Заполнение полей Докс
            Таб.ВывестиСекцию("Докс");
        КонецЦикла;
        // Заполнение полей "Итого"
        Таб.ВывестиСекцию("Итого");
        // Вывод заполненной формы
        Таб.ТолькоПросмотр(1);
        Таб.Показать("Сформировать", "");
    КонецПроцедуры
  3. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    для первого варианта
    создатьобъект("документ")
    если док.вид<>"Путевой лист" тогда
    продолжить
  4. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.443
    Симпатии:
    375
    Баллы:
    104
    не знаю, через запрос проще в данном случае
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Конкретизируйте задачу... Что хотите получить на выходе?
    з/ы через запрос мне тоже кажется удобнее и быстрее
Похожие темы
  1. gizi
    Ответов:
    0
    Просмотров:
    372
  2. rshakiro
    Ответов:
    9
    Просмотров:
    1.478
  3. new1
    Ответов:
    1
    Просмотров:
    410
  4. Ирина
    Ответов:
    11
    Просмотров:
    607
  5. BBDragon
    Ответов:
    0
    Просмотров:
    137
Загрузка...

Поделиться этой страницей