8.х Отчет о розничных продажах выдает ошибку

Тема в разделе "Установка платформы "1С:Предприятие 8"", создана пользователем tambovbelous, 15 авг 2012.

  1. TopicStarter Overlay
    tambovbelous
    Offline

    tambovbelous

    Регистрация:
    15 авг 2012
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте все.

    Столкнулся с такой проблемой: 1С УТ типовая на 8.1 работает со штриховским минипосом, уже года 3. Из минипоса выгружается файлик в конце смены, так вот при загрузке этого файлика создается док ОтчетОРозничныхПродажах. Загружается он верно открывается этот док все отлично. Но вот когда док этот хочу записать или провести выдается ошибка: "Ошибка при вызове метода контекста (ЭтоНовый): Документ не выбран". Подскажите как с этим бороться. (Базу тестил по всякому). Ошибка из общего модуля РаботаСДиалогами выпадает:
    Код:
    Процедура УстановитьЗаголовокФормыДокумента(СтрокаВидаОперации = "", ДокументОбъект, ФормаДокумента) Экспорт
    ФормаДокумента.АвтоЗаголовок = Ложь; // заголовок будем писать сами
    Если ПустаяСтрока(СтрокаВидаОперации) Тогда
    Заголовок = ДокументОбъект.Метаданные().Синоним + ": ";
    Иначе
    Заголовок = ДокументОбъект.Метаданные().Синоним + ": " + СтрокаВидаОперации + ". ";
    КонецЕсли;
    Если ДокументОбъект.ЭтоНовый() Тогда //////////////////////////////////////////////////////////// Ошибка здесь!!!!!!!!!!!!!!!!!!
    Заголовок = Заголовок + "Новый";
    Иначе
    Если ДокументОбъект.Проведен Тогда
    Заголовок = Заголовок + "Проведен";
    ИначеЕсли ДокументОбъект.Метаданные().Проведение = Метаданные.СвойстваОбъектов.Проведение.Разрешить Тогда
    Заголовок = Заголовок + "Не проведен";
    Иначе
    Заголовок = Заголовок + "Записан";
    КонецЕсли;
    КонецЕсли;
    ФормаДокумента.Заголовок = Заголовок;
    КонецПроцедуры // УстановитьЗаголовокФормыДокумента()
    Заранее спасибо всем кто откликнится...
  2. TopicStarter Overlay
    tambovbelous
    Offline

    tambovbelous

    Регистрация:
    15 авг 2012
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Ну скажите хоть что-нть, уже все перепробовал, нужна свежая идея
  3. n.s.gnedash
    Offline

    n.s.gnedash Опытный в 1С Команда форума

    Регистрация:
    15 авг 2010
    Сообщения:
    1.358
    Симпатии:
    5
    Баллы:
    29
    Отладчиком нужно смотреть,что делается в обработке проведения, либо в процедуре при\перед записью
  4. TopicStarter Overlay
    tambovbelous
    Offline

    tambovbelous

    Регистрация:
    15 авг 2012
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    В отладчике у "ДокументОбект" пустое значение с типом ДокументОбект.ОтчетОРозничных продажах.
    форма документа висит, но в базу сам док не сохраняется. Практически все элементы формы документа
    при нажатии выдают ошибку "Документ не выбран"
  5. Yuriy_Alexandrovich
    Offline

    Yuriy_Alexandrovich Профессионал в 1С Команда форума

    Регистрация:
    15 сен 2011
    Сообщения:
    1.275
    Симпатии:
    76
    Баллы:
    54
    Код создания документа покажи, и файлик загрузки, вероятно не правильно получает GUID (Это догадка, как такое может быть х.з.)
  6. TopicStarter Overlay
    tambovbelous
    Offline

    tambovbelous

    Регистрация:
    15 авг 2012
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Блин, тут оказалось так: скопировал себе на ноут 1Cv8.1CD из каталога базы, запустил, ииииииииииииииииии все работает, а не работает именно на том компе где база хранится фактически. и вот что это!? - Винда,вирусы, может НЛО..... платформу чтоли переустановить. Бред какой-то.
    Как это может быть связано с компом???
  7. Yuriy_Alexandrovich
    Offline

    Yuriy_Alexandrovich Профессионал в 1С Команда форума

    Регистрация:
    15 сен 2011
    Сообщения:
    1.275
    Симпатии:
    76
    Баллы:
    54
    Сразу почему то пришло в голову о файлах 1С т.н. "Кэш"
    файлы в
    попробуй удалить папки с длинным наименованием ввиде набора цифр и букв , на той машине где возникает проблема
  8. TopicStarter Overlay
    tambovbelous
    Offline

    tambovbelous

    Регистрация:
    15 авг 2012
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Все решилось переименованием ПК и Созданием нового пользователя
  9. kotlovD
    Offline

    kotlovD Опытный в 1С

    Регистрация:
    16 фев 2011
    Сообщения:
    718
    Симпатии:
    0
    Баллы:
    26

Поделиться этой страницей