7.7 Отчет на основании журнала

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем volchokt, 10 июн 2010.

  1. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Код:
    Процедура обработкаПроведения()
    //создадим объект
    Пер=СоздатьОбъект("Периодический"); 
    //определим 
    Пер.ИспользоватьОбъект(Наименование,"Состояние");
    //обратный порядок выборки
    Пер.ОбратныйПорядок(1);
    Пер.ВыбратьЗначения();
    ПоследняяДата=Дата(1980,1,1);
    Состояние=Перечисление.ВНаличииИНарука.ВНаличии; //тут смотрите как у вас названо
    Если Пер.ПолучитьЗначение()=1 Тогда
    ПоследняяДата=Пер.ДатаЗнач;
    Состояние=Пер.Значение;
    КонецЕсли;
    
    Если ПоследняяДата>ДатаДок Тогда
    Сообщить("Дата документа не может быть раньше "+ПоследняяДата);
    СтатусВозврата(0);
    Возврат;
    КонецЕсли;
    
    Если Состояние=Перечисление.ВНаличииИНарука.ВНаличии Тогда
    УстановитьРеквизитСправочника(Наименование,"Состояние",Перечисление.Вналичиинаруках.НаРуках,ДатаДок);
    Иначе
    УстановитьРеквизитСправочника(Наименование,"Состояние",Перечисление.Вналичиинаруках.ВНаличии,ДатаДок);
    КонецЕсли;
    КонецПроцедуры
    
    
  2. TopicStarter Overlay
    volchokt
    Offline

    volchokt

    Регистрация:
    10 июн 2010
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Буду вникать... А почему вы в тексте программы объявляете объект периодическим? Например при создании справочника ведь можно поставить в реквизите галку периодичный? Это принципиально?
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Я определяю объект для того чтобы потом использовать его свойства))))) Научитесь - поймете.....
  4. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    В 1Ске самое главное начать отличать сами объекты от ссылок на них.
    Остальное будет уже не сложно.
  5. TopicStarter Overlay
    volchokt
    Offline

    volchokt

    Регистрация:
    10 июн 2010
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Ну еще надо знать как реализовать свои мечты на практике, какие процедуры и функции использовать..... :smile: Почему я не робот, вставил себе флешку, перекинул информацию и все, ты - ГЕНИЙ!!!! :unsure:
  6. TopicStarter Overlay
    volchokt
    Offline

    volchokt

    Регистрация:
    10 июн 2010
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    А такой вопрос... в форме документа ведь тоже нужно прописывать выбор реквизита
  7. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Разумеется... Вы завели реквизит (думаю правильнее в табличной части т.к. книг абонент может взять несколько)... Добавьте табличную часть на форму. Затем в свойствах строки табличной части сделайте вызов процедуры котору я вам привел в модуле проведения (необходима проверка даты документа). А то что статус у них разный - это нормально. Абонент мог сдать и тут же взять новые книги.... Получилось совсем "шоколадно" - все одним документом сделали

Поделиться этой страницей