8.х Отчет, ячейка, среднее арифметическое

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Hakuei, 19 дек 2006.

  1. TopicStarter Overlay
    Hakuei
    Offline

    Hakuei

    Регистрация:
    19 дек 2006
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Здраствуйте... Мне хотелось бы спросить, как сделать так, чтобы в отчете итогом выводилось среднее арифметичекское (средний балл студентов). Что нужно дописать в модуле и в таблице, чтобы по оценкам выводилось среднее арифметическое?

    Модуль отчета:


    Процедура Сформировать()
    Перем Т;
    Перем Ту;
    Т=СоздатьОбъект("Таблица");
    Ту=СоздатьОбъект("Документ");
    Т.ВывестиСекцию("Секция_1");
    Т.ВывестиСекцию("Секция_2");
    Ту.ВыбратьДокументы(ДатаНачало, ДатаКонец);
    Пока Ту.ПолучитьДокумент()=1 Цикл
    Если Ту.Предмет = Предмет Тогда
    Т.ВывестиСекцию("Секция_3");
    КонецЕсли;
    КонецЦикла;

    Т.ТолькоПросмотр(1);
    Т.Показать()
    КонецПроцедуры

    Таблица
    http://img265.imageshack.us/img265/4519/11111111lp6.jpg

Поделиться этой страницей