7.7 Отчет Движение кадров

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем LedyOwl, 9 апр 2008.

  1. TopicStarter Overlay
    LedyOwl
    Offline

    LedyOwl

    Регистрация:
    25 июл 2007
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1
    При формировании отчета по движению кадров создаются три таблицы. Одна из них список принятых на работу. В ней есть поле Сотрудник и Дата. Мне нужно добавить еще две колонки: подразделение и должность. Подскажите пожалуйста как правильнее это сделать.

    Возможно понадобится вот эта часть кода:
    Код:
    Если (ПустоеЗначение(ТаблицаРеквизитов.СостояниеФизлица) = 1) и (ПустоеЗначение(ТаблицаРеквизитов.Документ) = 0) Тогда
    Если ТаблицаРеквизитов.Документ.Вид() = "ПриказОбУвольнении" Тогда
    ДатаУв = ТаблицаРеквизитов.Документ.ДатаУвольнения; 
    Если (ДатаУв >= НачДата) и (ДатаУв <= КонДата) Тогда
    СписокУволенных.ДобавитьЗначение(Сотрудник,);  
    Номер_У=Номер_у +1;  
    ТабУволенных.ВывестиСекцию("Строка"); 
    КонецЕсли;   
    КонецЕсли;
    ИначеЕсли (ПустоеЗначение(ТаблицаРеквизитов.СостояниеФизлица) = 0) 
    и (ТаблицаРеквизитов.СостояниеФизлица <> Перечисление.СостояниеФизлица.ВременноНеРаботает) 
    и (ПустоеЗначение(ТаблицаРеквизитов.Документ) = 0)   тогда
    Если ТаблицаРеквизитов.Документ.Вид() = "ПриказОПриемеНаРаботу" Тогда
    ДатаПриема = ТаблицаРеквизитов.Документ.ДатаПриема;
    
    Если (ДатаПриема >= НачДата) и (ДатаПриема <= КонДата) Тогда
    СписокПринятых.ДобавитьЗначение(Сотрудник,);
    
    Номер_П=Номер_П+1; 
    ТабПринятых.ВывестиСекцию("Строка");
    ТабПринятых.ПрисоединитьСекцию("Должность|Строка");
    КонецЕсли; 
    КонецЕсли; 
    КонецЕсли;
    
    
  2. Gucci76
    Offline

    Gucci76 Опытный в 1С

    Регистрация:
    9 мар 2008
    Сообщения:
    67
    Симпатии:
    0
    Баллы:
    26
    Таблицы создаются на какую-то дату?
    Тогда просто в таблице Сотрудник.Должность.Получить(ДатаАктуальности)
    Также для подразделения

Поделиться этой страницей