8.х Отчет Диаграмма начислений

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем Arnold9131, 11 май 2013.

  1. TopicStarter Overlay
    Arnold9131
    Offline

    Arnold9131

    Регистрация:
    11 май 2013
    Сообщения:
    30
    Симпатии:
    0
    Баллы:
    1
    Создаю отчет Диаграмма Ганта в модуле формы пишу


    Код:
    
    &НаКлиенте
    Процедура Сформировать(Команда)
    СформироватьНаСервере(Диаграмма);
    КонецПроцедуры
    
    &НаСервереБезКонтекста
    Процедура СформироватьНаСервере(ДГ)
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    | НачисленияСотрудникамФактическийПериодДействия.Сотрудник,
    | НачисленияСотрудникамФактическийПериодДействия.ВидРасчета,
    | НачисленияСотрудникамФактическийПериодДействия.ПериодДействияНачало,
    | НачисленияСотрудникамФактическийПериодДействия.ПериодДействияКонец
    |ИЗ
    | РегистрРасчета.НачисленияСотрудникам.ФактическийПериодДействия КАК НачисленияСотрудникамФактическийПериодДействия";
    
    Результат = Запрос.Выполнить();
    
    ВыборкаДетальныеЗаписи = Результат.Выбрать();
    ДГ.Обновление = Ложь;
    ДГ.Очистить();
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
    Точка = ДГ.УстановитьТочку(ВыборкаДетальныеЗаписи.Сотрудник);
    Серия = ДГ.УстановитьТочку(ВыборкаДетальныеЗаписи.ВидРасчета);
    Значение = ДГ.ПолучитьЗначение(Точка, Серия);
    
    Интервал = Значение.Добавить();
    
    Интервал.Начало = ВыборкаДетальныеЗаписи.ПериодДействияНачалоы;
    Интервал.Конец = ВыборкаДетальныеЗаписи.ПериодДействияКонец;
    КонецЦикла;
    ДГ.Обновление = Истина;
    
    КонецПроцедуры
    
    
    
  2. TopicStarter Overlay
    Arnold9131
    Offline

    Arnold9131

    Регистрация:
    11 май 2013
    Сообщения:
    30
    Симпатии:
    0
    Баллы:
    1
    Выдает вот эту ошибку

    {Отчет.ДиаграммаНачислений.Форма.ФормаОтчета.Форма(27)}: Ошибка при вызове метода контекста (ПолучитьЗначение)
    Значение = ДГ.ПолучитьЗначение(Точка, Серия);
    по причине:
    Недопустимое значение параметра (параметр номер '2')
  3. Mitriy
    Offline

    Mitriy Опытный в 1С

    Регистрация:
    20 авг 2012
    Сообщения:
    48
    Симпатии:
    0
    Баллы:
    26
    измени Серия = ДГ.УстановитьТочку(ВыборкаДетальныеЗаписи.ВидРасчета) на Серия = ДГ.УстановитьСерию(ВыборкаДетальныеЗаписи.ВидРасчета)
    а заодно и ы убери в конце Интервал.Начало = ВыборкаДетальныеЗаписи.ПериодДействияНачалоы
  4. TopicStarter Overlay
    Arnold9131
    Offline

    Arnold9131

    Регистрация:
    11 май 2013
    Сообщения:
    30
    Симпатии:
    0
    Баллы:
    1

    спасибо

Поделиться этой страницей