8.х Отбор

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем deaf, 11 июн 2007.

  1. TopicStarter Overlay
    deaf
    Offline

    deaf

    Регистрация:
    11 июн 2007
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    B) Помогите мне разобраться с отбором в справочнике (хочу чтоб одна группа и её элементы, а не остальные - типа "ВСпискеПоИеархии")... Получается тогда, когда при событии "НачалоВыбора", но мне нужно именно в справочнике.. Есть такая возможность когда ПриОткрытии - отбор вСпискеПоИерархии..?
    :D

    Помогите!!!

    :unsure:
  2. TopicStarter Overlay
    deaf
    Offline

    deaf

    Регистрация:
    11 июн 2007
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Код:
    Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    Спр = Справочники.Номенклатура.НайтиПоНаименованию("Услуги");
    Список.Отбор.Наименование.ВидСравнения = ВидСравнения.ВСпискеПоИерархии;
    Список.Отбор.Наименование.Значение.Добавить(Спр);
    Список.Отбор.Наименование.Использование=Истина;
    КонецПроцедуры
    
    
    B) :unsure: Ошибка из за ....ВСпискеПоИерархии.. Как по другому?
  3. TopicStarter Overlay
    deaf
    Offline

    deaf

    Регистрация:
    11 июн 2007
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Код:
    Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    Спр = Справочники.Номенклатура.НайтиПоНаименованию("Услуги");
    ЭлементыФормы.Дерево.ТекущаяСтрока = Спр;
    ЭлементыФормы.Дерево.Видимость = ложь;
    Дерево.Отбор.ЭтоГруппа.ВидСравнения = ВидСравнения.Равно;
    Дерево.Отбор.ЭтоГруппа.Использование = Истина;
    КонецПроцедуры
    
    Процедура СписокПриАктивизацииСтроки(Отказ,Элемент)
    Спр = Справочники.Номенклатура.НайтиПоНаименованию("Услуги");
    Если ЭлементыФормы.Список.ТекущаяСтрока = Спр Тогда
    ЭлементыФормы.Список.ТекущийРодитель = Спр;
    Отказ = ложь;
    Иначе    
    ЭлементыФормы.Дерево.ТекущаяСтрока = ЭлементыФормы.Список.ТекущийРодитель;
    Отказ = Истина;
    КонецЕсли;    
    КонецПроцедуры
    
    
    :unsure: Получилось!!!!

    Сам разобрался!!!

Поделиться этой страницей