8.х Отбор списка на форме СКД по реквизиту

Тема в разделе "Система компоновки данных (СКД)", создана пользователем Isupovalex, 27 май 2015.

  1. TopicStarter Overlay
    Isupovalex
    Offline

    Isupovalex

    Регистрация:
    23 апр 2015
    Сообщения:
    31
    Симпатии:
    0
    Баллы:
    1
    Доброе время суток, прошу помощи в одном деле. В отчете, в отборе есть реквизит, тип булево, по которому можно отсортировать список. На форме создал галочку, которая будет соответствовать изменению этого значения при построении отчета. С датами у меня получилось, а вот с этим реквизитов нет(.


    Процедура НачПериодаПриИзменении(Элемент)
    НД = КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("Дата1");
    Нд.Использование = Истина;
    НД.Значение = НачПериода;

    КонецПроцедуры

    Процедура КонПериодаПриИзменении(Элемент)
    КД = КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("Дата2");
    КД.Использование = Истина;
    Кд.Значение = КонПериода;

    КонецПроцедуры


    Процедура НеАктуальныеПриИзменении(Элемент)
    Актуальность = КомпоновщикНастроек.Настройки.отбор.Элементы.
    Если неактуальные тогда
    Актуальность = НеАктуальные
    Иначе Актуальность = ложь
    КонецЕсли;


    КонецПроцедуры
  2. Николаич87
    Offline

    Николаич87 Опытный в 1С

    Регистрация:
    1 апр 2015
    Сообщения:
    122
    Симпатии:
    4
    Баллы:
    29
    последняя процедура у вас нерабочая или вы не полностью скопировали код.
    исходя из того, что есть - элементам отбора вы пытаетесь присвоить тип булево - это точно не будет работать

Поделиться этой страницей