8.х Отбор с панелями в Журнале документов

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Vozdyh, 17 дек 2012.

  1. TopicStarter Overlay
    Vozdyh
    Offline

    Vozdyh

    Регистрация:
    17 дек 2012
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте
    Подскажите пожалуйста, где ошибся?
    Нужно в Журнале Документов добавить сортировку с панелями : "Не проведенные", "Проведенные", "Все"

    Работает с такой процедурой:


    Код:
    Процедура Панель1ПриСменеСтраницы(Элемент, ТекущаяСтраница)
    Если ТекущаяСтраница = 0 тогда
    Отбор.Проведен.Использование=Истина;
    ИначеЕсли ТекущаяСтраница = 1 тогда
    Отбор.Проведен.Использование=Истина;
    Отбор.Проведен.Значение=Истина;
    ИначеЕсли ТекущаяСтраница = 2 тогда
    Отбор.Проведен.Использование=Ложь;
    Отбор.Проведен.Значение=Истина;
    КонецЕсли;
    КонецПроцедуры
    Но при закрытии формы "ФормаСписок" в "Журнале Документов" и при повторном открытии не сохраняется настройка периода.

    При такой процедуре все работает: (В Журнале Документов панели в таком порядке : , "Все", "Проведенные", "Не проведенные" )


    Код:
    Процедура Панель1ПриСменеСтраницы(Элемент, ТекущаяСтраница)
    Если ТекущаяСтраница = 1 тогда
    Отбор.Проведен.Использование = Истина;
    Отбор.Проведен.Значение = Истина;
    ИначеЕсли ТекущаяСтраница = 2 тогда
    Отбор.Проведен.Использование = Истина;
    Отбор.Проведен.Значение = Ложь;
    ИначеЕсли ТекущаяСтраница = 0 тогда
    Отбор.Проведен.Использование = Ложь;
    КонецЕсли;
    КонецПроцедуры
    С логикой видимо напутал или с "объектами" панели?
  2. TopicStarter Overlay
    Vozdyh
    Offline

    Vozdyh

    Регистрация:
    17 дек 2012
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Уважаемые!
    Не могли бы Вы пожалуйста прокомментировать - отправить меня в "стол заказов" или просто объяснить, что у меня глупый вопрос или в этом духе?
    Спасибо!

Поделиться этой страницей