8.х Отбор по настройкам пользователя

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Ольгусик, 7 дек 2010.

  1. TopicStarter Overlay
    Ольгусик
    Offline

    Ольгусик Опытный в 1С Команда форума

    Регистрация:
    4 фев 2010
    Сообщения:
    646
    Симпатии:
    3
    Баллы:
    29
    Задача следующая. В форме списка документа при открытии нужно установить отбор по подразделению. Подразделение, которое указано в качестве основного в настройках пользователя. Но нужно сделать так, чтобы пользователь не мог сам отключить этот отбор. Заранее спасибо.
  2. BVB_berserk
    Offline

    BVB_berserk Опытный в 1С

    Регистрация:
    30 янв 2009
    Сообщения:
    162
    Симпатии:
    0
    Баллы:
    26
    Код:
    Процедура ОбновлениеОтображения()
    Если РольДоступна("Менеджер") Тогда
    ПодразделениеПользователя  = УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(глЗначениеПеременной("глТекущийПользователь"), "Подразделение");
    
    ОтборПодразделение = ЭтаФорма.ДокументСписок.Отбор;
    Если ОтборПодразделение .Найти("Подразделение") = Неопределено Тогда
    ОтборПодразделение .Добавить("Подразделение");
    КонецЕсли;
    ОтборПодразделение ["Подразделение"].Использование = Истина;
    ОтборПодразделение ["Подразделение"].ВидСравнения = ВидСравнения.Равно;
    ОтборПодразделение ["Подразделение"].Значение = ПодразделениеПользователя;
    
    КонецЕсли;    
    
    КонецПроцедуры 
    
    
    Что-то в таком духе. Обработчик события в форме списка - обновление отображения. Общий модуль "УправлениеПользователями" есть в моей древней УТ. В других конфах или даже в новой УТ может быть по-другому.
  3. TopicStarter Overlay
    Ольгусик
    Offline

    Ольгусик Опытный в 1С Команда форума

    Регистрация:
    4 фев 2010
    Сообщения:
    646
    Симпатии:
    3
    Баллы:
    29
    Нашла свою ошибку. Примерно так делала. Только основное подразделение ставила. Спасибо большое
  4. TopicStarter Overlay
    Ольгусик
    Offline

    Ольгусик Опытный в 1С Команда форума

    Регистрация:
    4 фев 2010
    Сообщения:
    646
    Симпатии:
    3
    Баллы:
    29
    Рано обрадовалась. Выходит ошибка
    ОбщийМодуль.УправлениеПользователями(46)}: Поле объекта не обнаружено (Подразделение)
    НастройкаСсылка = ПланыВидовХарактеристик.НастройкиПользователей[Настройка];
  5. TopicStarter Overlay
    Ольгусик
    Offline

    Ольгусик Опытный в 1С Команда форума

    Регистрация:
    4 фев 2010
    Сообщения:
    646
    Симпатии:
    3
    Баллы:
    29
    "ОсновноеПодразделениеОрганизации", конечно же.
    Спасибо еще раз. Все работает

Поделиться этой страницей