8.х Отбор и сортировка, операции по отобранному

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем Tihonidy, 4 дек 2015.

  1. TopicStarter Overlay
    Tihonidy
    Offline

    Tihonidy

    Регистрация:
    27 фев 2014
    Сообщения:
    13
    Симпатии:
    0
    Баллы:
    1
    В любой конфигурации на панели задач списка справочника, документов имеются кнопки "Отбор и сортировка", "Отбор по значению в текущей колонке" и т.д.
    В обработке ТЗ выгружается в ТЧ. Например, ТЧ заполняется накладными на разных контрагентов, по разным складам за определенный период. Колонки: Документ, Контрагент, Склад. Жмем "Распечатать накладные". Распечатываются все накладные из ТЧ. Как сделать так, чтобы при применении отбора по складу или 2-м складам (кнопка на панели задач " Отбор и сортировка") распечатывались только отобранные документы? Если это, конечно, возможно.
  2. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.548
    Симпатии:
    716
    Баллы:
    204
    Необходимо обрабатывать не ТЧ как реквизит объекта, а ЭлементыФормы.ТЧ - это если речь идет про обычные формы.
  3. TopicStarter Overlay
    Tihonidy
    Offline

    Tihonidy

    Регистрация:
    27 фев 2014
    Сообщения:
    13
    Симпатии:
    0
    Баллы:
    1
    Да, это обычная форма. Что-то не получается. Распечатываются все документы из ТЧ.

    Вложения:

    • Форма.png
      Форма.png
      Размер файла:
      10,1 КБ
      Просмотров:
      1
    • модуль.txt
      Размер файла:
      7,6 КБ
      Просмотров:
      2
  4. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.548
    Симпатии:
    716
    Баллы:
    204
    Либо:

    Код:
    Для Индекс = 0 По Накладные.Количество() - 1 Цикл
    
    Если ЭлементыФормы.Накладные.ПроверитьСтроку(Накладные.Получить(Индекс)) Тогда
    
    КонецЕсли;
    
    КонецЦикла;
    либо, если значения примитивного типа/одно значение:

    Код:
    Отбор = Новый Структура;
    Для Каждого ЭлОтбора ИЗ Элементыформы.Накладные.ОтборСтрок Цикл
    Отбор.Вставить(ЭлОтбора.ПутьКДанным, ЭлОтбора.Значение);
    КонецЦикла
    
    КопияТЧ = Накладные.Выгрузить(Отбор);

Поделиться этой страницей