7.7 ОстаткиТМЦ

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем larry, 14 мар 2008.

  1. TopicStarter Overlay
    larry
    Offline

    larry

    Регистрация:
    14 мар 2008
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Хочу получить цену функцией:
    Код:
     
    Функция ПолучитьЦену(Наим, КакаяИБ)
    Перем ЦенаЦены, ЕдЦены;
    Если КакаяИБ = "ИП" Тогда
    СпрНом = v7c.CreateObject("Справочник.Номенклатура");
    СпрЦен = v7c.CreateObject("Справочник.ТипыЦен");
    ИначеЕсли КакаяИБ = "ТХМ" Тогда
    СпрНом = v7h.CreateObject("Справочник.Номенклатура");
    СпрЦен = v7c.CreateObject("Справочник.ТипыЦен");
    Иначе
    Возврат 0;			    
    КонецЕсли;
    Если СпрНом.НайтиПоНаименованию(Наим,,)=1 Тогда
    Номенклатур = СпрНом.ТекущийЭлемент();
    Иначе
    Возврат 0;
    КонецЕсли;
    Если СпрЦен.НайтиПоНаименованию("Хорека(кафе)",,)=1 Тогда
    ВыбЦена = СпрЦен.ТекущийЭлемент();
    Иначе
    Возврат 0;
    КонецЕсли;
    Цена = "Розница";
    Если КакаяИБ = "ИП" Тогда
    СтрокаЦены = v7c.EvalExpr("ПолучитьЦенуOle('"+Наим+"','"+Цена+"')");
    ИначеЕсли КакаяИБ = "ТХМ" Тогда
    СтрокаЦены = v7h.EvalExpr("ПолучитьЦенуOle('"+Наим+"','"+Цена+"')");
    Иначе
    Возврат 0;			    
    КонецЕсли;
    Возврат СтрокаЦены;
    КонецФункции // ПолучитьЦену()    
    
    
    Что то не получается, помогите просканируйте своим опытным глазом я всю голову себе сломал уже.
    Все эти непонятные v7c,v7h это переменные в которые базы инициализируются в глобальном модуле конфиги
  2. Akulina
    Offline

    Akulina Опытный в 1С

    Регистрация:
    30 авг 2007
    Сообщения:
    87
    Симпатии:
    0
    Баллы:
    26
    Во-первых. Что не получается конкретно?
    Во-вторых. Вот в этом куске
    Код:
    ИначеЕсли КакаяИБ = "ТХМ" <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда		</span>
    СпрНом = v7h.CreateObject("Справочник.Номенклатура");
    СпрЦен = v7c.CreateObject("Справочник.ТипыЦен");
    
    по-моему вместо
    Код:
    СпрЦен = v7c.CreateObject("Справочник.ТипыЦен");
    
    должно быть
    Код:
    СпрЦен = v7h.CreateObject("Справочник.ТипыЦен");
    
    В-третьих. Как в глобальном модуле определяются v7h и v7c?

Поделиться этой страницей