7.7 Остатки

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Siddy, 8 ноя 2009.

  1. TopicStarter Overlay
    Siddy
    Offline

    Siddy Опытный в 1С

    Регистрация:
    18 мар 2009
    Сообщения:
    311
    Симпатии:
    0
    Баллы:
    26
    Ребят, подскажите, пожалуйста, каким способом можно получить остаток и резерв, имея строку с наименованием номенклатуры (т.е. имея переменную типа строка)? (ТиС)
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Сначала перебрать элементы справочника номенклатуры и найти элемент, соотвествующий искомой строке. Только потом выполнить запрос к регистрам
  3. Vlad
    Offline

    Vlad Модераторы Команда форума Модератор

    Регистрация:
    16 авг 2006
    Сообщения:
    3.517
    Симпатии:
    19
    Баллы:
    29
    А встроенные отчеты чем не устраивают?
  4. TopicStarter Overlay
    Siddy
    Offline

    Siddy Опытный в 1С

    Регистрация:
    18 мар 2009
    Сообщения:
    311
    Симпатии:
    0
    Баллы:
    26
    Поясните, пожалуйста.


    Не могу понять, как применить запрос на получение остатка и резерва относительно найденного элемента

    Код:
    Процедура ВернутьОстаток(ПолНаименование, Остаток, Резерв)
    Номенклатура = СоздатьОбъект("Справочник.Номенклатура");
    Номенклатура.ВыбратьЭлементы();
    Пока Номенклатура.ПолучитьЭлемент()=1 Цикл
    Если Номенклатура.Наименование<>ПолНаименование Тогда
    Продолжить;
    КонецЦикла;
    НайденныйЭлемент = Номенклатура.ТекущийЭлемент();  
    
    ТекстЗапроса =
    "
    |Номенклатура =  Регистр.ОстаткиТМЦ.Номенклатура,
    |                          Регистр.РезервыТМЦ.Номенклатура,
    |                          Регистр.Заказы.Номенклатура,
    |                          Регистр.ПартииОтданные.Номенклатура;
    |Количество     =  Регистр.ОстаткиТМЦ.Количество,
    |                          Регистр.ПартииОтданные.Количество;
    |Резерв            =  Регистр.РезервыТМЦ.Количество;";
    
    КонецПроцедуры
    
    
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Вот так....
    Функция вернет 1 если нашла.
    В данном случае не учитывается ни склад ни фирма...

    Код:
    Функция ВернутьОстаток(ПолНаименование, Остаток, Резерв)
    Нашли=0;
    Номенклатура = СоздатьОбъект("Справочник.Номенклатура");
    Номенклатура.ВыбратьЭлементы();
    Пока Номенклатура.ПолучитьЭлемент()=1 Цикл
    Если Номенклатура.ЭтоГруппа()=1 Тогда
    Продолжить;
    КонецЕсли;
    Если Номенклатура.Наименование=ПолНаименование Тогда
    Нашли=1;
    Прервать;
    КонецЕсли;
    КонецЦикла;
    Если Нашли=0 Тогда
    Возврат 0;
    КонецЕсли; 
    
    Остаок= Регистр.Остаток.СводныйОстаток(,, Номенклатура.ТекущийЭлемент(),, "Количество");
    Резерв= Регистр.РезервыТМЦ.СводныйОстаток(,, Номенклатура.ТекущийЭлемент(),,, "Количество");
    Возврат 1;
    КонецФункции
    
    
Похожие темы
  1. xxx949
    Ответов:
    4
    Просмотров:
    415
  2. xxx949
    Ответов:
    2
    Просмотров:
    304
Загрузка...

Поделиться этой страницей