8.х Остатки Товаров на складе!

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем MevMix, 19 май 2011.

  1. TopicStarter Overlay
    MevMix
    Offline

    MevMix Опытный в 1С

    Регистрация:
    21 фев 2011
    Сообщения:
    51
    Симпатии:
    0
    Баллы:
    26
    Добрый день!!!!
    В 1С программирую совсем недавно, надеюсь что поможете решить вопрос!!!!!

    Я создаю обработку, в которой хотел бы отобразить номенклатуру и ее остатки на складе

    Регистр Накопления "ОстаиТоваров"
    Справочник "Номенклатура"

    В табличном поле к номенклатуре добавляю колонку "количество"

    Какой должен быть запрос, чтоб отобразить количество

    Но у меня складов несколько
    Если не привязываться к складу, то она покажет общее количество.
    В принципе этого будет достаточно.

    Конфиг самописанный, не типовой.
  2. Dmitriy_76
    Offline

    Dmitriy_76 Опытный в 1С Команда форума

    Регистрация:
    26 мар 2011
    Сообщения:
    2.175
    Симпатии:
    13
    Баллы:
    29
    выбирай конструктор запросов..там все понятно
  3. TopicStarter Overlay
    MevMix
    Offline

    MevMix Опытный в 1С

    Регистрация:
    21 фев 2011
    Сообщения:
    51
    Симпатии:
    0
    Баллы:
    26
    при открытии обработки или при движении по строкам
    вешать запрос
  4. Dmitriy_76
    Offline

    Dmitriy_76 Опытный в 1С Команда форума

    Регистрация:
    26 мар 2011
    Сообщения:
    2.175
    Симпатии:
    13
    Баллы:
    29
    а ты где остатки хочешь отобразить ?
  5. TopicStarter Overlay
    MevMix
    Offline

    MevMix Опытный в 1С

    Регистрация:
    21 фев 2011
    Сообщения:
    51
    Симпатии:
    0
    Баллы:
    26
    В обработке добавил на фору "Табличное поле", данные берет из справочника "Номенклатура"

    в Табличном поле добавил колонку "Количество", вот в нем и хочу отобразить
  6. Dmitriy_76
    Offline

    Dmitriy_76 Опытный в 1С Команда форума

    Регистрация:
    26 мар 2011
    Сообщения:
    2.175
    Симпатии:
    13
    Баллы:
    29
    Зачем данные из справочника ? ты же гоовришь у тебя есть регистр накопления...
    А заполнять твою табличку можно при открытии...либо кнопку на форму повесить для заполнения...
  7. TopicStarter Overlay
    MevMix
    Offline

    MevMix Опытный в 1С

    Регистрация:
    21 фев 2011
    Сообщения:
    51
    Симпатии:
    0
    Баллы:
    26
    Хорошо
    Можете подсказать как из регистра вывести остатки и саму номенклатуру
    Я новичок, так что мне еще сложновато.
  8. Dmitriy_76
    Offline

    Dmitriy_76 Опытный в 1С Команда форума

    Регистрация:
    26 мар 2011
    Сообщения:
    2.175
    Симпатии:
    13
    Баллы:
    29
    а запрос то написал ?
    Теперь обрабатывай запрос и добавляй в табличку свои данные....
    как пример :

    Запрос=Новый Запрос;
    Запрос.Текст= "ВЫБРАТЬ
    | ТоварыНаСкладахОстатки.Номенклатура,
    | ТоварыНаСкладахОстатки.КоличествоОстаток
    |ИЗ
    | РегистрНакопления.ТоварыНаСкладах.Остатки КАК ТоварыНаСкладахОстатки";
    Выборка=Запрос.Выполнить().Выбрать();
    Пока Выборка.Следующий() Цикл
    Стр=Таб.Добавить();
    Стр.Номенклатура=Выборка.Номенклатура;
    Стр.Остаток=Выборка.КоличествоОстаток;
    КонецЦикла;

    Таб - это твоя табличка на форме...у которой колонуи Номенклатура и Остаток.

    в запросе : ТоварыНаСкладахОстатки - это табличка остатков регистра накопления ТоварыНаСкладах... в нем Номенклатура -Измерение, Количество - ресурс ...
  9. TopicStarter Overlay
    MevMix
    Offline

    MevMix Опытный в 1С

    Регистрация:
    21 фев 2011
    Сообщения:
    51
    Симпатии:
    0
    Баллы:
    26


    Сделал вот такой запрос
    Код:
    Процедура ПриОткрытии()
    Запрос=Новый Запрос;
    Запрос.Текст=
    "ВЫБРАТЬ
    |	ОстаткиТоваровОстатки.Номенклатура,
    |	ОстаткиТоваровОстатки.КоличествоОстаток
    |ИЗ
    |	РегистрНакопления.ОстаткиТоваров.Остатки КАК ОстаткиТоваровОстатки";
    
    Выборка = Запрос.Выполнить().Выбрать();
    Пока Выборка.Следующий() Цикл 
    Стр = ТабличноеПоле1.Добавить();
    Стр.Номенклатура = Выборка.Номенклатура;
    Стр.Количество = Выборка.КоличествоОстаток;
    КонецЦикла;
    КонецПроцедуры;
    
    
    


    но ругается вот на это

    {Обработка.ОстаткиНоменклатурыНаСкладах.Форма.Форма(14)}: Поле объекта не обнаружено (Номенклатура)
    Стр.Номенклатура = Выборка.Номенклатура;
  10. TopicStarter Overlay
    MevMix
    Offline

    MevMix Опытный в 1С

    Регистрация:
    21 фев 2011
    Сообщения:
    51
    Симпатии:
    0
    Баллы:
    26
    Сам лохонулся поле в таблице не так назавал
  11. TopicStarter Overlay
    MevMix
    Offline

    MevMix Опытный в 1С

    Регистрация:
    21 фев 2011
    Сообщения:
    51
    Симпатии:
    0
    Баллы:
    26
    Теперь вопрос как это все в иерархии просматривать
    Оно выводить просто списком
  12. yzek
    Offline

    yzek Опытный в 1С

    Регистрация:
    13 окт 2010
    Сообщения:
    713
    Симпатии:
    0
    Баллы:
    26
    А для чего вы используете обработку, чем вам отчет не подходит?
  13. TopicStarter Overlay
    MevMix
    Offline

    MevMix Опытный в 1С

    Регистрация:
    21 фев 2011
    Сообщения:
    51
    Симпатии:
    0
    Баллы:
    26
    Хочу сделать в РеализацииТоваровИУслуг
    Подбор, сразу с остатком товара на складе

    Да и как есть в типовых конфигурациях рабочее место менеджера
  14. Dmitriy_76
    Offline

    Dmitriy_76 Опытный в 1С Команда форума

    Регистрация:
    26 мар 2011
    Сообщения:
    2.175
    Симпатии:
    13
    Баллы:
    29
    Так и посмотри как в типовых реализовано....
  15. TopicStarter Overlay
    MevMix
    Offline

    MevMix Опытный в 1С

    Регистрация:
    21 фев 2011
    Сообщения:
    51
    Симпатии:
    0
    Баллы:
    26
    к сожалению нет конфига типовой
  16. TopicStarter Overlay
    MevMix
    Offline

    MevMix Опытный в 1С

    Регистрация:
    21 фев 2011
    Сообщения:
    51
    Симпатии:
    0
    Баллы:
    26
    Кто нить может поделиться конфигом Управление торговлей 10.3
  17. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104
    [warn=Внимание!]
    Распространение ссылок на нелегальные версии программ на данном сайте запрещено!
    [/warn]

Поделиться этой страницей