8.х остатки для группы

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем Raideres, 12 апр 2016.

  1. TopicStarter Overlay
    Raideres
    Offline

    Raideres Опытный в 1С

    Регистрация:
    9 фев 2016
    Сообщения:
    200
    Симпатии:
    0
    Баллы:
    26
    Запрос3.Текст = "ВЫБРАТЬ
    | ТоварыНаСкладахОстаткиИОбороты.Склад КАК Склад,
    | ТоварыНаСкладахОстаткиИОбороты.Номенклатура КАК Номенклатура,
    | ТоварыНаСкладахОстаткиИОбороты.КоличествоКонечныйОстаток КАК КоличествоКонечныйОстаток
    |ИЗ
    | РегистрНакопления.ТоварыНаСкладах.ОстаткиИОбороты(
    | &ДатаНачала,
    | &ДатаКонца,
    | ,
    | ,
    | Номенклатура в (&Номенклатура)
    | И Склад = &Склад
    | ИЛИ Склад = &Склад1) КАК ТоварыНаСкладахОстаткиИОбороты
    |
    |УПОРЯДОЧИТЬ ПО
    | Склад,
    | Номенклатура,
    | КоличествоКонечныйОстаток
    |АВТОУПОРЯДОЧИВАНИЕ";

    ВыбСклад = справочники.Склады.НайтиПоКоду("000000006");
    ВыбСклад1 = справочники.Склады.НайтиПоКоду("000000680");

    выбДата = НачалоМесяца(ТекущаяДата());
    СледущийДень= КонецДня(выбДата) + 10;

    Запрос3.УстановитьПараметр("склад",ВыбСклад);
    Запрос3.УстановитьПараметр("склад1",ВыбСклад1);
    масНом = ТЧКузнецк.ВыгрузитьКолонку("Наименование");
    Запрос3.УстановитьПараметр("Номенклатура",масНом);
    Запрос3.УстановитьПараметр("ДатаНачала",выбДата);
    Запрос3.УстановитьПараметр("ДатаКонца",СледущийДень);
    ВыборкаОстатки = Запрос3.Выполнить().ВЫгрузить();




    ТЧ = Новдок.Остатки;
    для каждого стрВ из ТЧК цикл
    Если стрВ.Группа = истина тогда
    //********************************вот тут подскажите что поправить чтобы считало не для номенклатуры а для группы
    стр4 = ТЧ.Добавить();
    стр4.Наименование = стрВ.Наименование;


    Отборост = Новый Структура;
    Отборост.Вставить("Номенклатура",стрВ.Наименование);
    найдСтроки = ВыборкаОстатки.НайтиСтроки(Отборост);
    Для каждого стрОст из найдСтроки Цикл
    стр4.ТекущийДень = стрОст.КоличествоКонечныйОстаток;
    стр4.СледМесяц = стрОст.КоличествоКонечныйОстаток;

    КонецЦикла;
    //ОбработкаПрерыванияПользователя();

    Иначе
    стр4 = ТЧ.Добавить();
    стр4.Наименование = СТрВ.Наименование;


    Отборост = Новый Структура;
    Отборост.Вставить("Номенклатура",стрВ.Наименование);
    найдСтроки = ВыборкаОстатки.НайтиСтроки(Отборост);

    Для каждого стрОст из найдСтроки Цикл
    стр4.ТекущийДень = стрОст.КоличествоКонечныйОстаток;
    стр4.СледМесяц = стрОст.КоличествоКонечныйОстаток;

    КонецЦикла;
    КонецЕсли;
  2. Konst82
    Offline

    Konst82 Опытный в 1С

    Регистрация:
    29 авг 2014
    Сообщения:
    53
    Симпатии:
    1
    Баллы:
    29
    масНом = ТЧКузнецк.ВыгрузитьКолонку("Наименование");

    .... в переменной масНом есть группы?
  3. TopicStarter Overlay
    Raideres
    Offline

    Raideres Опытный в 1С

    Регистрация:
    9 фев 2016
    Сообщения:
    200
    Симпатии:
    0
    Баллы:
    26
    да там и группы и номенклатура
  4. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.628
    Симпатии:
    946
    Баллы:
    204
    Я чет постановки задачи вообще не увидел
  5. TopicStarter Overlay
    Raideres
    Offline

    Raideres Опытный в 1С

    Регистрация:
    9 фев 2016
    Сообщения:
    200
    Симпатии:
    0
    Баллы:
    26
    немогу посчитать для группы остатки , считает только для номенклатуры а группе говорит пусто там хотя остатки там есть как посчитать тут остатки для группы??? крассным выделел где у меня для группы
  6. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.628
    Симпатии:
    946
    Баллы:
    204
    Новдок.Остатки это что такое
    --- Объединение сообщений, 13 апр 2016 ---
    и ТЧК то же

    тут же вроде ТЧ просто


    ТЧ = Новдок.Остатки;
    для каждого стрВ из ТЧК цикл
  7. TopicStarter Overlay
    Raideres
    Offline

    Raideres Опытный в 1С

    Регистрация:
    9 фев 2016
    Сообщения:
    200
    Симпатии:
    0
    Баллы:
    26
    Новдок.Остатки таблица куда помещаются остатки
Похожие темы
  1. Dmitrij
    Ответов:
    3
    Просмотров:
    789
Загрузка...

Поделиться этой страницей