7.7 Ошибочное сторнирование исполнительного листа

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем Виктор13245234, 22 окт 2015.

  1. TopicStarter Overlay
    Виктор13245234
    Offline

    Виктор13245234 Опытный в 1С

    Регистрация:
    17 мар 2015
    Сообщения:
    179
    Симпатии:
    3
    Баллы:
    29
    Здравствуйте! Работаю в Зик 7.70.352. Такая проблема: Бухгалтер вручную поставил окончание исполнительного листа и он отсторнировался за все предыдущие месяцы. Как это исправить? прилагаю скрин. Заранее спасибо! СторнированиеЛиста.png
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Нужно было через временное прекращение действия надбавок и удержаний... Сейчас только грохать созданные записи в ЖР
  3. TopicStarter Overlay
    Виктор13245234
    Offline

    Виктор13245234 Опытный в 1С

    Регистрация:
    17 мар 2015
    Сообщения:
    179
    Симпатии:
    3
    Баллы:
    29
    это я уже понял, спасибо. А как грохнуть? Вот я открыл журнала расчета ЗП, отобрал по нужному сотруднику. Как удалить? Обработкой? Может кто сталкивался?. Прилагаю скрин журнала расчета журнал расчета.png
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    можно:
    1) написать обработку и вычистить
    2) В ручную в ЖР обнулить суммы перерасчета
    3) Воспользоваться документом "исправление"
  5. TopicStarter Overlay
    Виктор13245234
    Offline

    Виктор13245234 Опытный в 1С

    Регистрация:
    17 мар 2015
    Сообщения:
    179
    Симпатии:
    3
    Баллы:
    29
    а как вручную обнулить суммы перерасчета?
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Заходите и изменяете... Только учтите - при перепроведении начисления ЗП ручные корректировки могут "слететь". 1с об этом предупреждает
  7. TopicStarter Overlay
    Виктор13245234
    Offline

    Виктор13245234 Опытный в 1С

    Регистрация:
    17 мар 2015
    Сообщения:
    179
    Симпатии:
    3
    Баллы:
    29
    я решил обработкой сделать! Спасибо!
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    не за что. обращайтесь
  9. TopicStarter Overlay
    Виктор13245234
    Offline

    Виктор13245234 Опытный в 1С

    Регистрация:
    17 мар 2015
    Сообщения:
    179
    Симпатии:
    3
    Баллы:
    29
    только вопрос один у меня: У меня почему то код не работает ( не удаляет записи). Хочу удалить лишние записи, только где отрицательные суммы.Вот Код:
    Код:
    Процедура Сформировать()
    ДатаНач = '01.10.2015'; 
    ДатаКон = '31.10.2015';
    док = СоздатьОбъект("Документ.ИсполнительныйЛист");
    если док.Выбрать("Выберите документ") = 0 тогда
    Предупреждение("Документ не выбран.");
    Возврат;
    КонецЕсли;
    жз = СоздатьОбъект("ЖурналРасчетов.Зарплата");
    жз.ВыбратьЗаписи(ДатаНач,ДатаКон);
    жз.ВыбратьЗаписиПоДокументу(док.ТекущийДокумент());
    пока жз.ПолучитьЗапись() = 1 цикл
    
        Если жз.Результат < 0 Тогда
            //    Сообщить(жз.Результат);
    жз.УдалитьЗапись(); // Удаляем расчет
    КонецЕсли;
    конецЦикла; // пока
    док.Удалить(0); // Удаляем документ (ставим 1С-пометку удаления)
    КонецПроцедуры
    
  10. TopicStarter Overlay
    Виктор13245234
    Offline

    Виктор13245234 Опытный в 1С

    Регистрация:
    17 мар 2015
    Сообщения:
    179
    Симпатии:
    3
    Баллы:
    29
    А стоп, ложная тревога, 1с - ка заглючила. Тему можно закрывать. Всем спасибо!
  11. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Странно что сработало... В цикле по записям нельзя удалять запись.... Цикл не будет выполнен полностью
  12. TopicStarter Overlay
    Виктор13245234
    Offline

    Виктор13245234 Опытный в 1С

    Регистрация:
    17 мар 2015
    Сообщения:
    179
    Симпатии:
    3
    Баллы:
    29
    а как бы Вы сделали? Что заменили б?
  13. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    цикл организовал по другому. Но смысл то же

Поделиться этой страницей