8.х Ошибки

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Настя999, 2 дек 2010.

  1. TopicStarter Overlay
    Настя999
    Offline

    Настя999

    Регистрация:
    27 ноя 2010
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    УТ8.Возникла при копировании кода,следующая проблема, так как я новичок в программе,я не могу понять что не так.В служебном сообщении: Метод обьекта не обнаружен(Пересчитать из Валюты в Валюту)Документ Инвентаризация Товаров на складе(739)Строка Табл.Части.Сумма Регл=общего назначения.
    Помогите, пожалуйста!!!
    :angry:
  2. Requin
    Offline

    Requin Опытный в 1С

    Регистрация:
    10 май 2010
    Сообщения:
    1.911
    Симпатии:
    2
    Баллы:
    29
    А полностью (дословно) ошибку можете привести (лучше скопировать)?

    Ну и заодно 739 строку кода (для начала)
  3. TopicStarter Overlay
    Настя999
    Offline

    Настя999

    Регистрация:
    27 ноя 2010
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    все сделала как посоветовали на сайте:

    "т.к. появились вопросы в личке по поводу этой темы выкладываю что я изменил в конфигурации:
    В Конфигураторе ищем Документ->ИнвенторизацияТоваровНаСкладе, открываем модуль объекта, ищем процедуру ЗаполнитьПоОстаткамНаСкладе, и весь ее код меняем на этот:
    Код


    Если РегистрыСведений.УчетнаяПолитика.ПолучитьПоследнее(Дата).ВестиПартионныйУчетПоСкладам Тогда
    ВремСклад = Склад;
    Иначе
    ВремСклад = Справочники.Склады.ПустаяСсылка();
    КонецЕсли;

    ВалютаУпрУчета = глЗначениеПеременной("ВалютаУправленческогоУчета");
    СтруктураКурса = ОбщегоНазначения.ПолучитьКурсВалюты(ВалютаУпрУчета, Дата);
    КурсУпрУчета = СтруктураКурса.Курс;
    КратностьУпрУчета = СтруктураКурса.Кратность;

    Если Склад.ВидСклада = Перечисления.ВидыСкладов.НТТ Тогда

    ПостроительОтчета.Текст =
    "ВЫБРАТЬ
    | ОстаткиТоваров.Номенклатура,
    | ОстаткиТоваров.ХарактеристикаНоменклатуры,"
    +?(УчитыватьСерии, "
    | ОстаткиТоваров.СерияНоменклатуры,", "") + "
    | ОстаткиТоваров.Номенклатура.ЕдиницаХраненияОстатков КАК ЕдиницаХранения,
    | ОстаткиТоваров.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент КАК КоэффициентЕдиницыХранения,
    | ОстаткиТоваров.ЦенаВРознице,
    | ВЫБОР
    | КОГДА (СУММА(ОстаткиПартий.КоличествоОстаток) = 0)
    | ИЛИ (СУММА(ОстаткиПартий.КоличествоОстаток) ЕСТЬ NULL) ТОГДА
    | 0
    | ИНАЧЕ
    | СУММА(ОстаткиПартий.СтоимостьОстаток)*СУММА(ОстаткиТоваров.КоличествоОстаток)
    | / СУММА(ОстаткиПартий.КоличествоОстаток)
    | КОНЕЦ КАК Сумма,
    | СУММА(ОстаткиТоваров.КоличествоОстаток) КАК Количество
    |ИЗ
    | РегистрНакопления.ТоварыВНТТ.Остатки(&МоментДокумента,
    | Склад = &Склад
    |// И ЦенаВРознице > 0
    |) КАК ОстаткиТоваров
    |ЛЕВОЕ СОЕДИНЕНИЕ
    | РегистрНакопления.ПартииТоваровНаСкладах.Остатки(&МоментДокумента,
    | Склад = &ПартионныйСклад) КАК ОстаткиПартий
    |ПО
    | ОстаткиТоваров.Номенклатура = ОстаткиПартий.Номенклатура
    | И ОстаткиТоваров.ХарактеристикаНоменклатуры = ОстаткиПартий.ХарактеристикаНоменклатуры"
    +?(УчитыватьСерии, "
    | И (ОстаткиТоваров.СерияНоменклатуры = ОстаткиПартий.СерияНоменклатуры
    | ИЛИ НЕ ОстаткиТоваров.Номенклатура.ВестиПартионныйУчетПоСериям)", "") + "
    |
    |{ГДЕ ОстаткиТоваров.Номенклатура КАК Номенклатура,
    | ОстаткиТоваров.Номенклатура.НоменклатурнаяГруппа КАК НоменклатурнаяГруппа}
    |
    |СГРУППИРОВАТЬ ПО
    | ОстаткиТоваров.Номенклатура,
    | ОстаткиТоваров.ХарактеристикаНоменклатуры,"
    +?(УчитыватьСерии, "
    | ОстаткиТоваров.СерияНоменклатуры,", "") + "
    | ОстаткиТоваров.ЦенаВРознице";
    //Start Инвентаризация в розничных ценах
    ИначеЕсли Склад.ВидСклада = Перечисления.ВидыСкладов.Розничный Тогда
    ПостроительОтчета.Текст =
    "ВЫБРАТЬ
    | ОстаткиТоваров.Номенклатура,
    | ОстаткиТоваров.ХарактеристикаНоменклатуры,"
    +?(УчитыватьСерии, "
    | ОстаткиТоваров.СерияНоменклатуры,", "") + "
    | ОстаткиТоваров.Номенклатура.ЕдиницаХраненияОстатков КАК ЕдиницаХранения,
    | ОстаткиТоваров.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент КАК КоэффициентЕдиницыХранения,
    | ОстаткиТоваров.Качество,
    | СУММА(ОстаткиТоваров.КоличествоОстаток) КАК Количество,
    | СУММА(ЦеныНоменклатурыСрезПоследних.Цена) Как Сумма,

    | ВЫБОР
    | КОГДА (СУММА(ОстаткиПартий.КоличествоОстаток) = 0)
    | ИЛИ (СУММА(ОстаткиПартий.КоличествоОстаток) ЕСТЬ NULL) ТОГДА
    | 0
    | ИНАЧЕ
    | СУММА(ОстаткиПартий.СтоимостьОстаток)*СУММА(ОстаткиТоваров.КоличествоОстаток)
    | / СУММА(ОстаткиПартий.КоличествоОстаток)
    | КОНЕЦ КАК СуммаУчет
    |ИЗ
    | РегистрСведений.ЦеныНоменклатуры.СрезПоследних(&МоментДокумента, ТипЦен = &ТипЦен) КАК ЦеныНоменклатурыСрезПоследних,
    |
    | РегистрНакопления.ТоварыВРознице.Остатки(&МоментДокумента, Склад = &Склад) КАК ОстаткиТоваров
    |
    |ЛЕВОЕ СОЕДИНЕНИЕ
    | РегистрНакопления.ПартииТоваровНаСкладах.Остатки(&МоментДокумента,
    | Склад = &ПартионныйСклад) КАК ОстаткиПартий
    |ПО
    | ОстаткиТоваров.Номенклатура = ОстаткиПартий.Номенклатура
    | И ОстаткиТоваров.ХарактеристикаНоменклатуры = ОстаткиПартий.ХарактеристикаНоменклатуры"
    +?(УчитыватьСерии, "
    | И (ОстаткиТоваров.СерияНоменклатуры = ОстаткиПартий.СерияНоменклатуры
    | ИЛИ НЕ ОстаткиТоваров.Номенклатура.ВестиПартионныйУчетПоСериям)", "") + "
    | И ОстаткиТоваров.Качество = ОстаткиПартий.Качество
    |
    |ГДЕ ЦеныНоменклатурыСрезПоследних.Номенклатура = ОстаткиТоваров.Номенклатура И ЦеныНоменклатурыСрезПоследних.ХарактеристикаНоменклатуры = ОстаткиТоваров.ХарактеристикаНоменклатуры
    |{ГДЕ ОстаткиТоваров.Номенклатура КАК Номенклатура,
    | ОстаткиТоваров.Номенклатура.НоменклатурнаяГруппа КАК НоменклатурнаяГруппа}
    |СГРУППИРОВАТЬ ПО
    | ОстаткиТоваров.Номенклатура,
    | ОстаткиТоваров.ХарактеристикаНоменклатуры,"
    +?(УчитыватьСерии, "
    | ОстаткиТоваров.СерияНоменклатуры,", "") + "
    | ОстаткиТоваров.Качество";

    //End Инвентаризация в розничных ценах
    Иначе
    Если Склад.ВидСклада = Перечисления.ВидыСкладов.Оптовый Тогда
    РегОстатки = "ТоварыНаСкладах";
    Иначе
    РегОстатки = "ТоварыВРознице";
    КонецЕсли;

    ПостроительОтчета.Текст =
    "ВЫБРАТЬ
    | ОстаткиТоваров.Номенклатура,
    | ОстаткиТоваров.ХарактеристикаНоменклатуры,"
    +?(УчитыватьСерии, "
    | ОстаткиТоваров.СерияНоменклатуры,", "") + "
    | ОстаткиТоваров.Номенклатура.ЕдиницаХраненияОстатков КАК ЕдиницаХранения,
    | ОстаткиТоваров.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент КАК КоэффициентЕдиницыХранения,
    | ОстаткиТоваров.Качество,
    | СУММА(ОстаткиТоваров.КоличествоОстаток) КАК Количество,
    | ВЫБОР
    | КОГДА (СУММА(ОстаткиПартий.КоличествоОстаток) = 0)
    | ИЛИ (СУММА(ОстаткиПартий.КоличествоОстаток) ЕСТЬ NULL) ТОГДА
    | 0
    | ИНАЧЕ
    | СУММА(ОстаткиПартий.СтоимостьОстаток)*СУММА(ОстаткиТоваров.КоличествоОстаток)
    | / СУММА(ОстаткиПартий.КоличествоОстаток)
    | КОНЕЦ КАК Сумма
    |ИЗ
    | РегистрНакопления." + РегОстатки + ".Остатки(&МоментДокумента, Склад = &Склад)
    |КАК ОстаткиТоваров
    |
    |ЛЕВОЕ СОЕДИНЕНИЕ
    | РегистрНакопления.ПартииТоваровНаСкладах.Остатки(&МоментДокумента,
    | Склад = &ПартионныйСклад) КАК ОстаткиПартий
    |ПО
    | ОстаткиТоваров.Номенклатура = ОстаткиПартий.Номенклатура
    | И ОстаткиТоваров.ХарактеристикаНоменклатуры = ОстаткиПартий.ХарактеристикаНоменклатуры"
    +?(УчитыватьСерии, "
    | И (ОстаткиТоваров.СерияНоменклатуры = ОстаткиПартий.СерияНоменклатуры
    | ИЛИ НЕ ОстаткиТоваров.Номенклатура.ВестиПартионныйУчетПоСериям)", "") + "
    | И ОстаткиТоваров.Качество = ОстаткиПартий.Качество
    |
    |{ГДЕ ОстаткиТоваров.Номенклатура КАК Номенклатура,
    | ОстаткиТоваров.Номенклатура.НоменклатурнаяГруппа КАК НоменклатурнаяГруппа}
    |
    |СГРУППИРОВАТЬ ПО
    | ОстаткиТоваров.Номенклатура,
    | ОстаткиТоваров.ХарактеристикаНоменклатуры,"
    +?(УчитыватьСерии, "
    | ОстаткиТоваров.СерияНоменклатуры,", "") + "
    | ОстаткиТоваров.Качество";

    КонецЕсли;

    Запрос = ПостроительОтчета.ПолучитьЗапрос();

    Запрос.УстановитьПараметр("Склад", Склад);
    Запрос.УстановитьПараметр("ТипЦен", Склад.ТипЦенРозничнойТорговли);
    Запрос.УстановитьПараметр("ПартионныйСклад", ВремСклад);
    Если ЭтоНовый() Тогда
    Запрос.УстановитьПараметр("МоментДокумента", КонецДня(Дата));
    Иначе
    Запрос.УстановитьПараметр("МоментДокумента", МоментВремени());
    КонецЕсли;
    Выборка = Запрос.Выполнить().Выбрать();
    Пока Выборка.Следующий() Цикл

    Если Выборка.Количество = 0 Тогда
    Продолжить;
    КонецЕсли;

    СтрокаТабличнойЧасти = Товары.Добавить();

    СтрокаТабличнойЧасти.Номенклатура = Выборка.Номенклатура;
    СтрокаТабличнойЧасти.КоличествоУчет = Выборка.Количество;
    СтрокаТабличнойЧасти.Количество = ?(ТолькоУчетные, 0, СтрокаТабличнойЧасти.КоличествоУчет);
    СтрокаТабличнойЧасти.ЕдиницаИзмерения = Выборка.ЕдиницаХранения;
    СтрокаТабличнойЧасти.Коэффициент = Выборка.КоэффициентЕдиницыХранения;
    СтрокаТабличнойЧасти.СуммаУчет = Выборка.Сумма;
    СтрокаТабличнойЧасти.Сумма = ?(ТолькоУчетные, 0, Выборка.Сумма);
    СтрокаТабличнойЧасти.Цена = СтрокаТабличнойЧасти.Сумма / СтрокаТабличнойЧасти.КоличествоУчет;
    Если Склад.ВидСклада = Перечисления.ВидыСкладов.НТТ Тогда
    СтрокаТабличнойЧасти.ЦенаВРознице = Выборка.ЦенаВРознице;
    Иначе
    СтрокаТабличнойЧасти.Качество = Выборка.Качество;
    КонецЕсли;

    СтрокаТабличнойЧасти.СуммаРегл = ОбщегоНазначения.ПересчитатьИзВалютыВВалюту(СтрокаТабличнойЧасти.Сумма, ВалютаУпрУчета,
    мВалютаРегламентированногоУчета, КурсУпрУчета, 1, КратностьУпрУчета, 1);

    СтрокаТабличнойЧасти.ХарактеристикаНоменклатуры = Выборка.ХарактеристикаНоменклатуры;
    Если УчитыватьСерии Тогда
    СтрокаТабличнойЧасти.СерияНоменклатуры = Выборка.СерияНоменклатуры;
    КонецЕсли;

    КонецЦикла;

    После замены на этот код,при заполнении документа "Инвентаризация"-Заполнить по остаткам на складе выскакивает ошибка:
    Метод обьекта не обнаружен(Пересчитать из Валюты в Валюту)Документ Инвентаризация Товаров на складе(739)

    Когда нажимаю подробно пишет:
    Строка Табл.Части.Сумма Регл=общего назначения.
  4. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Точную версию конфигурацию укажите, типовая ли?
  5. TopicStarter Overlay
    Настя999
    Offline

    Настя999

    Регистрация:
    27 ноя 2010
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    типовая,Управление торговлей 8 Украина.
  6. TopicStarter Overlay
    Настя999
    Offline

    Настя999

    Регистрация:
    27 ноя 2010
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Может быть это из-за того что у нас по учету USD, а курс валют и все до в грн. :angry:
  7. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Видимо, в укр. версии метод называется по другому.
    Дистриба конфы у меня нет - поэтому помочь тяжко :)
  8. Requin
    Offline

    Requin Опытный в 1С

    Регистрация:
    10 май 2010
    Сообщения:
    1.911
    Симпатии:
    2
    Баллы:
    29
    Неужели так с пробелами и точками пишет? В модуле ОбщегоНазначения точно есть функция ПересчитатьИзВалютыВВалюту()?

Поделиться этой страницей