8.х Ошибка

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем Кирилл17, 17 мар 2013.

  1. TopicStarter Overlay
    Кирилл17
    Offline

    Кирилл17

    Регистрация:
    17 мар 2013
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте.

    Делаю Проведение Документа РасходнаяНакладная на основе регистра накопления ОстаткиНоменклатуры.

    При записи, возникает ошибка

    Ошибка при выполнении обработчика - '{Документ.РасходнаяНакладная(36)}: Ошибка при вызове метода контекста (Остатки): Недопустимое значение параметра (параметр номер '2')'
    по причине:
    {Документ.РасходнаяНакладная(36)}: Ошибка при вызове метода контекста (Остатки): Недопустимое значение параметра (параметр номер '2')

    по причине:
    Недопустимое значение параметра (параметр номер '2')

    Модуль обьекта таков:

    Процедура ОбработкаПроведения(Отказ, Режим)
    //{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
    ОстаткиТовара=РегистрыНакопления.ОстаткиНоменклатуры;
    Для Каждого ТекСтрокаМатериалы Из Материалы Цикл
    ТекТовар=ТекСтрокаМатериалы.Материал;
    ТекСклад=Склад;
    ФильтрТовара=Новый Структура();
    ФильтрТовара.Вставить("Материал",ТекТовар);
    ФильтрТовара.Вставить("Склад",ТекСклад);
    ТаблицаОстатков=ОстаткиТовара.Остатки(МоментВремени(),ФильтрТовара,"Материал","Количество");
    Остатки=ТаблицаОстатков.Итог("Количество");
    Если Остатки>=ТекСтрокаМатериалы.Количество Тогда
    // регистр ОстаткиНоменклатуры Расход
    Движение = Движения.ОстаткиНоменклатуры.Добавить();
    Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
    Движение.Период = Дата;
    Движение.Номенклатура = ТекСтрокаМатериалы.Материал;
    Движение.Склад = Склад;
    Движение.Количество = ТекСтрокаМатериалы.Количество;
    Движение.Сумма = ТекСтрокаМатериалы.Себестоимость*ТекСтрокаМатериалы.Количество;
    Иначе
    Сообщить("На складе "+Склад.Наименование+" недостаточно товара "+ТекСтрокаМатериалы.Материал.Наименование+". Документ не проводится");
    отказ = истина;
    возврат;
    КонецЕсли;
    КонецЦикла;
    Движения.ОстаткиНоменклатуры.Записать();
    //}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
    КонецПроцедуры

    Подскажите пожалуйста, где ошибка?
  2. La Navidad
    Offline

    La Navidad Опытный в 1С

    Регистрация:
    25 дек 2012
    Сообщения:
    203
    Симпатии:
    1
    Баллы:
    26
    Может не так
    Код:
    ТаблицаОстатков=ОстаткиТовара.Остатки(МоментВремени(),ФильтрТовара,"Материал","Количество");
    а так:
    Код:
    ТаблицаОстатков=ОстаткиТовара.Остатки(МоментВремени(),ФильтрТовара,"Количество");
    Регистр точно остатошный?
    Измерения "материал" и "склад" - точно есть?
  3. TopicStarter Overlay
    Кирилл17
    Offline

    Кирилл17

    Регистрация:
    17 мар 2013
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    спасибо, все заработало!!!
Похожие темы
  1. Helmut
    Ответов:
    7
    Просмотров:
    1.374
  2. zxcv
    Ответов:
    7
    Просмотров:
    1.053
Загрузка...

Поделиться этой страницей