8.х УТ Ошибка!

Тема в разделе ""1С:Управление торговлей УТ"", создана пользователем videomause, 15 сен 2011.

  1. TopicStarter Overlay
    videomause
    Offline

    videomause Опытный в 1С

    Регистрация:
    14 янв 2011
    Сообщения:
    169
    Симпатии:
    2
    Баллы:
    29
    Здравствуйте! УТ 10.3. Начинал тему в форуме по обменам, но проблема крылась гораздо глубже. Вкраце: два узла УТ (основной и подчиненный), я отсутствовал пару недель, в это время на подчиненном узле проводили ревизию, и после этого обмен между узлами стал проходить только в одностороннем порядке: основной узел перестал принимать изменения от подчиненного (обмен через флешку). При проведении обмена на основном узле выдается: "Ошибка записи! Не установлен отбор по регистратору (Регистр накопления: Товары на складах)". При проведении тестирования и исправления на подчиненном узле выдаются следующие ошибки: "Проверка логической целостности. РегистрНакопления. Продажи :0. Не определена ссылка" а также:

    Код справочника стал не уникальным: ЕдиницыИзмерения (000000001)
    ....
    ....
    ....
    Код справочника стал не уникальным: ЕдиницыИзмерения (000000050)

    Сказали что за время моего отсутствия программа несколько раз сдавала сбой, не давала сохранить отчет о розничных продажах (посмотрел-несколько отчетов были неполными (обрывались на середине дня и были заполнены пустыми позициями, поудалял их вручную), но вот в РегистреНакопления в Продажах как раз и присутствует пустая строчка за одно из чисел когда отчет не сохранился, там только написано число и время, а сыылки на документ и какой товар нету. Строчку эту из Регистра удалить нет возможности, а насколько понимаю именно она и не дает произвести обмен.
  2. x_under
    Offline

    x_under Модераторы Команда форума Модератор

    Регистрация:
    25 апр 2007
    Сообщения:
    2.576
    Симпатии:
    13
    Баллы:
    29
    Так вы сделали тестирование или тестирование и исправление? Если да, то с какими параметрами. Там можно установить удаление ссылок на несуществующие объекты.
  3. TopicStarter Overlay
    videomause
    Offline

    videomause Опытный в 1С

    Регистрация:
    14 янв 2011
    Сообщения:
    169
    Симпатии:
    2
    Баллы:
    29
    Тестирование и исправление. Галочки поставил на удаление. Не помогает(((. Проверял и на физическую целостность, тоже результата никакого.
  4. comol
    Offline

    comol Опытный в 1С

    Регистрация:
    8 сен 2011
    Сообщения:
    153
    Симпатии:
    0
    Баллы:
    26
    Нууу мне помогала такая обработка:

    Код:
    Процедура УдалениеБитыхСсылок(ИмяРегистра,ТипРегистра,ТипРегистраЗ)
    МенеджерРегистра = ТипРегистра[ИмяРегистра];
    Запрос = Новый Запрос("
    |ВЫБРАТЬ Регистратор
    |ИЗ "+ТипРегистраЗ+"."+ИмяРегистра+" 
    |ГДЕ Регистратор.Номер ЕСТЬ NULL И НЕ Регистратор = &ПустаяСсылкаДокумента");
    Запрос.УстановитьПараметр("ПустаяСсылкаДокумента",Неопределено);
    Выборка = Запрос.Выполнить().Выбрать();
    Пока Выборка.Следующий() Цикл
    Набор = ТипРегистра[ИмяРегистра].СоздатьНаборЗаписей();
    Набор.Отбор.Регистратор.Установить(Выборка.Регистратор);
    Набор.ОбменДанными.Получатели.Очистить();
    Набор.Записать();
    ОбработкаПрерыванияПользователя();
    Состояние(""+ТипРегистра+" "+ИмяРегистра);
    КонецЦикла;
    КонецПроцедуры 
    
    Процедура КнопкаВыполнитьНажатие(Кнопка)
    
    //Для Каждого пРегистр из Метаданные.РегистрыСведений Цикл
    //	Подчинен        =    (пРегистр.РежимЗаписи = Метаданные.СвойстваОбъектов.РежимЗаписиРегистра.ПодчинениеРегистратору);
    //	Если Подчинен Тогда
    //		УдалениеБитыхСсылок(пРегистр.Имя,РегистрыСведений,"РегистрСведений");
    //	КонецЕсли; 
    // КонецЦикла; 
    
    // Для Каждого пРегистр из Метаданные.РегистрыБухгалтерии Цикл
    //	УдалениеБитыхСсылок(пРегистр.Имя,РегистрыБухгалтерии,"РегистрБухгалтерии")
    //КонецЦикла;
    //	Для Каждого пРегистр из Метаданные.РегистрыРасчета Цикл
    //	УдалениеБитыхСсылок(пРегистр.Имя,РегистрыРасчета,"РегистрРасчета")
    //КонецЦикла;
    
    Для Каждого пРегистр из Метаданные.РегистрыНакопления Цикл
    //Если пРегистр.Имя <> "ПродажиПоДисконтнымКартам" Тогда
    УдалениеБитыхСсылок(пРегистр.Имя,РегистрыНакопления,"РегистрНакопления");
    //КонецЕсли;		
    КонецЦикла;
    КонецПроцедуры
    

    в вашем случае может можно и модифицировать, убрав:

    Код:
    И НЕ Регистратор = &ПустаяСсылкаДокумента
    
Похожие темы
  1. Helmut
    Ответов:
    7
    Просмотров:
    1.372
  2. zxcv
    Ответов:
    7
    Просмотров:
    1.050
Загрузка...

Поделиться этой страницей