8.х Ошибка

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем FLoYD777, 30 июн 2009.

  1. TopicStarter Overlay
    FLoYD777
    Offline

    FLoYD777 Опытный в 1С

    Регистрация:
    4 май 2009
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    Код:
    СсылкаНаСправочник = Справочники.ХранилищеДополнительнойИнформации;	
    Отбор = Новый Структура("Проверка");
    ТипФ = Перечисления.ВидыДополнительнойИнформацииОбъектов.ПустаяСсылка();
    Отбор.Проверка = ТипФ;
    Выборка = СсылкаНаСправочник.Выбрать(,,Отбор,);
    
    Пока Выборка.Следующий() Цикл
    Эль = Выборка.ПолучитьОбъект();
    Эль.Проверка = Перечисления.ВидыДополнительнойИнформацииОбъектов.Изображение; 
    Попытка
    Эль.Записать();
    Исключение
    Предупреждение("Не удалось записать объект """ + Эль + """
    |" + ОписаниеОшибки(),60);
    КонецПопытки;
    КонецЦикла; 
    
    Выскакиевает ошибка:
    ВнешняяОбработка.ППП(10)}: Ошибка при вызове метода контекста (Выбрать): Недопустимое значение параметра (параметр номер '3')
    Выборка = СсылкаНаСправочник.Выбрать(,,Отбор,);

    на строчку:
    Код:
    Выборка = СсылкаНаСправочник.Выбрать(,,Отбор,);
    
    подскажите пожлста в чем причина? заранее благодарен!
  2. Tanya_22
    Offline

    Tanya_22 Опытный в 1С

    Регистрация:
    11 янв 2008
    Сообщения:
    68
    Симпатии:
    0
    Баллы:
    26
    Синтаксис-помощник гласит:
  3. TopicStarter Overlay
    FLoYD777
    Offline

    FLoYD777 Опытный в 1С

    Регистрация:
    4 май 2009
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    могли бы пояснить, просто вот пример из Синтаксис-помощника. Откуда впринципи я и взял скелет этого всего:
    Код:
    Номенклатура = Справочники.Номенклатура;
    Отбор = Новый Структура("ТипНоменклатуры");
    Пусто = Перечисления.ТипыНоменклатуры.ПустаяСсылка();
    Отбор.ТипНоменклатуры = Пусто;
    Выборка = Номенклатура.Выбрать(,,Отбор, "Наименование Убыв");
    Пока Выборка.Следующий() Цикл
    Объект = Выборка.ПолучитьОбъект();
    Объект.ТипНоменклатуры = Перечисления.ТипыНоменклатуры.Товар;
    Попытка
    Объект.Записать();
    Исключение
    Предупреждение("Не удалось записать объект """ + Объект + """
    |" + ОписаниеОшибки(),60);
    КонецПопытки;
    КонецЦикла;
    
  4. Tanya_22
    Offline

    Tanya_22 Опытный в 1С

    Регистрация:
    11 янв 2008
    Сообщения:
    68
    Симпатии:
    0
    Баллы:
    26
    Постараюсь. Но не факт что ошибка именно в этом.
    Открывете в дереве конфы справочник ХранилищеДополнительнойИнформации, далее смотрите реквизит по которому делаете отбор и проверяете в палитре свойств что установлено в свойстве "Индексировать". Я так предполагаю что там будет значение "Не индексировать", которое необходимо будет изменить.
  5. TopicStarter Overlay
    FLoYD777
    Offline

    FLoYD777 Опытный в 1С

    Регистрация:
    4 май 2009
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    стоит "Индексировать"... в чем ещё могут быть проблемы??
  6. Stack_G
    Offline

    Stack_G Опытный в 1С

    Регистрация:
    10 дек 2007
    Сообщения:
    786
    Симпатии:
    2
    Баллы:
    26
    хм... "Проверка" - точно рекыизит справочника???

    "<Отбор> (необязательный)
    Тип: Структура. Задает поле и значение отбора открываемой выборки. Ключ структуры описывает имя поля, а значение структуры - значение отбора по этому полю."

    может нужно так:

    Код:
    	СсылкаНаСправочник = Справочники.ХранилищеДополнительнойИнформации;	
    Отбор = Новый Структура("ВидДанных");
    ТипФ = Перечисления.ВидыДополнительнойИнформацииОбъектов.ПустаяСсылка();
    Отбор.ВидДанных = ТипФ;
    Выборка = СсылкаНаСправочник.Выбрать(,,Отбор,);
    
    Пока Выборка.Следующий() Цикл
    Эль = Выборка.ПолучитьОбъект();
    Эль.ВидДанных = Перечисления.ВидыДополнительнойИнформацииОбъектов.Изображение; 
    Попытка
    Эль.Записать();
    Исключение
    Предупреждение("Не удалось записать объект """ + Эль + """
    |" + ОписаниеОшибки(),60);
    КонецПопытки;
    КонецЦикла;
    
  7. TopicStarter Overlay
    FLoYD777
    Offline

    FLoYD777 Опытный в 1С

    Регистрация:
    4 май 2009
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    нет, надо с реквизитом "Проверка"...
  8. Tanya_22
    Offline

    Tanya_22 Опытный в 1С

    Регистрация:
    11 янв 2008
    Сообщения:
    68
    Симпатии:
    0
    Баллы:
    26
    А что за конфа?
  9. TopicStarter Overlay
    FLoYD777
    Offline

    FLoYD777 Опытный в 1С

    Регистрация:
    4 май 2009
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    вообще УТ версия 10.2.13.1... но здесь дописано и переписанно очень много всего... вообщем жесть...

    Ладно, всем спасибо за помощь!!! Буду наверное через запросы делать...=)
    если кто поймет в чем причина, буду благодарен за инфу)
  10. Stack_G
    Offline

    Stack_G Опытный в 1С

    Регистрация:
    10 дек 2007
    Сообщения:
    786
    Симпатии:
    2
    Баллы:
    26
    Посмотри в чем отличие реквизитов "Проверка" и "ВидДанных".
  11. Tanya_22
    Offline

    Tanya_22 Опытный в 1С

    Регистрация:
    11 янв 2008
    Сообщения:
    68
    Симпатии:
    0
    Баллы:
    26
    А если как Stack_G посоветовал сделать? "ВидДанных" реквизит в УТ есть. Реквизит "Проверка" вы сами добавляли? Я такой там не нашла.
  12. TopicStarter Overlay
    FLoYD777
    Offline

    FLoYD777 Опытный в 1С

    Регистрация:
    4 май 2009
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    Разница в том что у меня нет реквизита "ВидДанных"... но посмотрел в УТ 10.3 и отличий не нашел...

    На фирме работал прогер, который все это и сделал с базой... недавно он уволился... и связи с ним нету, говорят уехал...
  13. Tanya_22
    Offline

    Tanya_22 Опытный в 1С

    Регистрация:
    11 янв 2008
    Сообщения:
    68
    Симпатии:
    0
    Баллы:
    26
    Должен быть. Смотри скрин.

    Вложения:

  14. Stack_G
    Offline

    Stack_G Опытный в 1С

    Регистрация:
    10 дек 2007
    Сообщения:
    786
    Симпатии:
    2
    Баллы:
    26
    Да-да, дай-ка взглянуть на структуру справочника и свойства реквизита "Проверка"... уж очень интересно стало.
  15. TopicStarter Overlay
    FLoYD777
    Offline

    FLoYD777 Опытный в 1С

    Регистрация:
    4 май 2009
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    Здесь, в этой конфе он называется "Проверка"... Он никак не отличается от "ВидДанных"... Зачем его переименовали не понимаю... но раз переименовали значит нужно было...
    ща сфоткаю...
  16. Stack_G
    Offline

    Stack_G Опытный в 1С

    Регистрация:
    10 дек 2007
    Сообщения:
    786
    Симпатии:
    2
    Баллы:
    26
    если уж все-все правильно как утверждаешь - абсурдный вариант - латинские символы либо в названии реквизита, либо у тебя в обработке.
  17. Tanya_22
    Offline

    Tanya_22 Опытный в 1С

    Регистрация:
    11 янв 2008
    Сообщения:
    68
    Симпатии:
    0
    Баллы:
    26
    Специально обработку создала для УТ демо версии... Всё прекрасно работает и пустые ссылки подменяет на изображения.

    PS. Вообще я подобную операцию сделала легко с помощью групповой обработки. Не вижу смысл что-то конкретное выдумывать. Ведь так понимаю обработка разовая.

    Вложения:

  18. TopicStarter Overlay
    FLoYD777
    Offline

    FLoYD777 Опытный в 1С

    Регистрация:
    4 май 2009
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    ААА... жесть... Прошу пощады!!!
    Нашел ошибку пока делал скрины...
    название реквизита "Провертка", а я писал "Проверка"...
    вот ссылка на скрин:
    http://slil.ru/27800531

    Люди, сорри!!!
  19. Tanya_22
    Offline

    Tanya_22 Опытный в 1С

    Регистрация:
    11 янв 2008
    Сообщения:
    68
    Симпатии:
    0
    Баллы:
    26
    Ничего. Бывает :unsure:
  20. vitaly_mnpz
    Offline

    vitaly_mnpz Опытный в 1С

    Регистрация:
    15 фев 2009
    Сообщения:
    267
    Симпатии:
    0
    Баллы:
    26
    Может, ему просто руки оторвали? Или голову...
Похожие темы
  1. Helmut
    Ответов:
    7
    Просмотров:
    1.371
  2. zxcv
    Ответов:
    7
    Просмотров:
    1.048
Загрузка...

Поделиться этой страницей