8.х Ошибка внешней печтаной формы т-53

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем Patronus, 20 фев 2013.

  1. TopicStarter Overlay
    Patronus
    Offline

    Patronus

    Регистрация:
    9 фев 2012
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Добрый день, после выхода последнего обновления ЗУП 2.5.62.1 перестала работать внеш. печ. форма т-53 с полным ФИО. Вот ошибка:
    Не удалось сформировать внешнюю печатную форму!
    Метод объекта не обнаружен (ГоловнаяОрганизация)


    Подскажите что добавить. Файл прикрепил ниже.

    Вложения:

  2. Dmitriy_76
    Offline

    Dmitriy_76 Опытный в 1С Команда форума

    Регистрация:
    26 мар 2011
    Сообщения:
    2.175
    Симпатии:
    13
    Баллы:
    29
    ну открыл бы конфигуратором.... и нашел в стр 130 (модуля твоей обработки) вот такой кусочек

    Код:
    Запрос.УстановитьПараметр("ГоловнаяОрганизация", ОбщегоНазначения.ГоловнаяОрганизация(Организация));
    
    и сделай выводы..что в общем модуле ОбщегоНазначения нет функции ГоловнаяОрганизация() ...
    добавь из старой копии... а вообще лучше бы ее вставить в твою внеш печ форму.
  3. TopicStarter Overlay
    Patronus
    Offline

    Patronus

    Регистрация:
    9 фев 2012
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Еслиб я это еще понимал сюда бы не написал)) Можешь конкретно написать что добавить в печ. форму?
  4. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    вам по пунктам расписали что делать. Найдите в старой копии конфы в общем модуле "ОбщегоНазначения" функцию Головная организация и скопируйте ее в текущую конфигурацию в тот же модуль.

    НО для начала я бы посмотрела в этом общем модуле (в текущей обновленной конфе) а может у нее просто наименование изменилось?

    а вы первый раз конфигуратор открыли?
  5. TopicStarter Overlay
    Patronus
    Offline

    Patronus

    Регистрация:
    9 фев 2012
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Не первый раз, вы хотите чтобы в самой конфигурации чтоли подправил? Для меня это не вариант... Мне нужно в рамках самой печатной формы вопрос решить.
    Просмотрел я старую и новую версию в старой есть эта функция, а новой вообще все потерли...
  6. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    ну тогда код той функции скопируйте в модуль вашей печатной формы, а сам вызов подправьте по типу
    Код:
    Запрос.УстановитьПараметр("ГоловнаяОрганизация", фГоловнаяОрганизация(Организация));
  7. TopicStarter Overlay
    Patronus
    Offline

    Patronus

    Регистрация:
    9 фев 2012
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Добавил выходит ошибка:
    {ВнешняяОбработка.ПечатьТ53.МодульОбъекта(375,59)}: Ожидается символ ')'
    Функция СформироватьСтруктуруШапкиДокумента(ДокументОбъект<<?>>.ГоловнаяОрганизация) (Проверка: Толстый клиент (обычное приложение))

    Код:
    Функция СформироватьСтруктуруШапкиДокумента(ДокументОбъект.ГоловнаяОрганизация)
    
    СтруктураШапкиДокумента = Новый Структура;
    СтруктураШапкиДокумента.Вставить("Ссылка", ДокументОбъект.Ссылка);
    СтруктураШапкиДокумента.Вставить("Дата", ДокументОбъект.Дата);
    ИмяДокумента = ДокументОбъект.Метаданные().Имя;
    Для каждого Реквизит из Метаданные.Документы[ИмяДокумента].Реквизиты Цикл
    СтруктураШапкиДокумента.Вставить(Реквизит.Имя, ДокументОбъект[Реквизит.Имя]);
    Если Реквизит.Имя = "Организация" Тогда
    СтруктураШапкиДокумента.Вставить("ГоловнаяОрганизация", ГоловнаяОрганизация(ДокументОбъект[Реквизит.Имя]));
    КонецЕсли;
    КонецЦикла;
    Возврат СтруктураШапкиДокумента;
    
    КонецФункции // СформироватьСтруктуруШапкиДокумента()
  8. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    параметр в функцию передается при вызове, а не при описании. ошибка наверное тут
    Код:
    Функция СформироватьСтруктуруШапкиДокумента(ДокументОбъект.ГоловнаяОрганизация)
    зачем вам в описании вообще параметры?
  9. TopicStarter Overlay
    Patronus
    Offline

    Patronus

    Регистрация:
    9 фев 2012
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Все поправил в конфигураторе ошибок нету, но при выводе печ. формы ошибка осталась
    Код:
    Функция СформироватьСтруктуруШапкиДокумента()
    
    СтруктураШапкиДокумента = Новый Структура;
    СтруктураШапкиДокумента.Вставить("Ссылка", СсылкаНаОбъект.Ссылка);
    СтруктураШапкиДокумента.Вставить("Дата", СсылкаНаОбъект.Дата);
    ИмяДокумента = СсылкаНаОбъект.Метаданные().Имя;
    Для каждого Реквизит из Метаданные.Документы[ИмяДокумента].Реквизиты Цикл
    СтруктураШапкиДокумента.Вставить(Реквизит.Имя, СсылкаНаОбъект[Реквизит.Имя]);
    Если Реквизит.Имя = "Организация" Тогда
    СтруктураШапкиДокумента.Вставить("ГоловнаяОрганизация", СсылкаНаОбъект.ГоловнаяОрганизация(СсылкаНаОбъект[Реквизит.Имя]));
    КонецЕсли;
    КонецЦикла;
    Возврат СтруктураШапкиДокумента;
    
    КонецФункции // СформироватьСтруктуруШапкиДокумента()
    Ошибка:
    Не удалось сформировать внешнюю печатную форму!
    Метод объекта не обнаружен (фГоловнаяОрганизация)


    Ругается на эту функцию:
    Код:
    Запрос.УстановитьПараметр("ГоловнаяОрганизация", фГоловнаяОрганизация(Организация));
  10. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    ну дак а функцию то вы к себе перетянули? выложите код
  11. TopicStarter Overlay
    Patronus
    Offline

    Patronus

    Регистрация:
    9 фев 2012
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Код:
    Функция ГоловнаяОрганизация(Организация)
    
    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("Организация",Организация);
    Запрос.Текст =
    "ВЫБРАТЬ РАЗРЕШЕННЫЕ
    | Организации.ГоловнаяОрганизация
    |ИЗ
    | Справочник.Организации КАК Организации
    |ГДЕ
    | Организации.Ссылка = &Организация";
    Выборка = Запрос.Выполнить().Выбрать();
    Если Не Выборка.Следующий() Тогда
    Возврат Справочники.Организации.ПустаяСсылка()
    КонецЕсли;
    Если Организация.Пустая() или Выборка.ГоловнаяОрганизация.Пустая() Тогда
    Возврат Организация;
    Иначе
    Возврат Выборка.ГоловнаяОрганизация;
    КонецЕсли;
    КонецФункции // ГоловнаяОрганизация()
    
  12. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    вы точно программируете? может надо к спецам обратиться, а то наделаете делов....

    на счет ошибки, .внимательно посмотрите на название вашей функции и на название функции в контрукции установки параметра запроса. Разницу видите? Они должны быть одинаковыми, иначе все правильно прога ругается, что такой функции нет...
  13. TopicStarter Overlay
    Patronus
    Offline

    Patronus

    Регистрация:
    9 фев 2012
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Не, я не программист, а сделать требуют... Все поправил, теперь стал ругаться на СуммуПрописью которая была в объекте ОбщегоНазначения в старой версии, в новой версии ее перенесли на ОбщегоНазначенияЗК. В печ. форме я вместо ОбщегоНазначения сделал ОбщегоНазначенияЗК и все заработало, но в печатной форме все равно не прописиваются суммы прописью что делать?
    Код:
    Валюта = Константы.ВалютаРегламентированногоУчета.Получить();
    Если ВыборкаДляШапки.Сумма <> 0 Тогда
    ОбластьМакетаШапкаДокумента.Параметры.СуммаДок = ОбщегоНазначенияЗК.СформироватьСуммуПрописью(ВыборкаДляШапки.Сумма, Валюта);
    ОбластьМакетаШапкаДокумента.Параметры.СуммаДокРублей = Цел(ВыборкаДляШапки.Сумма);
    ОбластьМакетаШапкаДокумента.Параметры.СуммаДокКопеек = (ВыборкаДляШапки.Сумма - Цел(ВыборкаДляШапки.Сумма)) * 100
    КонецЕсли;
    Если ВыборкаДляШапки.ОплаченоПолностью Тогда
    Если ВыборкаДляШапки.ВсегоДепонировано > 0 Тогда
    ОбластьМакетаПодвал.Параметры.ВсегоДепонировано = ОбщегоНазначенияЗК.СформироватьСуммуПрописью(ВыборкаДляШапки.ВсегоДепонировано, Валюта);
    Иначе
    ОбластьМакетаПодвал.Параметры.ВсегоДепонировано = "---";
    КонецЕсли;
    Если ВыборкаДляШапки.ВсегоВыплачено > 0 Тогда
    ОбластьМакетаПодвал.Параметры.ВсегоВыплачено = ОбщегоНазначенияЗК.СформироватьСуммуПрописью(ВыборкаДляШапки.ВсегоВыплачено, Валюта);
    Иначе
    ОбластьМакетаПодвал.Параметры.ВсегоВыплачено = "---";
    КонецЕсли;
    ВывестиДанныеРКО = ВыборкаДляШапки.КоличествоРКО = 1;
    КонецЕсли;
    
  14. TopicStarter Overlay
    Patronus
    Offline

    Patronus

    Регистрация:
    9 фев 2012
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Все догнал, теперь все работает, если кому надо прикрепил ниже.

    Вложения:

  15. JaloHa
    Offline

    JaloHa

    Регистрация:
    23 апр 2013
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    столкнулась с такой же проблемой, скачала файл из последнего сообщения, но почему-то все равно дает ошибку Не удалось сформировать внешнюю печатную форму! Метод объекта не обнаружен (ГоловнаяОрганизация)
  16. TopicStarter Overlay
    Patronus
    Offline

    Patronus

    Регистрация:
    9 фев 2012
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    У Вас какая версия ЗУП стоит?
  17. rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
    В новых релизах ЗУП изменился(добален новый модуль, все процедуры и функции перешли на новый модуль) общий модуль ОбщегоНазначения на ОбщегоНазначенияЗК... Вопрос поднимался --> http://www.1c-pro.ru/topic50048.html/page__fromsearch__1
  18. Doska_New
    Offline

    Doska_New

    Регистрация:
    3 май 2014
    Сообщения:
    1
    Симпатии:
    1
    Баллы:
    1
    Вот форма с полным ФИО, переделывал для полного написания китайских рабочих. Автору топик стартера громадное спасибо, на основе его внешки всё и собрал, доработал. Так что у кого потребность милости просим, качайте, пользуйте на здоровье.

    Вложения:

    prowax нравится это.

Поделиться этой страницей