8.х Ошибка внешней обработки записи в ХМЛ 1С 8.2

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем Дмитрий Игоревич, 21 май 2013.

  1. TopicStarter Overlay
    Дмитрий Игоревич
    Offline

    Дмитрий Игоревич Опытный в 1С

    Регистрация:
    11 апр 2013
    Сообщения:
    152
    Симпатии:
    0
    Баллы:
    26
    Есть функция которая записывает значения в xml Если ЗначениеЗаполнено(СпрШабл.СчетДТ) И ЗначениеЗаполнено(СпрШабл.СчетКт) тогда он в файле задваевает строку а иначе все хорошо, не могу понять в чем дело,если кто знает подскажите. буду очень рад, вот код
    Код:
    Процедура КнопкаВыполнитьНажатие(Кнопка)
    
    Объект="";
    НачДата=НачалоМесяца(Константы.ДатаНачалаВыгрузкивФП.Получить());				 
    КонДата=КонецМесяца(Константы.ДатаОкончанияВыгрузкивФП.Получить()); 
    ДатаЦикла=НачДата;
    Пока КонецМесяца(ДатаЦикла)<= КонДата Цикл
    
    Анализатор = Новый ЗаписьXML;
    Анализатор.ОткрытьФайл(ПутьКФайлам+"\FinPlan_DIR_"+ ЭлементыФормы.Организация.Значение.ИНН+"_"+Лев(ДатаЦикла,2)+"_"+Сред(ДатаЦикла,4,2)+".xml");			
    Анализатор.ЗаписатьОбъявлениеXML();
    Анализатор.Отступ = Истина;
    
    Анализатор.ЗаписатьНачалоЭлемента("Фирма");
    Анализатор.ЗаписатьАтрибут("Period", Формат(ДатаЦикла,"дд.ММ.гггг"));
    Анализатор.ЗаписатьАтрибут("CodeFirm",ЭлементыФормы.Организация.Значение.ИНН);
    
    Анализатор.ЗаписатьНачалоЭлемента("Данные");
    ВременнаяТаблица=БазоваяТаблица(ДатаЦикла);
    ДатаЦикла=ДобавитьМесяц(ДатаЦикла,1);
    
    Для каждого СтрокаРезультата1 из ВременнаяТаблица Цикл  
    Анализатор.ЗаписатьНачалоЭлемента("Element");
    Анализатор.ЗаписатьАтрибут("KodStatii",Строка(СтрокаРезультата1.КодСтатьи));
    Анализатор.ЗаписатьАтрибут("CFO",Строка(СтрокаРезультата1.ЦфО));
    Анализатор.ЗаписатьАтрибут("Sum",Формат(СтрокаРезультата1.Сумма,"ЧЦ=15; ЧДЦ=2; ЧРД=.; ЧРГ=; ЧГ=0"));
    Анализатор.ЗаписатьАтрибут("SchetDt",Строка(СтрокаРезультата1.СчетДТ));
    Анализатор.ЗаписатьАтрибут("SubkontoDt1",Строка(СтрокаРезультата1.СубконтоДт1));
    Анализатор.ЗаписатьАтрибут("SubkontoDt2",Строка(СтрокаРезультата1.СубконтоДт2));
    Анализатор.ЗаписатьАтрибут("SubkontoDt3",Строка(СтрокаРезультата1.СубконтоДт3));
    Анализатор.ЗаписатьАтрибут("SchetKt",Строка(СтрокаРезультата1.СчетКт));
    Анализатор.ЗаписатьАтрибут("SubkontoKt1",Строка(СтрокаРезультата1.СубконтоКт1));
    Анализатор.ЗаписатьАтрибут("SubkontoKt2",Строка(СтрокаРезультата1.СубконтоКт2));
    Анализатор.ЗаписатьАтрибут("SubkontoKt3",Строка(СтрокаРезультата1.СубконтоКт3));
    Анализатор.ЗаписатьКонецЭлемента();
    КонецЦикла;
    
    Анализатор.ЗаписатьКонецЭлемента();
    Анализатор.ЗаписатьКонецЭлемента();
    //КонецЦикла;
    Анализатор.Закрыть();
    КонецЦикла;
    КонецПроцедуры
    Процедура ПолеВвода1НачалоВыбора(Элемент, СтандартнаяОбработка)
    Режим = РежимДиалогаВыбораФайла.ВыборКаталога;
    ДиалогОткрытияФайла = Новый ДиалогВыбораФайла(Режим);
    Если ПустаяСтрока(СокрЛП(ПутьКФайлам)) = Ложь Тогда
    ДиалогОткрытияФайла.Каталог = СокрЛП(ПутьКФайлам);
    КонецЕсли;
    ДиалогОткрытияФайла.Выбрать();
    ПутьКФайлам = ДиалогОткрытияФайла.Каталог;
    КонецПроцедуры
    Процедура ВыбПериодНажатие(Элемент)
    НастройкаПериода = Новый НастройкаПериода;
    НастройкаПериода.УстановитьПериод(НачПериода, ?(КонПериода='0001-01-01', КонПериода, КонецДня(КонПериода)));
    НастройкаПериода.РедактироватьКакИнтервал = Истина;
    НастройкаПериода.РедактироватьКакПериод = Истина;
    НастройкаПериода.ВариантНастройки = ВариантНастройкиПериода.Период;
    Если НастройкаПериода.Редактировать() Тогда
    НачПериода = НастройкаПериода.ПолучитьДатуНачала();
    КонПериода = НастройкаПериода.ПолучитьДатуОкончания();
    КонецЕсли;
    КонецПроцедуры
    Функция БазоваяТаблица(ДатаЦикла)
    
    ВременнаяТаблица = Новый ТаблицаЗначений;
    ВременнаяТаблица.Колонки.Добавить("КодСтатьи");
    ВременнаяТаблица.Колонки.Добавить("Цфо");
    ВременнаяТаблица.Колонки.Добавить("Сумма");
    ВременнаяТаблица.Колонки.Добавить("СчетДт");
    ВременнаяТаблица.Колонки.Добавить("СубконтоДт1");
    ВременнаяТаблица.Колонки.Добавить("СубконтоДт2");
    ВременнаяТаблица.Колонки.Добавить("СубконтоДт3");
    ВременнаяТаблица.Колонки.Добавить("СчетКт");
    ВременнаяТаблица.Колонки.Добавить("СубконтоКт1");
    ВременнаяТаблица.Колонки.Добавить("СубконтоКт2");
    ВременнаяТаблица.Колонки.Добавить("СубконтоКт3");
    СпрШабл = Справочники.ШаблонВыгрузкиФинПланСтатейРасходов.Выбрать();
    
    Пока СпрШабл.Следующий() Цикл
    Если СпрШабл.ПометкаУдаления=Истина тогда
    Продолжить;
    КонецЕсли;
    Если ЗначениеЗаполнено(СпрШабл.СчетДТ) И ЗначениеЗаполнено(СпрШабл.СчетКт) тогда
    //Формируем Запрос Между Счетами
    СписокСубконто1 = Новый СписокЗначений;
    СписокСубконто2 = Новый СписокЗначений;
    СписокСубконто3 = Новый СписокЗначений;
    СписокСубконто11 = Новый СписокЗначений;
    СписокСубконто22 = Новый СписокЗначений;
    СписокСубконто33 = Новый СписокЗначений;
    Если ЗначениеЗаполнено(СпрШабл.СубконтоДт1)=Истина тогда
    СписокСубконто1.Добавить(СпрШабл.СубконтоДт1);
    КонецЕсли; 
    Если ЗначениеЗаполнено(СпрШабл.СубконтоДт2)=Истина тогда
    СписокСубконто2.Добавить(СпрШабл.СубконтоДт2);
    КонецЕсли;
    Если ЗначениеЗаполнено(СпрШабл.СубконтоДт3)=Истина тогда
    СписокСубконто3.Добавить(СпрШабл.СубконтоДт3);
    КонецЕсли;
    Если ЗначениеЗаполнено(СпрШабл.СубконтоКт1)=Истина тогда
    СписокСубконто11.Добавить(СпрШабл.СубконтоКт1);
    КонецЕсли; 
    Если ЗначениеЗаполнено(СпрШабл.СубконтоКт2)=Истина тогда
    СписокСубконто22.Добавить(СпрШабл.СубконтоКт2);
    КонецЕсли;
    Если ЗначениеЗаполнено(СпрШабл.СубконтоКт3)=Истина тогда
    СписокСубконто33.Добавить(СпрШабл.СубконтоКт3);
    КонецЕсли;
    
    // Запрос тело запроса
    Запрос = Новый Запрос;
    Запрос.Текст = "
    |ВЫБРАТЬ
    |ХозрасчетныйОбороты.Организация КАК Организация,
    |ХозрасчетныйОбороты.Счет КАК Счет,";
    Если (СписокСубконто1.Количество()>0) тогда
    Запрос.Текст =Запрос.Текст + "
    |ХозрасчетныйОбороты.Субконто1 КАК Субконто1,";
    КонецЕсли;
    Если (СписокСубконто2.Количество()>0) тогда
    Запрос.Текст =Запрос.Текст + "
    |ХозрасчетныйОбороты.Субконто2 КАК Субконто2,";
    КонецЕсли;
    Если (СписокСубконто3.Количество()>0) тогда
    Запрос.Текст =Запрос.Текст + "
    |ХозрасчетныйОбороты.Субконто3 КАК Субконто3,";
    КонецЕсли;
    Если (СписокСубконто11.Количество()>0) тогда
    Запрос.Текст =Запрос.Текст + "
    |ХозрасчетныйОбороты.КорСубконто1 КАК КорСубконто1,";
    КонецЕсли;
    Если (СписокСубконто22.Количество()>0) тогда
    Запрос.Текст =Запрос.Текст + "
    |ХозрасчетныйОбороты.КорСубконто2 КАК КорСубконто2,";
    КонецЕсли;
    Если (СписокСубконто33.Количество()>0) тогда
    Запрос.Текст =Запрос.Текст + "
    |ХозрасчетныйОбороты.КорСубконто3 КАК КорСубконто3,";
    КонецЕсли;
    Запрос.Текст =Запрос.Текст + "
    |ХозрасчетныйОбороты.СуммаОборот,
    |ХозрасчетныйОбороты.СуммаОборотДт,
    |ХозрасчетныйОбороты.СуммаОборотКт
    |ИЗ
    |РегистрБухгалтерии.Хозрасчетный.Обороты(&НачДата, &КонДата, Период, , , , , ) КАК ХозрасчетныйОбороты
    |ГДЕ
    |ХозрасчетныйОбороты.Счет В ИЕРАРХИИ(&СписокКодов)
    |И ХозрасчетныйОбороты.КорСчет В ИЕРАРХИИ(&СписокКодовКорСчетов)
    |И ХозрасчетныйОбороты.Организация = &Организация ";
    Если (СписокСубконто1.Количество()>0) тогда
    Запрос.Текст =Запрос.Текст + "
    |И ХозрасчетныйОбороты.Субконто1 В(&СписокСубконто1)";
    КонецЕсли;
    Если (СписокСубконто2.Количество()>0) тогда
    Запрос.Текст =Запрос.Текст + "
    |И ХозрасчетныйОбороты.Субконто2 В(&СписокСубконто2)";
    КонецЕсли;
    Если (СписокСубконто3.Количество()>0) тогда
    Запрос.Текст =Запрос.Текст + "
    |И ХозрасчетныйОбороты.Субконто3 В(&СписокСубконто3)";
    КонецЕсли;
    Если (СписокСубконто11.Количество()>0) тогда
    Запрос.Текст =Запрос.Текст + "
    |И ХозрасчетныйОбороты.КорСубконто1 В(&СписокСубконто11)";
    КонецЕсли;
    Если (СписокСубконто22.Количество()>0) тогда
    Запрос.Текст =Запрос.Текст + "
    |И ХозрасчетныйОбороты.КорСубконто2 В(&СписокСубконто22)";
    КонецЕсли;
    Если (СписокСубконто33.Количество()>0) тогда
    Запрос.Текст =Запрос.Текст + "
    |И ХозрасчетныйОбороты.КорСубконто3 В(&СписокСубконто33)";
    КонецЕсли;
    Запрос.Текст =Запрос.Текст + "
    |СГРУППИРОВАТЬ ПО
    |ХозрасчетныйОбороты.Счет,
    |ХозрасчетныйОбороты.Организация,";
    Если (СписокСубконто1.Количество()>0) тогда
    Запрос.Текст =Запрос.Текст + "
    |ХозрасчетныйОбороты.Субконто1,";
    КонецЕсли;
    Если (СписокСубконто2.Количество()>0) тогда
    Запрос.Текст =Запрос.Текст + "
    |ХозрасчетныйОбороты.Субконто2,";
    КонецЕсли;
    Если (СписокСубконто3.Количество()>0) тогда
    Запрос.Текст =Запрос.Текст + "
    |ХозрасчетныйОбороты.Субконто3,";
    КонецЕсли;
    Если (СписокСубконто11.Количество()>0) тогда
    Запрос.Текст =Запрос.Текст + "
    |ХозрасчетныйОбороты.КорСубконто1,";
    КонецЕсли;
    Если (СписокСубконто22.Количество()>0) тогда
    Запрос.Текст =Запрос.Текст + "
    |ХозрасчетныйОбороты.КорСубконто2,";
    КонецЕсли;
    Если (СписокСубконто33.Количество()>0) тогда
    Запрос.Текст =Запрос.Текст + "
    |ХозрасчетныйОбороты.КорСубконто3,";
    КонецЕсли;
    Запрос.Текст =Запрос.Текст + "
    |ХозрасчетныйОбороты.СуммаОборот,
    |ХозрасчетныйОбороты.СуммаОборотДт,
    |ХозрасчетныйОбороты.СуммаОборотКт
    |УПОРЯДОЧИТЬ ПО
    |Счет,
    |Организация";
    // Запрос тело запроса
    
    ДатНач = НачалоМесяца(ДатаЦикла);
    ДатКон = КонецМесяца(ДатаЦикла);
    
    СписокСчетов = Новый СписокЗначений;
    СписокСчетов1 = Новый СписокЗначений;
    
    СписокСчетов.Добавить(СпрШабл.СчетДТ);
    СписокСчетов1.Добавить(СпрШабл.СчетКТ);
    
    Запрос.УстановитьПараметр("СписокКодов",СписокСчетов);
    Запрос.УстановитьПараметр("СписокКодовКорСчетов",СписокСчетов1);
    Запрос.УстановитьПараметр("Организация",Организация.Ссылка);
    Запрос.УстановитьПараметр("НачДата", ?( ЗначениеЗаполнено(СпрШабл.ДатаНачала)<>Истина,НачалоДня(ДатНач),Макс(НачалоДня(ДатНач),НачалоДня(СпрШабл.ДатаНачала))));
    Запрос.УстановитьПараметр("КонДата", ?( ЗначениеЗаполнено(СпрШабл.ДатаКонца)<>Истина,КонецДня(ДатКон),Мин(КонецДня(ДатКон),КонецДня(СпрШабл.ДатаКонца))));
    Запрос.УстановитьПараметр("СписокСубконто1",СписокСубконто1);
    Запрос.УстановитьПараметр("СписокСубконто2",СписокСубконто2);
    Запрос.УстановитьПараметр("СписокСубконто3",СписокСубконто3);
    Запрос.УстановитьПараметр("СписокСубконто11",СписокСубконто11);
    Запрос.УстановитьПараметр("СписокСубконто22",СписокСубконто22);
    Запрос.УстановитьПараметр("СписокСубконто33",СписокСубконто33);
    
    ТаблицаДокументов = Запрос.Выполнить().Выгрузить(ОбходРезультатаЗапроса.ПоГруппировкам);
    
    Для Каждого СтрокаРезультата Из ТаблицаДокументов.Строки Цикл
    НовСтр=ВременнаяТаблица.Добавить();
    НовСтр.КодСтатьи=СпрШабл.СтатьяБДРС.КодСтатьи;
    НовСтр.ЦФО=СпрШабл.ЦФО;
    Если СпрШабл.ИсключениеП=Ложь Тогда 
    НовСтр.Сумма=СтрокаРезультата.СуммаОборот;
    Иначе
    НовСтр.Сумма=СтрокаРезультата.СуммаОборот*(-1);
    КонецЕсли;
    НовСтр.СчетДт=СпрШабл.СчетДТ;
    НовСтр.СубконтоДт1=СпрШабл.СубконтоДт1;
    НовСтр.СубконтоДт2=СпрШабл.СубконтоДт2;
    НовСтр.СубконтоДт3=СпрШабл.СубконтоДт3;
    НовСтр.СчетКт=СпрШабл.СчетКт;
    НовСтр.СубконтоКт1=СпрШабл.СубконтоКт1;
    НовСтр.СубконтоКт2=СпрШабл.СубконтоКт2;
    НовСтр.СубконтоКт3=СпрШабл.СубконтоКт3;
    
    КонецЦикла;																					  
    
    ИначеЕсли  ЗначениеЗаполнено(СпрШабл.СчетДТ) ИЛИ ЗначениеЗаполнено(СпрШабл.СчетКт) Тогда
    
    //Выполняем запрос либо по СчетуДТ либо по СчетуКт
    СписокСубконто1 = Новый СписокЗначений;								 
    СписокСубконто2 = Новый СписокЗначений;
    СписокСубконто3 = Новый СписокЗначений;
    СписокСчетов = Новый СписокЗначений;
    
    Если ЗначениеЗаполнено(СпрШабл.СчетДТ)  тогда
    СписокСчетов.Добавить(СпрШабл.СчетДТ); 
    Если ЗначениеЗаполнено(СпрШабл.СубконтоДт1)=Истина тогда
    СписокСубконто1.Добавить(СпрШабл.СубконтоДт1);
    КонецЕсли; 
    Если ЗначениеЗаполнено(СпрШабл.СубконтоДт2)=Истина тогда
    СписокСубконто2.Добавить(СпрШабл.СубконтоДт2);
    КонецЕсли; 
    Если ЗначениеЗаполнено(СпрШабл.СубконтоДт3)=Истина тогда
    СписокСубконто3.Добавить(СпрШабл.СубконтоДт3);
    КонецЕсли;
    ИначеЕсли ЗначениеЗаполнено(СпрШабл.СчетКт)  Тогда
    СписокСчетов.Добавить(СпрШабл.СчетКт);
    Если ЗначениеЗаполнено(СпрШабл.СубконтоКт1)=Истина тогда
    СписокСубконто1.Добавить(СпрШабл.СубконтоКт1);
    КонецЕсли; 
    Если ЗначениеЗаполнено(СпрШабл.СубконтоКт2)=Истина тогда
    СписокСубконто2.Добавить(СпрШабл.СубконтоКт2);
    КонецЕсли;
    Если ЗначениеЗаполнено(СпрШабл.СубконтоКт3)=Истина тогда
    СписокСубконто3.Добавить(СпрШабл.СубконтоКт3);
    КонецЕсли;
    КонецЕсли;
    
    Запрос = Новый Запрос;
    Запрос.Текст = "
    |ВЫБРАТЬ
    |ХозрасчетныйОбороты.Организация КАК Организация,
    |ХозрасчетныйОбороты.Счет КАК Счет,";
    Если (СписокСубконто1.Количество()>0) тогда
    Запрос.Текст =Запрос.Текст + "
    |ХозрасчетныйОбороты.Субконто1 КАК Субконто1,";
    КонецЕсли;
    Если (СписокСубконто2.Количество()>0) тогда
    Запрос.Текст =Запрос.Текст + "
    |ХозрасчетныйОбороты.Субконто2 КАК Субконто2,";
    КонецЕсли;
    Если (СписокСубконто3.Количество()>0) тогда
    Запрос.Текст =Запрос.Текст + "
    |ХозрасчетныйОбороты.Субконто3 КАК Субконто3,";
    КонецЕсли;
    Запрос.Текст =Запрос.Текст + "
    |ХозрасчетныйОбороты.СуммаОборот,
    |ХозрасчетныйОбороты.СуммаОборотДт,
    |ХозрасчетныйОбороты.СуммаОборотКт
    |ИЗ
    |РегистрБухгалтерии.Хозрасчетный.Обороты(&НачДата, &КонДата, Период, , , , , ) КАК ХозрасчетныйОбороты
    |ГДЕ
    |ХозрасчетныйОбороты.Счет В ИЕРАРХИИ(&СписокКодов)
    |И ХозрасчетныйОбороты.Организация = &Организация ";
    Если (СписокСубконто1.Количество()>0) тогда
    Запрос.Текст =Запрос.Текст + "
    |И ХозрасчетныйОбороты.Субконто1 В(&СписокСубконто1)";
    КонецЕсли;
    Если (СписокСубконто2.Количество()>0) тогда
    Запрос.Текст =Запрос.Текст + "
    |И ХозрасчетныйОбороты.Субконто2 В(&СписокСубконто2)";
    КонецЕсли;
    Если (СписокСубконто3.Количество()>0) тогда
    Запрос.Текст =Запрос.Текст + "
    |И ХозрасчетныйОбороты.Субконто3 В(&СписокСубконто3)";
    КонецЕсли;
    Запрос.Текст =Запрос.Текст + "
    |СГРУППИРОВАТЬ ПО
    |ХозрасчетныйОбороты.Счет,
    |ХозрасчетныйОбороты.Организация,";
    Если (СписокСубконто1.Количество()>0) тогда
    Запрос.Текст =Запрос.Текст + "
    |ХозрасчетныйОбороты.Субконто1,";
    КонецЕсли;
    Если (СписокСубконто2.Количество()>0) тогда
    Запрос.Текст =Запрос.Текст + "
    |ХозрасчетныйОбороты.Субконто2,";
    КонецЕсли;
    Если (СписокСубконто3.Количество()>0) тогда
    Запрос.Текст =Запрос.Текст + "
    |ХозрасчетныйОбороты.Субконто3,";
    КонецЕсли;
    Запрос.Текст =Запрос.Текст + "
    |ХозрасчетныйОбороты.СуммаОборот,
    |ХозрасчетныйОбороты.СуммаОборотДт,
    |ХозрасчетныйОбороты.СуммаОборотКт
    |УПОРЯДОЧИТЬ ПО
    |Счет,		 
    |Организация";
    
    ДатНач = НачалоМесяца(ДатаЦикла);
    ДатКон = КонецМесяца(ДатаЦикла);
    
    Запрос.УстановитьПараметр("СписокКодов",СписокСчетов);
    Запрос.УстановитьПараметр("Организация",Организация.Ссылка);
    Запрос.УстановитьПараметр("НачДата", ?( ЗначениеЗаполнено(СпрШабл.ДатаНачала)<>Истина,НачалоДня(ДатНач),Макс(НачалоДня(ДатНач),НачалоДня(СпрШабл.ДатаНачала))));
    Запрос.УстановитьПараметр("КонДата", ?( ЗначениеЗаполнено(СпрШабл.ДатаКонца)<>Истина,КонецДня(ДатКон),Мин(КонецДня(ДатКон),КонецДня(СпрШабл.ДатаКонца))));
    Запрос.УстановитьПараметр("СписокСубконто1",СписокСубконто1);
    Запрос.УстановитьПараметр("СписокСубконто2",СписокСубконто2);
    Запрос.УстановитьПараметр("СписокСубконто3",СписокСубконто3);
    ТаблицаДокументов = Запрос.Выполнить().Выгрузить(ОбходРезультатаЗапроса.ПоГруппировкам);
    Для Каждого СтрокаРезультата Из ТаблицаДокументов.Строки Цикл	
    НовСтр=ВременнаяТаблица.Добавить();
    НовСтр.КодСтатьи=СпрШабл.СтатьяБДРС.КодСтатьи;
    НовСтр.ЦФО=СпрШабл.ЦФО;
    Если СпрШабл.ИсключениеП=Ложь Тогда 
    Если ЗначениеЗаполнено(СпрШабл.СчетДТ)  Тогда
    НовСтр.Сумма=СтрокаРезультата.СуммаОборотДт;
    ИначеЕсли ЗначениеЗаполнено(СпрШабл.СчетКт) Тогда
    НовСтр.Сумма=СтрокаРезультата.СуммаОборотКт;
    КонецЕсли;
    Иначе
    Если ЗначениеЗаполнено(СпрШабл.СчетДТ) Тогда
    НовСтр.Сумма=СтрокаРезультата.СуммаОборотДт*(-1);
    ИначеЕсли  ЗначениеЗаполнено(СпрШабл.СчетКт) Тогда
    НовСтр.Сумма=СтрокаРезультата.СуммаОборотКт*(-1);
    КонецЕсли;
    КонецЕсли;
    НовСтр.СчетДт=СпрШабл.СчетДТ;
    НовСтр.СубконтоДт1=СпрШабл.СубконтоДт1;
    НовСтр.СубконтоДт2=СпрШабл.СубконтоДт2;
    НовСтр.СубконтоДт3=СпрШабл.СубконтоДт3;
    НовСтр.СчетКт=СпрШабл.СчетКт;
    НовСтр.СубконтоКт1=СпрШабл.СубконтоКт1;
    НовСтр.СубконтоКт2=СпрШабл.СубконтоКт2;
    НовСтр.СубконтоКт3=СпрШабл.СубконтоКт3;
    КонецЦикла;				 
    КонецЕсли;
    КонецЦикла;
    ВременнаяТаблица.Свернуть("КодСтатьи,ЦФО,СчетДт,СубконтоДт1,СубконтоДт2,СубконтоДт3,СчетКт,СубконтоКт1,СубконтоКт2,СубконтоКт3","Сумма");
    ВременнаяТаблица.Сортировать("КодСтатьи");
    Возврат(ВременнаяТаблица);
    КонецФункции
    
  2. TopicStarter Overlay
    Дмитрий Игоревич
    Offline

    Дмитрий Игоревич Опытный в 1С

    Регистрация:
    11 апр 2013
    Сообщения:
    152
    Симпатии:
    0
    Баллы:
    26
    Решено в коде все правильно в данных был косяк

Поделиться этой страницей