8.х Ошибка в переборе документа

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Letos, 3 фев 2010.

  1. TopicStarter Overlay
    Letos
    Offline

    Letos Опытный в 1С

    Регистрация:
    23 ноя 2009
    Сообщения:
    218
    Симпатии:
    0
    Баллы:
    26
    Необходимо устроить пересчет всех позиций в документе "Реализация товара", на один товар я сделал а вот с несколькими возникла проблема.
    Код:
    	
    СтрокаТабЧасти=ЭФ.Товары.ТекущиеДанные; 
    
    Если СкидкаНаВсё Тогда  			
    Для каждого ТекущаяСтрока из Товары Цикл 
    
    Цена=СтрокаТабЧасти.Цена;  				
    Результат  = Цена-((Цена/100)*скидка);  				
    СтрокаТабЧасти.Цена=строка(Результат);  				
    ТоварыЦенаПриИзменении(Элемент);  				
    КонецЦикла;  
    
    
    он проходит по всем имеющимся позициям, сколько позиций столько раз расчитывает скидку, но для Текущих данных. Что нужно использовать вместо ТекущиеДанные что бы расчитывалось для каждого.
  2. ASh
    Offline

    ASh Опытный в 1С

    Регистрация:
    10 сен 2008
    Сообщения:
    568
    Симпатии:
    0
    Баллы:
    26
    Код:
    //Должна быть определена переменная с именем "Скидка"
    Если СкидкаНаВсё Тогда  			
    Для Каждого ТекущаяСтрока Из Товары Цикл
    ТекущаяСтрока.Цена = ТекущаяСтрока.Цена-((ТекущаяСтрока.Цена/100)*Скидка);
    ЭлементыФормы.Товары.ТекущаяСтрока = ТекущаяСтрока;
    ТоварыЦенаПриИзменении(Скидка);
    КонецЦикла;
    КонецЕсли;
    
  3. TopicStarter Overlay
    Letos
    Offline

    Letos Опытный в 1С

    Регистрация:
    23 ноя 2009
    Сообщения:
    218
    Симпатии:
    0
    Баллы:
    26
    Все заработало, спасибо. :unsure:

Поделиться этой страницей