8.х Ошибка в коде

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем pvkInside, 6 дек 2009.

  1. TopicStarter Overlay
    pvkInside
    Offline

    pvkInside

    Регистрация:
    18 авг 2009
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Выдает вот такую ошибку:
    {Документ.РеализацияТоваровУслуг.Форма.ФормаСписка(159)}: Поле объекта не обнаружено (Реализация)
    Соответствие[Выборка.Реализация].Ячейки.Остаток.Значение=Выборка.СуммаПлатежки+Выборка.СуммаКО;



    А вот сам код:

    Код:
    Процедура СписокПриПолученииДанных(Элемент, ОформленияСтрок)
    
    Соответствие = Новый Соответствие;
    МассивСтрок = Новый Массив;
    Для каждого Стр из ОформленияСтрок Цикл
    Если Стр.ДанныеСтроки = Неопределено Тогда
    Продолжить;
    КонецЕсли; 
    
    МассивСтрок.Добавить(Стр.ДанныеСтроки.Ссылка);
    Соответствие.Вставить(Стр.ДанныеСтроки.Ссылка, Стр);
    
    КонецЦикла;
    
    ЗапросОстатка=Новый Запрос;
    ЗапросОстатка.Текст="ВЫБРАТЬ
    |	Заказ.СделкаРеализации,
    |	Заказ.СуммаРеализации,
    |	Заказ.ЗаказПокупателя,
    |	Заказ.СуммаЗаказа,
    |	КО.СделкаНаЗаказ,
    |	КО.СуммаКО,
    |	Платежка.СделкаНаЗаказОтПлатежки,
    |	Платежка.СуммаПлатежки
    |ИЗ
    |	(ВЫБРАТЬ
    |		РеализацияТоваровУслуг.Сделка КАК СделкаРеализации,
    |		ЕСТЬNULL(РеализацияТоваровУслуг.СуммаДокумента, 0) КАК СуммаРеализации,
    |		ЗаказПокупателя.Ссылка КАК ЗаказПокупателя,
    |		ЕСТЬNULL(ЗаказПокупателя.СуммаДокумента, 0) КАК СуммаЗаказа,
    |		РеализацияТоваровУслуг.Ссылка КАК Реализация
    |	ИЗ
    |		Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
    |			ЛЕВОЕ СОЕДИНЕНИЕ Документ.ЗаказПокупателя КАК ЗаказПокупателя
    |			ПО РеализацияТоваровУслуг.Сделка = ЗаказПокупателя.Ссылка
    |	ГДЕ
    |		ЗаказПокупателя.Проведен = ИСТИНА
    |		И РеализацияТоваровУслуг.Проведен = ИСТИНА
    |		И РеализацияТоваровУслуг.Ссылка В(&Ссылка)) КАК Заказ
    |		ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
    |			ЗаказПокупателя.Ссылка КАК СсылкаЗаказа,
    |			ЕСТЬNULL(ЗаказПокупателя.СуммаДокумента, 0) КАК СуммаЗаказа,
    |			ПриходныйКассовыйОрдерРасшифровкаПлатежа.Сделка КАК СделкаНаЗаказ,
    |			ЕСТЬNULL(ПриходныйКассовыйОрдерРасшифровкаПлатежа.СуммаПлатежа, 0) КАК СуммаКО
    |		ИЗ
    |			Документ.ПриходныйКассовыйОрдер.РасшифровкаПлатежа КАК ПриходныйКассовыйОрдерРасшифровкаПлатежа
    |				ЛЕВОЕ СОЕДИНЕНИЕ Документ.ЗаказПокупателя КАК ЗаказПокупателя
    |				ПО ПриходныйКассовыйОрдерРасшифровкаПлатежа.Сделка = ЗаказПокупателя.Ссылка
    |		ГДЕ
    |			ЗаказПокупателя.Проведен = ИСТИНА
    |			И ПриходныйКассовыйОрдерРасшифровкаПлатежа.Ссылка.Проведен = ИСТИНА) КАК КО
    |		ПО Заказ.ЗаказПокупателя.Ссылка = КО.СделкаНаЗаказ
    |		ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
    |			ЗаказПокупателя.Ссылка КАК СсылкаЗаказа,
    |			ЕСТЬNULL(ЗаказПокупателя.СуммаДокумента, 0) КАК СуммаЗаказа,
    |			ПлатежноеПоручениеВходящееРасшифровкаПлатежа.Сделка КАК СделкаНаЗаказОтПлатежки,
    |			ЕСТЬNULL(ПлатежноеПоручениеВходящееРасшифровкаПлатежа.СуммаПлатежа, 0) КАК СуммаПлатежки
    |		ИЗ
    |			Документ.ПлатежноеПоручениеВходящее.РасшифровкаПлатежа КАК ПлатежноеПоручениеВходящееРасшифровкаПлатежа
    |				ЛЕВОЕ СОЕДИНЕНИЕ Документ.ЗаказПокупателя КАК ЗаказПокупателя
    |				ПО ПлатежноеПоручениеВходящееРасшифровкаПлатежа.Сделка = ЗаказПокупателя.Ссылка
    |		ГДЕ
    |			ЗаказПокупателя.Проведен = ИСТИНА
    |			И ПлатежноеПоручениеВходящееРасшифровкаПлатежа.Ссылка.Проведен = ИСТИНА) КАК Платежка
    |		ПО Заказ.ЗаказПокупателя.Ссылка = Платежка.СделкаНаЗаказОтПлатежки";
    
    ЗапросОстатка.УстановитьПараметр("Ссылка",МассивСтрок);
    Выборка=ЗапросОстатка.Выполнить().Выбрать();
    
    Пока Выборка.Следующий() Цикл
    
    //Соответствие[Выборка.Реализация].Ячейки.Остаток.Значение=Выборка.СуммаПлатежа;
    //Соответствие[Выборка.Реализация].Ячейки.ОстОпл.Значение=Выборка.СуммаДокумента-Выборка.СуммаПлатежа;
    
    Соответствие[Выборка.Реализация].Ячейки.Остаток.Значение=Выборка.СуммаПлатежки+Выборка.СуммаКО;
    Соответствие[Выборка.Реализация].Ячейки.ОстОпл.Значение=Выборка.СуммаРеализации-Выборка.СуммаПлатежки-Выборка.СуммаКО;
    
    КонецЦикла;
    
    КонецПроцедуры
    
    
    Помогите, а то не могу разобраться сам... ОЧень срочно надо
  2. ASh
    Offline

    ASh Опытный в 1С

    Регистрация:
    10 сен 2008
    Сообщения:
    568
    Симпатии:
    0
    Баллы:
    26
    У Вас в выборке нет поля "Реализация" - вот и ошибка. Попробуйте написать
    Код:
    Соответствие[Выборка.СделкаРеализации]...
    

Поделиться этой страницей