7.7 ошибка типовой зик 7.70.336

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем LED82, 29 апр 2013.

  1. TopicStarter Overlay
    LED82
    Offline

    LED82 Опытный в 1С

    Регистрация:
    27 июн 2012
    Сообщения:
    66
    Симпатии:
    0
    Баллы:
    26
    Сейчас полазил по матпомощи за рождение ребенка действительно в расчете стоит ноль
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Документ актуален?
  3. TopicStarter Overlay
    LED82
    Offline

    LED82 Опытный в 1С

    Регистрация:
    27 июн 2012
    Сообщения:
    66
    Симпатии:
    0
    Баллы:
    26
    да актуален платилась мадпомощь на рождение ребенка в графе вычет стоит ноль

    попробую сделать как вы сказали отпишусь о результате
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
  5. TopicStarter Overlay
    LED82
    Offline

    LED82 Опытный в 1С

    Регистрация:
    27 июн 2012
    Сообщения:
    66
    Симпатии:
    0
    Баллы:
    26
    Спасибо все получилось как вы сказали
    нашел еще один способ как обойти эту ошибку


    Процедура ЗаполнитьСуммуВычетНаДетей()

    Док = СоздатьОбъект("Документ.НачисленияУдержанияСотрудника");
    Док.УстановитьФильтр(1,0);// добавил вот сюда переборку фильтром не учитывает не проведенные документы
    Док.ВыбратьДокументы();

    РазмерСкидкаМатпомощьПриРожденииРебенка = 0;
    СпрВычетов = СоздатьОбъект("Справочник.СтраховыеВзносыСкидкиКДоходам");
    СпрВычетов.НайтиПоКоду("МатпомощьПриРождРебенка");

    Пока Док.ПолучитьДокумент()=1 Цикл

    Если глТипВидЗначения(Док.Расчет)="ВидРасчета" Тогда
    Расчет = ВидРасчета.ПолучитьАтрибут(Док.Расчет.Код);
    Если Расчет = ВидРасчета.МатПомощьПриРожденииРебенка Тогда
    РазмерСкидкаМатпомощьПриРожденииРебенка = ?(СпрВычетов.Выбран()=1,СпрВычетов.ГодоваяСкидка.Получить(НачГода(Док.ДатаДок)),0);
    Док.СуммаВычета = Мин(Док.Величина,Док.КоличествоДетей * РазмерСкидкаМатпомощьПриРожденииРебенка);
    Док.Записать();
    КонецЕсли;
    КонецЕсли;


    КонецЦикла;

    КонецПроцедуры

Поделиться этой страницей