8.х Ошибка совместного доступа к файлу

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Вселенная, 22 дек 2011.

  1. TopicStarter Overlay
    Вселенная
    Offline

    Вселенная Опытный в 1С

    Регистрация:
    4 ноя 2009
    Сообщения:
    176
    Симпатии:
    0
    Баллы:
    26
    Есть обработка по выгрузке некоторых данных в файл xml. Возникает такая ошибка:
    Ошибка при вызове метода контекста (ОткрытьФайл): Ошибка совместного доступа к файлу 'E:\\документ.xml' Запись.ОткрытьФайл(ИмяФайла,"UTF-8");

    Код:
    Запрос.УстановитьПараметр("Родитель", ЭлементыФормы.Группа.Значение);
    Выборка = Запрос.Выполнить().Выбрать();
    
    Если ПустаяСтрока(ИмяФайла) Тогда
    Предупреждение("Укажите файл данных XML для выгрузки!");
    Возврат;
    КонецЕсли;
    Файл = Новый Файл(ИмяФайла);
    Если Файл.Существует() Тогда
    Ответ = Вопрос("Файл " + ИмяФайла + " существует. Заменить?",РежимДиалогаВопрос.ДаНет);
    Если Ответ = КодВозвратаДиалога.Нет Тогда
    Сообщить("Сохранение отменено.");
    Возврат;
    КонецЕсли;
    КонецЕсли;
    
    ТекстФайл = Новый ЗаписьТекста(ИмяФайла, КодировкаТекста.UTF8);
    
    Запись = Новый ЗаписьXML; 
    Запись.ОткрытьФайл(ИмяФайла,"UTF-8"); 
    Запись.ЗаписатьОбъявлениеXML(); 
    Запись.ЗаписатьНачалоЭлемента("_1CV8DtUD", "http://www.1c.ru/V8/1CV8DtUD/"); 
    Запись.ЗаписатьСоответствиеПространстваИмен("V8Exch", "http://www.1c.ru/V8/1CV8DtUD/");
    Запись.ЗаписатьСоответствиеПространстваИмен("xsi", "http://www.w3.org/2001/XMLSchema-instance");
    Запись.ЗаписатьСоответствиеПространстваИмен("v8",  "http://v8.1c.ru/data");
    Запись.ЗаписатьНачалоЭлемента("V8Exch:Data");
    
    Пока Выборка.Следующий() Цикл 
    
    Запись.ЗаписатьНачалоЭлемента("Элемент"); 
    .......
    
    Запись.ЗаписатьКонецЭлемента(); 
    КонецЦикла; 
    
    Запись.ЗаписатьКонецЭлемента(); 
    
    ТекстФайл.Записать(Запись.Закрыть());
    ТекстФайл.Закрыть();
    
    
    Запись.Закрыть();
    
    
    Подскажите, в чем может быть дело?
  2. leemuar
    Offline

    leemuar Опытный в 1С

    Регистрация:
    21 окт 2010
    Сообщения:
    310
    Симпатии:
    0
    Баллы:
    26
    Вероятно файл уже отрыт другим сеансом или приложением
  3. TopicStarter Overlay
    Вселенная
    Offline

    Вселенная Опытный в 1С

    Регистрация:
    4 ноя 2009
    Сообщения:
    176
    Симпатии:
    0
    Баллы:
    26
    нет, не открыт. Я уже и перезагружалась, без толку :angry:
  4. uza
    Offline

    uza 1С, VBA (EXCEL), VB (.NET + WEB)

    Регистрация:
    10 июл 2007
    Сообщения:
    1.845
    Симпатии:
    1
    Баллы:
    29
    А что приходит в ИмяФайла?
    Если "E:\\документ.xml" - то это неправильный путь к файлу. Ибо правильный "E:\документ.xml", возможно.
  5. TopicStarter Overlay
    Вселенная
    Offline

    Вселенная Опытный в 1С

    Регистрация:
    4 ноя 2009
    Сообщения:
    176
    Симпатии:
    0
    Баллы:
    26
    Там всё правильно, я просто не стала сюда весь путь копировать :angry:
  6. TopicStarter Overlay
    Вселенная
    Offline

    Вселенная Опытный в 1С

    Регистрация:
    4 ноя 2009
    Сообщения:
    176
    Симпатии:
    0
    Баллы:
    26
    Неужели никто не сталкивался с такой ошибкой?
  7. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Ошибка у Вас в коде где-то.

    Откуда получаете имя файла?
  8. uza
    Offline

    uza 1С, VBA (EXCEL), VB (.NET + WEB)

    Регистрация:
    10 июл 2007
    Сообщения:
    1.845
    Симпатии:
    1
    Баллы:
    29
    А файл вообще доступен для записи?
    А то может у Вас прав нет на запись.

    А ОС какая? Не Vista/7ка ли - а то они "из коробки" любят ограничивать доступ к файлам разным прогам.
  9. TopicStarter Overlay
    Вселенная
    Offline

    Вселенная Опытный в 1С

    Регистрация:
    4 ноя 2009
    Сообщения:
    176
    Симпатии:
    0
    Баллы:
    26
    ИмяФайла - реквизит обработки, типа Строка. Поле ввода на форме с данными ИмяФайла.
  10. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    вот нашла такую инфу, сама не пробовала
    обратите внимание. в примере в имени файла наклон разделителей в другую сторону (возможно конечно это не влияет, но все же....)
  11. TopicStarter Overlay
    Вселенная
    Offline

    Вселенная Опытный в 1С

    Регистрация:
    4 ноя 2009
    Сообщения:
    176
    Симпатии:
    0
    Баллы:
    26
    Проблема решилась. Я убрала
    Код:
    Запись.ОткрытьФайл(ИмяФайла,"UTF-8");
    
    и вставила
    Код:
    Запись.УстановитьСтроку("UTF-8");
    
    

Поделиться этой страницей