7.7 Ошибка: Сформировать(<<?>>) Недостаточно фактических параметров

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Natalia_k, 6 окт 2010.

  1. TopicStarter Overlay
    Natalia_k
    Offline

    Natalia_k Опытный в 1С

    Регистрация:
    8 сен 2009
    Сообщения:
    153
    Симпатии:
    0
    Баллы:
    26
    Всем привет!
    Помогите, пожалуйста, исправить ошибку.
    Я хочу программно записать данные в шаблон Word.
    Выскакивает ошибка Сформировать(<<?>>)
    Недостаточно фактических параметров

    Как её исправить?
    Код:
    Процедура Сформировать(Докум)
    
    
    Перем Группа, ФИО, РД, ПАдрес,  ДатаДоговораНПО, НомерДоговораНПО, ДоговорУчредителя, НомерДоговораПД, ДатаНач, ПенсДог;
    Перем НомерДок, НомерДок1, ДоговорВкладчика, Дог, Код1, ДатаДок;      
    
    
    
    Спр=СоздатьОбъект("Справочник.Договоры");
    Спр=СоздатьОбъект("Справочник.Контрагенты"); 
    Спр. ИспользоватьДату(РабочаяДата());                 
    
    
    
    Вкладчик=Докум.Вкладчик; 
    Договор=Докум.Договор;
    ДатаДок=Докум.ДатаДок; 
    
    
    ДАТА_ОТВЕТА_ПОЛУЧ =  формат(Докум.ДатаДок,"Д (0)ДДММММГГГГ");
    
    ПутьШаблона = СокрЛП(КаталогИБ()+"\ExtForms\шаблон.dot");
    Если ФС.СуществуетФайл(ПутьШаблона)=0 Тогда
    Предупреждение("Не найден файл "+ПутьШаблона); 
    Возврат;
    КонецЕсли; 
    
    
    Ворд=СоздатьОбъект("Word.Application");    
    
    Ворд.Visible=1;
    ДокВорд=Ворд.documents;
    ТекДокВорд=ДокВорд.Open(СокрЛП(ПутьШаблона)); //путь к шаблону  
    Содержание=ТекДокВорд.Content;
    
    
    Содержание.Find.Execute("[ДАТА_ОТВЕТА_ПОЛУЧ]",0,0,,,,,,,Строка(ДАТА_ОТВЕТА_ПОЛУЧ),1);
    Содержание=ТекДокВорд.Content; 
    Содержание.Find.Execute("[ТЕК_ДАТА]",0,0,,,,,,,Строка(Format(ТекущаяДата(), "D(0)DDMMMMYYYY")),1);   
    
    Попытка
    
    ТекДокВорд.SaveAs("C:\"+"1.doc");
    Исключение  
    Сообщить(ОписаниеОшибки());
    КонецПопытки;    
    Сообщить("Записан -> "+"C:\"+"1.doc");         
    
    
    КонецПроцедуры
    
    
    
  2. MaxxaM
    Offline

    MaxxaM Опытный в 1С

    Регистрация:
    16 окт 2007
    Сообщения:
    288
    Симпатии:
    2
    Баллы:
    29
    Проверь кнопку по нажатию которой вызывается процедура "Сформировать"
    в команде вызова не указан параметр "докум" :angry:
  3. TopicStarter Overlay
    Natalia_k
    Offline

    Natalia_k Опытный в 1С

    Регистрация:
    8 сен 2009
    Сообщения:
    153
    Симпатии:
    0
    Баллы:
    26

    Не получается всё равно.
    Вот внешняя обработка. Что не так?

    Вложения:

    • ааа.ert
      Размер файла:
      74,5 КБ
      Просмотров:
      93
  4. Mitay_D
    Online

    Mitay_D Опытный в 1С

    Регистрация:
    16 фев 2010
    Сообщения:
    314
    Симпатии:
    0
    Баллы:
    26
    Попробуйте

    Вложения:

    • aaa.ert
      Размер файла:
      69,5 КБ
      Просмотров:
      130
  5. TopicStarter Overlay
    Natalia_k
    Offline

    Natalia_k Опытный в 1С

    Регистрация:
    8 сен 2009
    Сообщения:
    153
    Симпатии:
    0
    Баллы:
    26

    Работает, но не так. Ошибки уже не выдает, но дату ДАТА_ОТВЕТА_ПОЛУЧ в шаблон не выводит. Почему? Помогите разобраться, пожалуйста. Пишу подобную обработку первый раз.
  6. Mitay_D
    Online

    Mitay_D Опытный в 1С

    Регистрация:
    16 фев 2010
    Сообщения:
    314
    Симпатии:
    0
    Баллы:
    26
    Шаблон печатает? покажите принскрин.
  7. TopicStarter Overlay
    Natalia_k
    Offline

    Natalia_k Опытный в 1С

    Регистрация:
    8 сен 2009
    Сообщения:
    153
    Симпатии:
    0
    Баллы:
    26

    В шаблоне печатает только текущую дату. А ДАТА_ОТВЕТА_ПОЛУЧ не печатает, вместо [ДАТА_ОТВЕТА_ПОЛУЧ] указанной в шаблоне пустота. Тоже самое происходит, если пытаюсь вывести ФИО контрагента.
  8. Mitay_D
    Online

    Mitay_D Опытный в 1С

    Регистрация:
    16 фев 2010
    Сообщения:
    314
    Симпатии:
    0
    Баллы:
    26
    посмотрите я в комментарии написал.

    Вложения:

    • aaa.ert
      Размер файла:
      69,5 КБ
      Просмотров:
      228
  9. TopicStarter Overlay
    Natalia_k
    Offline

    Natalia_k Опытный в 1С

    Регистрация:
    8 сен 2009
    Сообщения:
    153
    Симпатии:
    0
    Баллы:
    26

    Спасибо вам большое за помощь! Можете ругаться на меня, но не получается у меня.

    Вот в приложении даю ту же самую обработку, только там создается таблица значений. Здесь всё работает при подключении этой обработке к кнопке печать. Ну не получается у меня выгрузить те же данные в Word

    Вложения:

    • чччч.ert
      Размер файла:
      80,5 КБ
      Просмотров:
      203
  10. TopicStarter Overlay
    Natalia_k
    Offline

    Natalia_k Опытный в 1С

    Регистрация:
    8 сен 2009
    Сообщения:
    153
    Симпатии:
    0
    Баллы:
    26
    У меня получилось!!!!!!!!! :angry: Спасибо большое!
  11. Mitay_D
    Online

    Mitay_D Опытный в 1С

    Регистрация:
    16 фев 2010
    Сообщения:
    314
    Симпатии:
    0
    Баллы:
    26
    ну вот и славненько, а я уже готовый вариант хотел отправлять! :D
  12. TopicStarter Overlay
    Natalia_k
    Offline

    Natalia_k Опытный в 1С

    Регистрация:
    8 сен 2009
    Сообщения:
    153
    Симпатии:
    0
    Баллы:
    26
    А можно еще спросить? А как сделать так, чтобы он сохранял мне не на диск С, а в выбранный пользователем каталог и именовал файл ФИОконтрагента.doc?

    Если напишу ТекДокВорд.SaveAs("C:\"+ФИО +".doc");

    То он мне сохранит на диск С файл с именем Иванов Иван Иванович.doc
    С именем разобралась, а как быть с каталогом?
  13. Time dont wait
    Offline

    Time dont wait Опытный в 1С

    Регистрация:
    20 окт 2009
    Сообщения:
    192
    Симпатии:
    0
    Баллы:
    26
    МОжно прикрутить к форме реквизит т.Строка(идентификатор - ВыбФайл), рядом кнопку ВыбКаталог(), функцию для выбора каталога:
    Код:
    ПРоцедура ВыбКаталог()
    перем каталог,имя; 
    каталог="C:\";  
    
    Если ФС.ВыбратьКаталог(каталог,"Выберите каталог",30)=1 тогда
    выбфайл=СокрЛП(каталог+"_"+имя+"_"+ФИО+".doc");
    КонецЕсли;
    КонецПроцедуры
    
    
    А далее:
    ТекДокВорд.SaveAs(ВыбФайл);

Поделиться этой страницей