8.х Ошибка SDBL: Выход за пределы размерности результата

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Magregor, 2 окт 2008.

  1. TopicStarter Overlay
    Magregor
    Offline

    Magregor

    Регистрация:
    25 сен 2008
    Сообщения:
    7
    Симпатии:
    0
    Баллы:
    1
    Код:
    ВыбДопАн = ВыбДоговор.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"Субконто3","Субконто2"); 
    Пока ВыбДопАн.Следующий() Цикл
    ВывестиСекцию("ШапкаДопАн",Ложь,ВыбДопАн,Неопределено);
    ВыбП = ВыбДопАн.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"Период","Субконто3");
    Пока ВыбП.Следующий() Цикл
    ВыбПериод = ВыбП.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"Регистратор","Период");
    Пока ВыбПериод.Следующий() Цикл
    Если (ВыбПериод.Субконто2.ВидДоговора = Перечисления.ВидыДоговоровКонтрагентов.СКомиссионером) ИЛИ
    (ВыбПериод.Субконто2.ВидДоговора = Перечисления.ВидыДоговоровКонтрагентов.СПокупателем) Тогда
    Если ВыбПериод.СуммаОборотДт <>0 Тогда // только для дебетового оборота по покупателям
    ВывестиСекцию("Регистратор",Истина,ВыбПериод,Истина);
    КонецЕсли;  // по дебетовому обороту
    КонецЕсли; // по покупателям 
    КонецЦикла; // по регистратору
    КонецЦикла; // по периодам
    КонецЦикла; // по доп разрезам 
    
    
    До этого из регистра бухгалтерии еще по запросу выбиралось субконто1 и субконто2 тоже по группировкам. Интересно, но если по "Период" не группирую, никаких ошибок не вылазит.
  2. TopicStarter Overlay
    Magregor
    Offline

    Magregor

    Регистрация:
    25 сен 2008
    Сообщения:
    7
    Симпатии:
    0
    Баллы:
    1
    Еще одно.
    При использовании построителя никаких проблем не возникает.
  3. TopicStarter Overlay
    Magregor
    Offline

    Magregor

    Регистрация:
    25 сен 2008
    Сообщения:
    7
    Симпатии:
    0
    Баллы:
    1
    Все. Я уже обошел проблему через ТЗ
  4. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Обновите платформу до последней

Поделиться этой страницей