8.х Ошибка при записи текстового документа в файл

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем smir.evg, 3 сен 2016.

  1. TopicStarter Overlay
    smir.evg
    Offline

    smir.evg

    Регистрация:
    3 сен 2016
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Версия 8.3 (8.3.8.1652)
    &НаКлиенте
    Процедура Выгрузка(Команда)

    ФайлТЗ = Новый ТекстовыйДокумент;
    ФайлТЗ.ДобавитьСтроку("раз два три");
    ФайлТЗ.Записать("C:\пример.txt", КодировкаТекста.Windows-1250);
    Сообщить ("Данные успешно выгружены в файл по адресу: C:\пример.txt");

    КонецПроцедуры

    Выдает ошибку "Поле объекта не обнаружено (Windows)" со ссылкой на строку "ФайлТЗ.Записать("C:\пример.txt", КодировкаТекста.Windows-1250);"
    Что это может быть?
  2. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.548
    Симпатии:
    716
    Баллы:
    204
    Внимательно прочитайте С-П по методу ТекстовыйДокумент.Записать(), на тему как указать кодировку.
    smir.evg нравится это.
  3. TopicStarter Overlay
    smir.evg
    Offline

    smir.evg

    Регистрация:
    3 сен 2016
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Спасибо большое за совет!

    Подскажите еще, почему хранилище значений возвращает в данном случае фразу "ТаблицаЗначений", как сделать, что оно вернуло результаты запроса, записанные в таблицу значений?
    Код:
    &НаКлиенте
    Процедура Выгрузка(Команда)
    ФайлТ = Новый ТекстовыйДокумент;
    ФайлТ.УстановитьТекст(ЗапросСервер());
    ФайлТ.Записать("C:\пример.txt", "windows-1251");
      
    КонецПроцедуры
    
    &НаСервере
    Функция ЗапросСервер ()
       //сам запрос
            ТЗ.Загрузить(Запрос.Выполнить().Выгрузить());
            ДанныеТЗ = ПоместитьВоВременноеХранилище(ТЗ.Выгрузить());
            Возврат ПолучитьИзВременногоХранилища(ДанныеТЗ);
    КонецФункции
    Последнее редактирование модератором: 5 сен 2016
  4. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.548
    Симпатии:
    716
    Баллы:
    204
    Потому что опять нужно внимательно прочитать с-п по методу ПоместитьВоВременноеХранилище :)
Похожие темы
  1. andryxa85
    Ответов:
    5
    Просмотров:
    1.643
  2. Helmut
    Ответов:
    7
    Просмотров:
    1.371
  3. Dikiy
    Ответов:
    2
    Просмотров:
    590
  4. materiy_boec
    Ответов:
    7
    Просмотров:
    1.199
  5. Svb
    Ответов:
    9
    Просмотров:
    620
Загрузка...

Поделиться этой страницей