8.х Ошибка при загрузке из Excel

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем chernuscaМАРИНА, 15 апр 2008.

  1. TopicStarter Overlay
    chernuscaМАРИНА
    Offline

    chernuscaМАРИНА

    Регистрация:
    9 апр 2008
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    Привет всем! у меня какая - то ошибка.помогите разобраться.
    Ошибка:{Документ.ЗарплатаКВыплатеОрганизаций.Форма.ФормаДокумента(633)}: Ошибка при вызове метода контекста (Open): Произошла исключительная ситуация (Microsoft OLE DB Service Components): Формат строки инициализации не соответствует спецификации OLE DB.

    Код:
    Процедура ЗагрузитьБазуНажатие(Элемент)
    Если ЭлементыФормы.ЗагрузитьБазу.ИсточникДействий ="192.168.0.10:\АСУ\Крылова\*.dbf"  Тогда
    Предупреждение("Не выбрана база данных");
    Возврат;    
    КонецЕсли; 	
    
    MBD = Новый COMОбъект("ADODB.CONNECTION");
    
    Попытка
    MBD.Open("Driver={Microsoft Excel Driver(*.mdb)}; Dbq= ""; Uid=Admin;Pwd=");
    Исключение
    Сообщить(ОписаниеОшибки());
    Возврат;
    КонецПопытки;
    
    ТекстСелект = "SELECT * FROM NOMEN";
    НаборЗаписей = Новый COMОбъект("ADODB.RecordSet");
    
    Попытка
    НаборЗаписей=MBD.Execute(ТекстСелект);
    Исключение
    Сообщить(ОписаниеОшибки());
    КонецПопытки;
    
    Попытка
    НаборЗаписей.MoveFirst();
    Исключение //табилца пустая
    Сообщить(ОписаниеОшибки());
    НаборЗаписей.Close();
    Возврат;
    КонецПопытки;
    
    Пока НаборЗаписей.EOF()=0 Цикл
    FAM = Строка(НаборЗаписей.Fields("FAM").Value);
    NAME = Строка(НаборЗаписей.Fields("NAME").Value);
    OTCH = Строка(НаборЗаписей.Fields("OTCH").Value);
    SU_ = Строка(НаборЗаписей.Fields("SU_").Value);
    Сообщить(FAM+" "+NAME+" "+OTCH+" "+SU_);
    НаборЗаписей.MoveNext();
    КонецЦикла;
    НаборЗаписей.Close()
    КонецПроцедуры
    ы
    
    
    
    
    Это документ "Зарплата к выплате в организации".
    версия программы: 1С:Предприятие 8.0 (8.0.16.2)
    Конфа:Бухгалтерия предприятия, редакция 1.5 (1.5.7.5)

    Прописывала по подобию http://www.1c-pro.ru/index.php?showtopic=9504
  2. dend
    Offline

    dend Опытный в 1С

    Регистрация:
    9 апр 2007
    Сообщения:
    175
    Симпатии:
    0
    Баллы:
    26
    Ошибка возникает при окрытии файла dbf.
    Неправильно сформирована строка подключения

    В каком формате файл который вы пытаетесь загрузить?
    Если dbf, тогда строка должна быть примерно такой :

    "Driver={Microsoft dBASE Driver (*.dbf)};Dbq="+ПутьДоФайла+";"

Поделиться этой страницей