8.х Ошибка при вызове метода контекста (Установить)

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем RoZii, 29 июл 2009.

  1. TopicStarter Overlay
    RoZii
    Offline

    RoZii Опытный в 1С

    Регистрация:
    29 июл 2009
    Сообщения:
    58
    Симпатии:
    0
    Баллы:
    26
    Для реализации товаров и услуг была создана новая форма подбора с дополнительными полями поиска. В УПП 8.1 работает без проблем, а в УТ 8.1 при открытии групппы номенклатуры выдается ошибка:
    Ошибка при вызове метода контекста (Установить): Недопустимое значение параметра (параметр номер '1') ТаблицаНоменклатуры.Порядок.Установить("Тип"); что ему не хватает? и на что следует обратить внимание?

    Код:
    Процедура ТаблицаНоменклатурыПриСменеТекущегоРодителя(Элемент)
    Если Не Элемент.ТекущиеДанные=Неопределено Тогда
    Если Элемент.ТекущиеДанные.ЭтоГруппа Тогда
    Элемент.Колонки.Наименование.Видимость=Истина;
    Элемент.Колонки.Наименование.Доступность=Истина;
    ТаблицаНоменклатуры.Порядок.Установить("Код");
    Иначе
    Элемент.Колонки.Наименование.Видимость=Ложь;
    Элемент.Колонки.Наименование.Доступность=Ложь;
    ИмяКолонки=ТаблицаНоменклатуры.Порядок[1].Имя;
    Если ИмяКолонки="Наименование" Тогда
    ТаблицаНоменклатуры.Порядок.Установить("Тип");
    Иначе
    УстановкаПорядка(ИмяКолонки);
    КонецЕсли;
    КонецЕсли;
    Иначе
    Элемент.Колонки.Наименование.Видимость=Истина;
    КонецЕсли;
    ПоследняяСтрока="";
    ПерваяСтрока="";
    ТаблицаСтрок=Неопределено;
    КонецПроцедуры
    
  2. TopicStarter Overlay
    RoZii
    Offline

    RoZii Опытный в 1С

    Регистрация:
    29 июл 2009
    Сообщения:
    58
    Симпатии:
    0
    Баллы:
    26
    Все решила проблему. В номенклатуре не создала реквизиты.

Поделиться этой страницей