8.х Ошибка при установке значения атрибута контекста (Картинка):Несоответствие типов

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем Громов, 30 авг 2012.

  1. TopicStarter Overlay
    Громов
    Offline

    Громов

    Регистрация:
    10 май 2012
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Добрый день, не могу разобраться, подскажите если не трудно,
    Обработка должна выводить на печать сертификаты из спр. ХранилищеДополнительнойИнформации, конфигурация Комплексная автоматизация.
    Выыодит ошибку: Ошибка при установке значения атрибута контекста (Картинка): Несоответствие типов..
    Код:
    Функция Печать() Экспорт
    
    ТабДокумент = Новый ТабличныйДокумент;
    Макет	   = ПолучитьМакет("Макет");
    Для Каждого Строка из СсылкаНаОбъект.Товары Цикл
    
    Запрос=Новый Запрос;
    Запрос.Текст=
    "ВЫБРАТЬ
    |    ХранилищеДополнительнойИнформации.Хранилище,
    |    ХранилищеДополнительнойИнформации.Ссылка
    |ИЗ
    |    Справочник.ХранилищеДополнительнойИнформации КАК ХранилищеДополнительнойИнформации
    |ГДЕ
    |    ХранилищеДополнительнойИнформации.Объект = &Объект";
    Запрос.УстановитьПараметр("Объект",Строка.Номенклатура);
    Если НЕ Запрос.Выполнить().Пустой() Тогда
    ВыборкаХранИзображений=Запрос.Выполнить().Выбрать();
    Пока ВыборкаХранИзображений.Следующий() Цикл
    ОбластьМакета = Макет.ПолучитьОбласть("Изображение");		   
    РисунокСертификат = ОбластьМакета.Рисунки.Добавить(ТипРисункаТабличногоДокумента.Картинка);
    РисунокСертификат = ВыборкаХранИзображений.Хранилище.Получить();
    РисунокСертификат.Защита = Истина;
    РисунокСертификат.Лево=0;
    РисунокСертификат.Верх=0;
    РисунокСертификат.Высота=280;
    РисунокСертификат.Ширина=180;
    
    ТабДокумент.Вывести(ОбластьМакета);
    ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц();
    
    КонецЦикла;
    Иначе
    Сообщить("Для номенклатуры "+СокрЛП(Строка.Номенклатура)+" сертификат не загружен");
    КонецЕсли;		   
    
    КонецЦикла;   
    ТабДокумент.ПолеСверху = 0;
    ТабДокумент.ПолеСлева  = 0;
    ТабДокумент.ПолеСнизу  = 0;
    ТабДокумент.ПолеСправа = 0;
    ТабДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Портрет;
    ТабДокумент.АвтоМасштаб = Истина;
    
    ТабДокумент.Показать();
    КонецФункции
    Заранее благодарен за любую помощь!

    или поправьте, если совсем не так делаю..
Похожие темы
  1. Santa4527
    Ответов:
    6
    Просмотров:
    5.659
  2. umbra777
    Ответов:
    2
    Просмотров:
    1.582
  3. csusha
    Ответов:
    1
    Просмотров:
    1.059
  4. materiy_boec
    Ответов:
    0
    Просмотров:
    1.047
  5. ILDARIAN
    Ответов:
    9
    Просмотров:
    4.396
Загрузка...

Поделиться этой страницей