7.7 Ошибка при создании счета-фактуры

Тема в разделе "Общие вопросы "1С:Предприятие 7.7"", создана пользователем Lika-2009, 9 окт 2009.

  1. TopicStarter Overlay
    Lika-2009
    Offline

    Lika-2009

    Регистрация:
    9 окт 2009
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    При создании с/ф выдается следующее сообщение:
    Если ПустоеЗначение(ЕдиницаИзмерейия<<?>>) = 1 Тогда
    {Документ.СчетФактура.Форма.Модуль(1671)}: Переменная не определена (ЕдиницаИзмерейия)
    Если ПсстоеЗначение<<?>>(ТабДок.ГТД) = 1 Тогда
    {Документ.СчетФактура.Форма.Модуль(1674)}: Функция не обнаружена (ПсстоеЗначение)
    Еqли <<?>>ПустаяСтрока(ТабДок.ГТД.СтранаПроисхождения) = 1 Тогда
    {Документ.СчетФактура.Форма.Модуль(1679)}: Переменная не определена (Еqли)
    <<?>>Иначе
    {Документ.СчетФактура.Форма.Модуль(1681)}: Ожидается ключевое слово 'КонецЕсли' ('EndIf')
    <<?>>Иначе
    {Документ.СчетФактура.Форма.Модуль(1681)}: Ожидается ключевое слово 'КонецЕсли' ('EndIf')
    <<?>>Иначе
    {Документ.СчетФактура.Форма.Модуль(1681)}: Ожидается ключевое слово 'КонецЦикла' ('EndDo')
    <<?>>Иначе
    {Документ.СчетФактура.Форма.Модуль(1681)}: Ожидается ключевое слово 'КонецПроцедуры' ('EndProcedure')
    <<?>>Иначе
    {Документ.СчетФактура.Форма.Модуль(1681)}: Процедура или функция с указанным именем объявлена, но не определена в текущем модуле (ПриВыбореСтавкеНольПроцентов)
    Как это исправить?
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Над модулем кто-то хорошо поиздевался.

    Если ПустоеЗначение(ЕдиницаИзмерейия<<?>>) = 1 Тогда ЕдиницаИзмерения
    Если ПсстоеЗначение<<?>>(ТабДок.ГТД) = 1 Тогда ПустоеЗначение
    Еqли <<?>>ПустаяСтрока(ТабДок.ГТД.СтранаПроисхождения) = 1 Тогда Если

    Возможно кто-то это "устроил" специально. Разбирайтесь....

Поделиться этой страницей