8.х КА Ошибка при отправке почты

Тема в разделе ""1С:Комплексная автоматизация"", создана пользователем Konst82, 22 сен 2014.

  1. TopicStarter Overlay
    Konst82
    Offline

    Konst82 Опытный в 1С

    Регистрация:
    29 авг 2014
    Сообщения:
    53
    Симпатии:
    1
    Баллы:
    29
    Доброго дня! 1С:Предприятие 8.3 (8.3.4.482), Комплексная автоматизация, редакция 1.1 (1.1.46.2). При отправке печатной формы по почте (почта на mail.ru) выдает Предупреждение "Произошли ошибки при проверке настроек учетной записи. Описание ошибки приведено в окне сообщения" , "Ошибка при вызове метода контекста (Подключиться): Can not authenticate to POP3 server: POP3 is available only with SSL or TLS connection enabled
    ".Настройки как надо (smtp.mail.ru порт 25, pop.mail.ru порт 110, включена "Требуется SMTP аутентификация") , раньше все работало, логин , пароль в норме, на сайте заходил, с портами игрался (2525) не помогло. Другая учетная запись , также на mail.ru работает норм. КЕШ на сервере сейчас чистить пока возможности нет...в чем еще может быть проблема
  2. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.548
    Симпатии:
    716
    Баллы:
    204
    Включить SSL/TLS надобно.
  3. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    ну насколько помню при отправке используется smtp, а не pop3... или ошибаюсь? Если вторая учетка работает, посмотрите как там настроено
  4. TopicStarter Overlay
    Konst82
    Offline

    Konst82 Опытный в 1С

    Регистрация:
    29 авг 2014
    Сообщения:
    53
    Симпатии:
    1
    Баллы:
    29
    все аналогично первой..в том то и дело..без всяких SSL/TLS работает. но в коде тоже пробовал.. при нажатии на кнопку "Проверить настройки учетной записи" включал свйство ИспользоватьSSLPOP3 = Истина...нифига не работает
    --- Объединение сообщений, 22 сен 2014 ---
    да все верно так и есть
    --- Объединение сообщений, 22 сен 2014 ---
    две учетки полностью аналогичны..только со своим логином и паролем..сравнивал их даже в отладчике на всяк случай...но вот одна не работает а другая все ок!
  5. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    а в реалии можно зайти на этот ящик7
  6. TopicStarter Overlay
    Konst82
    Offline

    Konst82 Опытный в 1С

    Регистрация:
    29 авг 2014
    Сообщения:
    53
    Симпатии:
    1
    Баллы:
    29
    да заходил, все норм, в настройках копался все норм
  7. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104
  8. TopicStarter Overlay
    Konst82
    Offline

    Konst82 Опытный в 1С

    Регистрация:
    29 авг 2014
    Сообщения:
    53
    Симпатии:
    1
    Баллы:
    29
    Добавил код

    Код:
    // Формирует почтовый профиль по учетной записи
    //
    // Параметры
    //  УчетнаяЗапись
    //
    // Возвращаемое значение:
    //   ИнтернетПочтовыйПрофиль
    //
    Функция ПолучитьИнтернетПочтовыйПрофиль(УчетнаяЗапись) Экспорт
    
        Профиль = Новый ИнтернетПочтовыйПрофиль;
       
        Профиль.АдресСервераPOP3 = УчетнаяЗапись.POP3Сервер;
        Профиль.АдресСервераSMTP = УчетнаяЗапись.SMTPСервер;
        Если УчетнаяЗапись.ВремяОжиданияСервера > 0 Тогда
            Профиль.ВремяОжидания = УчетнаяЗапись.ВремяОжиданияСервера;
        КонецЕсли;
        Профиль.Пароль           = УчетнаяЗапись.Пароль;
        Профиль.Пользователь     = УчетнаяЗапись.Логин;
        Профиль.ПортPOP3         = УчетнаяЗапись.ПортPOP3;
        Профиль.ПортSMTP         = УчетнаяЗапись.ПортSMTP;
        Профиль.ИспользоватьSSLIMAP = Истина;
        Профиль.ИспользоватьSSLPOP3 = Истина;
       
        Если УчетнаяЗапись.ТребуетсяSMTPАутентификация Тогда
            Профиль.АутентификацияSMTP = СпособSMTPАутентификации.ПоУмолчанию;
            Профиль.ПарольSMTP         = УчетнаяЗапись.ПарольSMTP;
            Профиль.ПользовательSMTP   = УчетнаяЗапись.ЛогинSMTP;
        Иначе
            Профиль.АутентификацияSMTP = СпособSMTPАутентификации.БезАутентификации;
            Профиль.ПарольSMTP         = "";
            Профиль.ПользовательSMTP   = "";
        КонецЕсли;
       
        Возврат Профиль;
    
    КонецФункции
    
    Потом поэксперементировал с портами, сработало на портах для SMTP 587, для POP3 995//
    По кнопке "Проверить настройки учетной записи" все норм проходит,.. но при отправке печатной формы появилась другая ошибка

    {ОбщийМодуль.УправлениеЭлектроннойПочтой.Модуль(1117)}: Ошибка при вызове метода контекста (Подключиться): Host not found (#11001): STARTTLS
    В инете почитал вроде как на сервер ругается который доступ в инет дает..возможно с антивирус блокирует..
  9. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    скорее всего на серваке не настроено ssl tls
  10. TopicStarter Overlay
    Konst82
    Offline

    Konst82 Опытный в 1С

    Регистрация:
    29 авг 2014
    Сообщения:
    53
    Симпатии:
    1
    Баллы:
    29
    почему другая почта работает норм?...кстати только обнаружил письмо на проблемной учетке след. содержания

    --- Объединение сообщений, 22 сен 2014 ---
    это от команды mail.ru
    --- Объединение сообщений, 22 сен 2014 ---
    а где это настраивается? а то я с этим не сталкивался..)
  11. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    значит с другого адреса походу через указанные клиенты никогда не заходил что ли получается?
  12. TopicStarter Overlay
    Konst82
    Offline

    Konst82 Опытный в 1С

    Регистрация:
    29 авг 2014
    Сообщения:
    53
    Симпатии:
    1
    Баллы:
    29
    печатную форму не отправлял, но по кнопке "Проверить настройки учетной записи" все норм проходило.

Поделиться этой страницей