8.х ОБМЕН ! ошибка при конверации !

Тема в разделе "Обмен данными в "1С:Предприятие 8"", создана пользователем ХочуСпец, 19 мар 2009.

  1. TopicStarter Overlay
    ХочуСпец
    Offline

    ХочуСпец Опытный в 1С

    Регистрация:
    17 ноя 2008
    Сообщения:
    53
    Симпатии:
    0
    Баллы:
    26
    Скажите пож, как из обработчика события одного ПКС получить значение другого ПКС того же ПКО? Ни у того ни у другого ПКС нет источника.
    Данные источника заполняются в ПВД.
    Проблемы попробовал решить в след виде:
    В ПКС РасчетныеДокументы перед выгрузкой прописал:
    Сообщить(ВходящиеДанные.ВзаиморасчетыСПодотчетнымиЛицами.ВидДвижения);

    но выдается ошибка
  2. TopicStarter Overlay
    ХочуСпец
    Offline

    ХочуСпец Опытный в 1С

    Регистрация:
    17 ноя 2008
    Сообщения:
    53
    Симпатии:
    0
    Баллы:
    26
    никто не знает?
  3. TopicStarter Overlay
    ХочуСпец
    Offline

    ХочуСпец Опытный в 1С

    Регистрация:
    17 ноя 2008
    Сообщения:
    53
    Симпатии:
    0
    Баллы:
    26
    Попробую еще раз описать проблему! Прошу помочь!
    Возникла необходимость в переносе остатков ДС подотчетным лицам из БП в УТ. Перенос делаю с помощью Конвертации 8.1. Справочную информацию уже перенес, остатки по кассам, по расчетным счетам и взаиморасчетам перенес тоже. При переносе остатков подотчетных лиц возникла проблема:
    Остатки в УТ ввожу с помощью документа КорректировкаЗаписейРегистров, добавляю записи в РН: ВзаиморасчетыПоПодотчетным лицам. В этом регистре есть измерение РасчетныйДокумент, его заполнять обязательно нужно для дальнейшего закрытия в УТ. Заполнять это измерение решил непроведенными документами РКО (в том случает если сальдо в БП дебетовое) и АвансовыйОтчет (если в БП сальдо кредетовое). Для решения этой проблемы в Конвертации создал два параметра: ФАО (ДокументСсылка.АвансовыйОтчет) и ФРКО (ДокументСсылка.РасходныйКассовыйОрдер)

    Для загрузки этих непроведенных документов создал два ПКО:
    НепроведенныйФиктивныйРКО и НепроведенныйФиктивныйАвансовыйОтчет.

    Создал ПКО: ОстаткиПоДСПодотчетныхЛиц, добавил в него таблицы имен регистров и набор записей регистов (сделал все правильно, т.к. делал тоже самое в предыдущих ПКО)

    В ПВД ОстаткиПоДСПодотчетныхЛиц в обработчике перед выгрузкой прописал:

    ТаблицаРегистровНакопления = Новый ТаблицаЗначений;
    ТаблицаРегистровНакопления.Колонки.Добавить("Имя");
    ТаблицаРегистровНакопления.Колонки.Добавить("Представление");

    НоваяСтрокаРН = ТаблицаРегистровНакопления.Добавить();
    НоваяСтрокаРН.Имя = "ВзаиморасчетыСПодотчетнымиЛицами";
    НоваяСтрокаРН.Представление = "Взаиморасчеты с подотчетными лицами";

    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("Организация", Параметры.ПоОрганизации);
    Запрос.УстановитьПараметр("Дата", Параметры.ОстаткиНаДату);
    Запрос.Текст =
    "ВЫБРАТЬ
    | ХозрасчетныйОстатки.Субконто1 КАК ФизЛицо,
    | ВЫБОР
    | КОГДА ЕСТЬNULL(ХозрасчетныйОстатки.СуммаОстатокДт, 0) > 0
    | ТОГДА ЕСТЬNULL(ХозрасчетныйОстатки.СуммаОстатокДт, 0)
    | ИНАЧЕ ВЫБОР
    | КОГДА ЕСТЬNULL(ХозрасчетныйОстатки.СуммаОстатокКт, 0) > 0
    | ТОГДА -ЕСТЬNULL(ХозрасчетныйОстатки.СуммаОстатокКт, 0)
    | КОНЕЦ
    | КОНЕЦ КАК СуммаОстаток
    |ИЗ
    | РегистрБухгалтерии.Хозрасчетный.Остатки(&Дата, Счет = ЗНАЧЕНИЕ(ПланСчетов.Хозрасчетный.РасчетыСПодотчетнымиЛицами), , Организация = &Организация) КАК ХозрасчетныйОстатки";


    Результат = Запрос.Выполнить();
    Выборка = Результат.Выбрать();

    //Движения по РН ВСПЛ
    ВзаиморасчетыСПодотчетнымиЛицами = Новый ТаблицаЗначений;
    ВзаиморасчетыСПодотчетнымиЛицами.Колонки.Добавить("ВидДвижения");
    ВзаиморасчетыСПодотчетнымиЛицами.Колонки.Добавить("ФизЛицо");
    ВзаиморасчетыСПодотчетнымиЛицами.Колонки.Добавить("РасчетныйДокумент");
    ВзаиморасчетыСПодотчетнымиЛицами.Колонки.Добавить("СуммаВзаиморасчетов");
    ВзаиморасчетыСПодотчетнымиЛицами.Колонки.Добавить("СуммаУпр");


    Если Выборка.Количество() = 0 тогда
    Сообщить("По счету 71.01 нет остатков!");
    Иначе
    Пока Выборка.Следующий() цикл
    Если Выборка.СуммаОстаток <> 0 тогда

    Если Выборка.СуммаОстаток > 0 тогда

    //РКО
    //приход
    Строка = ВзаиморасчетыСПодотчетнымиЛицами.Добавить();
    Строка.ВидДвижения = "Приход";
    Строка.ФизЛицо = Выборка.ФизЛицо;
    Строка.РасчетныйДокумент = Параметры.ФРКО;
    Строка.СуммаВзаиморасчетов = Выборка.СуммаОстаток;
    Строка.СуммаУпр = Выборка.СуммаОстаток;

    Иначе

    //АО
    //расход
    Строка = ВзаиморасчетыСПодотчетнымиЛицами.Добавить();
    Строка.ВидДвижения = "Расход";
    Строка.ФизЛицо = Выборка.ФизЛицо;
    Строка.РасчетныйДокумент = Параметры.ФАО;
    Строка.СуммаВзаиморасчетов = -Выборка.СуммаОстаток;
    Строка.СуммаУпр = -Выборка.СуммаОстаток;

    КонецЕсли;
    КонецЕсли;
    КонецЦикла;

    КонецЕсли;


    Как сделать так чтобы параметры ФАО и ФРКО заполнялись???? При загрузке непроведенные документы создаются, но не подцепялются к измерению регистра РасчетныйДокумент! Как быть?


    ПРОШУ ОБРАТИТЬ ВНИМАНИЕ НА ПРОБЛЕМУ BABYGS!!!!!
Похожие темы
  1. Helmut
    Ответов:
    7
    Просмотров:
    1.372
  2. zxcv
    Ответов:
    7
    Просмотров:
    1.052
Загрузка...

Поделиться этой страницей