7.7 Ошибка при формировании справки 2НДФЛ

Тема в разделе "Общие вопросы "1С:Предприятие 7.7"", создана пользователем Vertex, 5 июл 2011.

  1. TopicStarter Overlay
    Vertex
    Offline

    Vertex Опытный в 1С

    Регистрация:
    14 июн 2011
    Сообщения:
    468
    Симпатии:
    4
    Баллы:
    29
    Доброго дня.
    Конфа бухучёт: 525.
    Отчёт Справки по НДФЛ выдаёт неверное значение налоговой базы по НДФЛ очень сильно завышенное.
    Это глюк обновления или у меня что то не так?

    Когда открываю налоговую карточку для заполнения там всё в порядке.
    В отчёте бардак
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Гммм.... Вообще-то актуальный релиз 527.

    Относительно отчета - позвольте не согласиться. В ОБОИХ случаях работает одна и та же процедура - глСобратьДанныеДляНДФЛВыбор
  3. Vlad
    Offline

    Vlad Модераторы Команда форума Модератор

    Регистрация:
    16 авг 2006
    Сообщения:
    3.517
    Симпатии:
    19
    Баллы:
    29
    Что за налоговую карточку ты открываешь?
  4. TopicStarter Overlay
    Vertex
    Offline

    Vertex Опытный в 1С

    Регистрация:
    14 июн 2011
    Сообщения:
    468
    Симпатии:
    4
    Баллы:
    29
    В этой функции трабла
    Код:
     // глСобратьДанныеДляНДФЛ2010(ДоходыВычетыНалогиСотрудников,ОбобщенныйСотрудник,ДатаАктуальности,Форма)
    
    
    
    А именно отсюда начинается
    Код:
        НалоговаяБаза13 = 0;
    НалогИсчисленный13 = 0;
    НалогУдержанный13 = 0;
    Для ТекНомерМесяца = 1 по НомерМесяца Цикл    
    НалоговаяБаза13 = НалоговаяБаза13 + ПоляКарточки.Получить("НБаза" + глДополнитьСтроку(ТекНомерМесяца, 2));//<----Сюда
    НалогИсчисленный13 = НалогИсчисленный13 + ПоляКарточки.Получить("НИ" + глДополнитьСтроку(ТекНомерМесяца, 2));
    НалогУдержанный13 = НалогУдержанный13 + ПоляКарточки.Получить("П" + глДополнитьСтроку(Строка(132+ТекНомерМесяца), 3));
    КонецЦикла;
    КонецЕсли;
    
    
    
    Когда в ручную в отладчике подставляешь значение месяцев получает всё верно.
    С счётчиком месяцев что то не в порядке

    Налоговая карточка 1-НДФЛ за 09-10годы
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    А вы знаете что отчет Отчёт СправкиПоНДФЛ нельзя применять ранее 2011 года? Для предыдущих периодов работает Обработка.ОДоходах
  6. TopicStarter Overlay
    Vertex
    Offline

    Vertex Опытный в 1С

    Регистрация:
    14 июн 2011
    Сообщения:
    468
    Симпатии:
    4
    Баллы:
    29
    Нужны справки за 2010 год.
    Ошибку исправил.
    Была следующая: программа складывала уже посчитаную налоговую базу из ячеек карточки 1 НДФЛ тоесть например у сотрудника идёт налоговая база c нарастающим итогом (уже сложенные значения дохода за - вычета)
    1(месяц)6500
    2(месяц)13000 (6500+6500)
    3(месяц)19500 (6500+6500+6500)
    и тд.
    А программа считала

    1(месяц)6500
    2(месяц)13000 (6500+1300=19500)
    3(месяц)19500 (19500+6500=39000)

    и.тд

    Код:
    НалоговаяБаза13 = ПоляКарточки.Получить("НБаза" + глДополнитьСтроку(ТекНомерМесяца, 2));
    
    
    
  7. TopicStarter Overlay
    Vertex
    Offline

    Vertex Опытный в 1С

    Регистрация:
    14 июн 2011
    Сообщения:
    468
    Симпатии:
    4
    Баллы:
    29
    А почему нельзя эту обработку использовать?
    Печатная форма соответствует, 2010 год в списке есть..
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Не припомню я что-то у 1с такого косяка....
    Может это чье-то рукоблудство?

    Вы упомянули 2009й год
  9. TopicStarter Overlay
    Vertex
    Offline

    Vertex Опытный в 1С

    Регистрация:
    14 июн 2011
    Сообщения:
    468
    Симпатии:
    4
    Баллы:
    29
    Бухучёт конечно тоже не типовой, дописки есть для обмена с торговлей, но это касается только по части реализации.
    При обновлении всё кроме документов реализации обновил...
    Так что рукоблудия в данном случае быть не могло
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Вообще-то 1-НДФЛ с этого года утратила свою силу.
    Вы этот ляп обнаружили именно в 527м релизе?
  11. TopicStarter Overlay
    Vertex
    Offline

    Vertex Опытный в 1С

    Регистрация:
    14 июн 2011
    Сообщения:
    468
    Симпатии:
    4
    Баллы:
    29
    Именно.
    Справочники>Сотрудники>[Сотрудник]>Налоги н доходы>Формы прошлых лет>Налоговая карточка 1-НДФЛ за 09-10 годы,по 2010 году именно оттуда берёт значения


    525.
    Сегодня 527 планирую поставить
  12. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Если не затруднит - отпишитесь по результату
  13. TopicStarter Overlay
    Vertex
    Offline

    Vertex Опытный в 1С

    Регистрация:
    14 июн 2011
    Сообщения:
    468
    Симпатии:
    4
    Баллы:
    29
    После обновления?
  14. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Да. Просто под рукой в данный момент нет 525го чтобы проверить
  15. TopicStarter Overlay
    Vertex
    Offline

    Vertex Опытный в 1С

    Регистрация:
    14 июн 2011
    Сообщения:
    468
    Симпатии:
    4
    Баллы:
    29
    Кстати
    Конкретно по 525 релизу , такая трабла с налоговой базой по ндфл по всем ставкам..
    я откорректировал именно по ставке 13% НалоговаяБаза13

    Нет проблем отпишусь
  16. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Странно. НИКТО из клиентов не жаловался на данный баг. Поэтому прошу уточнить при обновлении. В 527 такого не наблюдаю
  17. TopicStarter Overlay
    Vertex
    Offline

    Vertex Опытный в 1С

    Регистрация:
    14 июн 2011
    Сообщения:
    468
    Симпатии:
    4
    Баллы:
    29
    Может никто за 2010 не формировал справку о доходах?
  18. TopicStarter Overlay
    Vertex
    Offline

    Vertex Опытный в 1С

    Регистрация:
    14 июн 2011
    Сообщения:
    468
    Симпатии:
    4
    Баллы:
    29
    Ошибка следующая в 525 релизе
    Резидент=?(СтатусНеРезидента=1,2,1);

    в 527 исправлено
    Резидент=?(СтатусНеРезидента=1,1,2);

    В зависимости от этого не выполнилось условие
    Код:
    Если Резидент = 1 Тогда
    НомерПоследнегоМесяца = ПоляКарточки.Получить("ПоследнийМесяц");
    Если НомерМесяца > НомерПоследнегоМесяца Тогда
    НалоговаяБаза13 = ПоляКарточки.Получить("НБаза" + глДополнитьСтроку(НомерПоследнегоМесяца, 2));
    НалогИсчисленный13 = ПоляКарточки.Получить("НИ" + глДополнитьСтроку(НомерПоследнегоМесяца, 2));
    НалогУдержанный13 = ПоляКарточки.Получить("П" + глДополнитьСтроку(Строка(132+НомерПоследнегоМесяца), 3));
    
    Иначе
    НалоговаяБаза13 = ПоляКарточки.Получить("НБаза" + глДополнитьСтроку(НомерМесяца, 2));
    НалогИсчисленный13 = ПоляКарточки.Получить("НИ" + глДополнитьСтроку(НомерМесяца, 2));
    НалогУдержанный13 = ПоляКарточки.Получить("П" + глДополнитьСтроку(Строка(132+НомерМесяца), 3));
    
    КонецЕсли; 
    Если НомерМесяца > НомерПоследнегоМесяца Тогда
    Если НалоговаяБаза13 = 0 Тогда
    НалоговаяБаза13 = НалоговаяБаза13Пред;
    Иначе
    НалоговаяБаза13Пред = НалоговаяБаза13;
    КонецЕсли;
    Если НалогИсчисленный13 = 0 Тогда
    НалогИсчисленный13 = НалогИсчисленный13Пред;
    Иначе
    НалогИсчисленный13Пред = НалогИсчисленный13;
    КонецЕсли; 
    Если НалогУдержанный13 = 0 Тогда
    НалогУдержанный13 = НалогУдержанный13Пред;
    Иначе
    НалогУдержанный13Пред = НалогУдержанный13;
    КонецЕсли; 
    Иначе                                         
    НалоговаяБаза13Пред = НалоговаяБаза13;
    НалогИсчисленный13Пред = НалогИсчисленный13;
    НалогУдержанный13Пред = НалогУдержанный13;                    
    КонецЕсли;                
    Иначе
    НалоговаяБаза13 = 0;
    НалогИсчисленный13 = 0;
    НалогУдержанный13 = 0;
    Для ТекНомерМесяца = 1 по НомерМесяца Цикл    
    НалоговаяБаза13 = НалоговаяБаза13 + ПоляКарточки.Получить("НБаза" + глДополнитьСтроку(ТекНомерМесяца, 2));
    НалогИсчисленный13 = НалогИсчисленный13 + ПоляКарточки.Получить("НИ" + глДополнитьСтроку(ТекНомерМесяца, 2));
    НалогУдержанный13 = НалогУдержанный13 + ПоляКарточки.Получить("П" + глДополнитьСтроку(Строка(132+ТекНомерМесяца), 3));
    КонецЦикла;
    КонецЕсли;
    
    Взыскание13 = 0;
    Возврат13 = 0;
    Взыскание9 = 0;
    Возврат9 = 0;
    
    НалоговаяБаза9 = 0;
    НалогИсчисленный9 = 0;
    НалогУдержанный9 = 0;
    
    Для ТекНомерМесяца = 1 по НомерМесяца Цикл
    НалоговаяБаза9 = НалоговаяБаза9 + ПоляКарточки.Получить("ОбДив" + глДополнитьСтроку(ТекНомерМесяца, 2));
    НалогИсчисленный9 = НалогИсчисленный9 + ПоляКарточки.Получить("НД6И" + глДополнитьСтроку(ТекНомерМесяца, 2));
    НалогУдержанный9 = НалогУдержанный9 + ПоляКарточки.Получить("П" + глДополнитьСтроку(Строка(175+ТекНомерМесяца), 3));
    
    Взыскание13 = Взыскание13 + ПоляКарточки.Получить("НалВзыск" + глДополнитьСтроку(ТекНомерМесяца, 2));
    Возврат13 = Возврат13 + ПоляКарточки.Получить("НалВозвр" + глДополнитьСтроку(ТекНомерМесяца, 2));
    Взыскание9 = Взыскание9 + ПоляКарточки.Получить("ДНалВзыск" + глДополнитьСтроку(ТекНомерМесяца, 2));
    Возврат9 = Возврат9 + ПоляКарточки.Получить("ДНалВозвр03" + глДополнитьСтроку(ТекНомерМесяца, 2));
    КонецЦикла;
    
    
    
    
    Строку для расчёта базы я исправил в такой вид
    Код:
    НалоговаяБаза13 = ПоляКарточки.Получить("НБаза" + глДополнитьСтроку(НомерПоследнегоМесяца, 2));
    
    
    
    Копнул чуток не в том направлении, значение резидент или нет я не проверил :angry:
  19. TopicStarter Overlay
    Vertex
    Offline

    Vertex Опытный в 1С

    Регистрация:
    14 июн 2011
    Сообщения:
    468
    Симпатии:
    4
    Баллы:
    29
    Только странно как то переменную обозвали СтатусНеРезидента
    в случае Резидент=?(СтатусНеРезидента=1,2,1);
    логически было правильно, сотрудник резидент соответственно СтатусНеРезидента должен быть = 0 и выполниться второе условие (1)
    Сами хитрожопо написали сами и запутались
  20. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Логично)))))

Поделиться этой страницей