8.х Ошибка преобразование к типу число не может быть выполнено

Тема в разделе "Установка платформы "1С:Предприятие 8"", создана пользователем Екатерина92, 25 мар 2017.

  1. TopicStarter Overlay
    Екатерина92
    Offline

    Екатерина92

    Регистрация:
    30 янв 2017
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Функция ПризнакИспользованияВнешнегоОтчетаСУчетомКэша(РеглОтч)
    Перем ОтчетВКэше;

    Попытка
    Кэш = ПараметрыСеанса.ХранилищеПараметровВнешнихРегламентированныхОтчетов.Получить();
    Исключение
    Кэш = Новый Структура;
    КонецПопытки;

    ВКэшеАктуальныйОтчет = Ложь;
    Если Кэш.Свойство(РеглОтч.ИсточникОтчета, ОтчетВКэше) Тогда
    // Проверим, актуален ли отчет
    Если ОтчетВКэше.ВерсияДанных = РеглОтч.ВерсияДанных Тогда
    ВКэшеАктуальныйОтчет = Истина;
    КонецЕсли;
    КонецЕсли;

    Если ВКэшеАктуальныйОтчет Тогда
    Возврат ОтчетВКэше.Признак;
    Иначе
    Попытка
    ВнешнийОтчетИспользовать = РеглОтч.ВнешнийОтчетИспользовать;
    Кэш.Вставить(РеглОтч.ИсточникОтчета, Новый Структура("Отчет, Признак, ВерсияДанных", РеглОтч.ВнешнийОтчетХранилище.Получить(), ВнешнийОтчетИспользовать, РеглОтч.ВерсияДанных));
    ПараметрыСеанса.ХранилищеПараметровВнешнихРегламентированныхОтчетов = Новый ХранилищеЗначения(Кэш);
    Возврат ВнешнийОтчетИспользовать;
    Исключение
    Возврат Неопределено;
    КонецПопытки;
    КонецЕсли;

    КонецФункции

Поделиться этой страницей