8.х Ошибка прав доступа в ут 10.3

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем alboldinov, 31 мар 2016.

  1. TopicStarter Overlay
    alboldinov
    Offline

    alboldinov Опытный в 1С

    Регистрация:
    8 сен 2014
    Сообщения:
    183
    Симпатии:
    0
    Баллы:
    26
    Есть роль Сертификация у нее доступны все права на Регистр Партии товаров на складах, но при проведении документа корректировка качества товаров, после завершения процедуры обработка проведения выдается ошибка нарушение прав доступа на этот регистр. По всем реквизитам, ресурсам и измерениям роли даны права на чтение и просмотр. RLS не включено. Вообще непонятно куда смотреть. Под полными правами документ проводится. Причем если писать в регистр через обработку под этой ролью, то все хорошо.
    Последнее редактирование: 31 мар 2016
  2. alexburn
    Online

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.742
    Симпатии:
    509
    Баллы:
    204
    Отладчик и ЖР в помощь
  3. TopicStarter Overlay
    alboldinov
    Offline

    alboldinov Опытный в 1С

    Регистрация:
    8 сен 2014
    Сообщения:
    183
    Симпатии:
    0
    Баллы:
    26
    не помогает, из ЖР видно что отваливается на Регистре, в отладчике все записывается в регистре записи есть на КонецПроцедуры ОбработкаПроведения(), следущий шаг ошибка прав и отмена транзакции. Куда дальше ковырять непонятно
  4. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.551
    Симпатии:
    716
    Баллы:
    204
    Дык после ОбработкаПроведения() там еще куча всего может происходить.
    Подписки на события - они такие, да :)
  5. Draco
    Online

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.631
    Симпатии:
    946
    Баллы:
    204
    смотрите подписки на события
  6. TopicStarter Overlay
    alboldinov
    Offline

    alboldinov Опытный в 1С

    Регистрация:
    8 сен 2014
    Сообщения:
    183
    Симпатии:
    0
    Баллы:
    26
    Подписки смотрел в первую очередь :(, нет их на эти объекты.
  7. Draco
    Online

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.631
    Симпатии:
    946
    Баллы:
    204
    Может в модуле или менеджере самого регистра чтото есть за код
  8. TopicStarter Overlay
    alboldinov
    Offline

    alboldinov Опытный в 1С

    Регистрация:
    8 сен 2014
    Сообщения:
    183
    Симпатии:
    0
    Баллы:
    26
    там все стандартное
    ОбщегоНазначения.ВыполнитьДвижениеПоРегистру(ЭтотОбъект, ВидДвиженияНакопления.Приход);
    причем отладчиком туда не доходит
  9. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.551
    Симпатии:
    716
    Баллы:
    204
    оно выполняется без ошибок?
  10. TopicStarter Overlay
    alboldinov
    Offline

    alboldinov Опытный в 1С

    Регистрация:
    8 сен 2014
    Сообщения:
    183
    Симпатии:
    0
    Баллы:
    26
    До этого места не доходит раньше на права ругается
  11. Dem0lisher
    Offline

    Dem0lisher Профессионал в 1С

    Регистрация:
    4 авг 2009
    Сообщения:
    1.023
    Симпатии:
    51
    Баллы:
    54
    Почему по ресурсам и измерениям чтение и просмотр? Тогда уж Чтение и Редактирование..
    А на сам регистр какие права? Тоже только чтение? Корректировка двигает этот регистр, а не только читает
  12. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.551
    Симпатии:
    716
    Баллы:
    204
    Разберитесь, в каком именно месте ругается на права доступа.
  13. TopicStarter Overlay
    alboldinov
    Offline

    alboldinov Опытный в 1С

    Регистрация:
    8 сен 2014
    Сообщения:
    183
    Симпатии:
    0
    Баллы:
    26
    На сам регистр все права, имеется ввиду на измерения с составным типом документов.
    --- Объединение сообщений, 1 апр 2016 ---
    Код:
    Процедура ОбработкаПроведения(Отказ, РежимПроведения)
    
        // Дерево значений, содержащее имена необходимых полей в запросе по шапке.
        Перем ДеревоПолейЗапросаПоШапке;
       
        Если мУдалятьДвижения Тогда
            ОбщегоНазначения.УдалитьДвиженияРегистратора(ЭтотОбъект, Отказ);
        КонецЕсли;
    
        СтруктураШапкиДокумента = ОбщегоНазначения.СформироватьСтруктуруШапкиДокумента(ЭтотОбъект);
    
        СтруктураШапкиДокумента.Вставить("СкладОтправитель", Склад);
    
        // Заполним по шапке документа дерево параметров, нужных при проведении.
        ДеревоПолейЗапросаПоШапке      = УправлениеЗапасами.СформироватьДеревоПолейЗапросаПоШапке();
        УправлениеЗапасами.ДобавитьСтрокуВДеревоПолейЗапросаПоШапке(ДеревоПолейЗапросаПоШапке, "Склад",           "ВидСклада",                        "ВидСклада");
        УправлениеЗапасами.ДобавитьСтрокуВДеревоПолейЗапросаПоШапке(ДеревоПолейЗапросаПоШапке, "Организации",     "ОтражатьВРегламентированномУчете", "ОтражатьВРегламентированномУчете");
        УправлениеЗапасами.ДобавитьСтрокуВДеревоПолейЗапросаПоШапке(ДеревоПолейЗапросаПоШапке, "УчетнаяПолитика", "ВестиПартионныйУчетПоСкладам",     "ВестиПартионныйУчетПоСкладам");
        УправлениеЗапасами.ДобавитьСтрокуВДеревоПолейЗапросаПоШапке(ДеревоПолейЗапросаПоШапке, "УчетнаяПолитика", "ВестиУчетТоваровОрганизацийВРазрезеСкладов", "ВестиУчетТоваровОрганизацийВРазрезеСкладов");
    
        // Сформируем запрос на дополнительные параметры, нужные при проведении, по данным шапки документа
        СтруктураШапкиДокумента = УправлениеЗапасами.СформироватьЗапросПоДеревуПолей(ЭтотОбъект, ДеревоПолейЗапросаПоШапке, СтруктураШапкиДокумента, мВалютаРегламентированногоУчета);
    
        // Заголовок для сообщений об ошибках проведения.
        Заголовок = ОбщегоНазначения.ПредставлениеДокументаПриПроведении(СтруктураШапкиДокумента);
    
        // Проверим правильность заполнения шапки документа
        ПроверитьЗаполнениеШапки(СтруктураШапкиДокумента, Отказ, Заголовок);
    
        // Получим необходимые данные для проведения и проверки заполнения данных по табличной части "Товары".
        СтруктураПолей = Новый Структура;
        СтруктураПолей.Вставить("Номенклатура"                 , "Номенклатура");
        СтруктураПолей.Вставить("Количество"                   , "Количество * Коэффициент /Номенклатура.ЕдиницаХраненияОстатков.Коэффициент");
        СтруктураПолей.Вставить("ХарактеристикаНоменклатуры"   , "ХарактеристикаНоменклатуры");
        СтруктураПолей.Вставить("СерияНоменклатуры"            , "СерияНоменклатуры");
        СтруктураПолей.Вставить("Набор"                        , "Номенклатура.Набор");
        СтруктураПолей.Вставить("Комплект"                     , "Номенклатура.Комплект");
        СтруктураПолей.Вставить("Услуга"                       , "Номенклатура.Услуга");
        СтруктураПолей.Вставить("Качество"                     , "Качество");
        СтруктураПолей.Вставить("КачествоНовое"                , "КачествоНовое");
        СтруктураПолей.Вставить("Склад"                        , "Ссылка.Склад");
    
        РезультатЗапросаПоТоварам = УправлениеЗапасами.СформироватьЗапросПоТабличнойЧасти(ЭтотОбъект, "Товары", СтруктураПолей);
    
        // Подготовим таблицу товаров для проведения.
        ТаблицаПоТоварам = ПодготовитьТаблицуТоваров(РезультатЗапросаПоТоварам, СтруктураШапкиДокумента);
    
        // Проверить заполнение ТЧ "Товары".
        ПроверитьЗаполнениеТабличнойЧастиТовары(ТаблицаПоТоварам, СтруктураШапкиДокумента, Отказ, Заголовок);
    
        // Движения по документу
        Если Не Отказ Тогда
            ДвиженияПоРегистрам(РежимПроведения, СтруктураШапкиДокумента, ТаблицаПоТоварам, Отказ, Заголовок);
        КонецЕсли;
    вот здесь ошибка КонецПроцедуры
    --- Объединение сообщений, 1 апр 2016 ---
    последняя строка потом ошибка прав
  14. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.551
    Симпатии:
    716
    Баллы:
    204
    После завершения ОбработкаПроведения() отрабатывают подписки, если не установлен флаг Отказ, затем происходит запись всех/измененных наборов записей регистров, у которых документ является регистратором.
  15. TopicStarter Overlay
    alboldinov
    Offline

    alboldinov Опытный в 1С

    Регистрация:
    8 сен 2014
    Сообщения:
    183
    Симпатии:
    0
    Баллы:
    26
    отказ ложь, до записи не доходит, получается где-то подписка, буду тогда все подписки еще раз проверять
  16. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.551
    Симпатии:
    716
    Баллы:
    204
    Есть же поиск ссылок на объект.
  17. TopicStarter Overlay
    alboldinov
    Offline

    alboldinov Опытный в 1С

    Регистрация:
    8 сен 2014
    Сообщения:
    183
    Симпатии:
    0
    Баллы:
    26
    в конфигурации?
    --- Объединение сообщений, 1 апр 2016 ---
    руками не нашел, функции чтобы искала по объектам конфигурации ссылки такой не знаю:(
  18. alexburn
    Online

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.742
    Симпатии:
    509
    Баллы:
    204
    Правой мышью по документу - поиск ссылок на объект
  19. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.551
    Симпатии:
    716
    Баллы:
    204
  20. TopicStarter Overlay
    alboldinov
    Offline

    alboldinov Опытный в 1С

    Регистрация:
    8 сен 2014
    Сообщения:
    183
    Симпатии:
    0
    Баллы:
    26
    Спасибо, результат
    ПодпискаНаСобытие.ПередЗаписьюДокументаДляОбменаУТУПП.Источник
    ПодпискаНаСобытие.ПередУдалениемДокументаДляОбменаУТУПП.Источник
    ПодпискаНаСобытие.ПриУстановкеНовогоНомераДокумента.Источник
    В которых все проходит нормально

Поделиться этой страницей