7.7 Ошибка! Поле агрегатного объекта не обнаружено

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Алёна, 22 сен 2008.

  1. TopicStarter Overlay
    Алёна
    Offline

    Алёна

    Регистрация:
    8 сен 2008
    Сообщения:
    40
    Симпатии:
    0
    Баллы:
    1
    В запросе к документу пишу так:
    Код:
    КДниОМС = Документ.ЭкономическиеКойкоДни.ФактическиеКойкоДниОМС;
    //Затем выгружаю в таблицу значений:
    ЗапросДок.Выгрузить(ТабДокЭк);
    //И переношу данные в новую таблицу значений которая положена в основу отчета:
    ТабЗнач.ВыбратьСтроки();
    ТабДокЭк.ВыбратьСтроки();
    Пока ТабЗнач.ПолучитьСтроку()=1 Цикл 
    Пока ТабДокЭк.ПолучитьСтроку()=1 Цикл
    Пока ЗапросДок.Группировка("Койка")=1 Цикл
    Если ТабЗнач.Койка=ТабДокЭк.Койка Тогда
    ТабЗнач.ФактКДниОМС=ТабДокЭк.КДниОМС; 
    Если ТабЗнач.ПланКДни>0 тогда
    ТабЗнач.ВыполПлПоКДнямОМС=ТабЗнач.ФактКДниОМС*100/ТабЗнач.ПланКДни;
    КонецЕсли;
    Прервать;
    КонецЕсли;
    КонецЦикла;
    КонецЦикла;
    КонецЦикла;
    
    В результате выдает ошибку:
    ТабЗнач.ФактКДниОМС=ТабДокЭк.КДниОМС;
    {Отчет.ПоказателиСтационара.Форма.Модуль(239)}: Поле агрегатного объекта не обнаружено (КДниОМС) :unsure:
  2. Kaboom
    Offline

    Kaboom Опытный в 1С

    Регистрация:
    2 июл 2007
    Сообщения:
    158
    Симпатии:
    0
    Баллы:
    26
    Похоже что в запросе нет переменной и/или группировки с наименованием КДниОМС. Предлагаю показать текст запроса.

    ЗЫ. Используйте тег code, и форматируйте код. Будет намного удобнее читать.
  3. Мастер_миража
    Offline

    Мастер_миража Опытный в 1С

    Регистрация:
    22 сен 2008
    Сообщения:
    148
    Симпатии:
    0
    Баллы:
    26
    ЗапросДок.Выгрузить(ТабДокЭк);

    Скорее всего нужно указать дополнительные параметры...
    Кажется по умолчанию из запроса выгружаются тока переменные учавствующие в группировке
  4. TopicStarter Overlay
    Алёна
    Offline

    Алёна

    Регистрация:
    8 сен 2008
    Сообщения:
    40
    Симпатии:
    0
    Баллы:
    1
    Спасибо! Уже разобралась! В запросе была функция по суммированию данной переменной, которую и надо было достать на самом деле! :unsure:

Поделиться этой страницей