7.7 Ошибка подключения 7.7 по OLE

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Poleshenko, 17 окт 2006.

  1. TopicStarter Overlay
    Poleshenko
    Offline

    Poleshenko

    Регистрация:
    17 окт 2006
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Конфигурация «Управление производственным предприятием» рел. 1.1.8.2
    Релиз платформы 8.0.16

    При попытке создать ОЛЕ объект 1С Предприятия 7.7 из 1С Предприятия 8.0 выскакивает ошибка:

    {Обработка.ЗагрузкаВБухгалтерию.Форма.Форма(6)}: Ошибка при вызове конструктора (COMОбъект): Недопустимая строка с указанием класса
    V7 = Новый COMОбъект("V77.Application");
    по причине:
    Недопустимая строка с указанием класса

    Это происходит только на компьютерах в одном отделе. В офисе, на сервере, в ИТ отделе подключение происходит без проблем и процедура все отрабатывает (пишет в 7.7 новые доки из 8.0).
    Операционка Windows XP SP1.
    Ставили там компоненту .net framework - не помогло.
    Ни каких особенных настроек прав не выполнялось.

    В чем причина?
    :unsure:
  2. 1010011010
    Offline

    1010011010 [1cworld]

    Регистрация:
    1 авг 2006
    Сообщения:
    582
    Симпатии:
    0
    Баллы:
    26
    он не видит такую штуку как V77.Application, говорит такого нет.
  3. TopicStarter Overlay
    Poleshenko
    Offline

    Poleshenko

    Регистрация:
    17 окт 2006
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Действительно в реестре не было записей об установленном 1С Предприятии 7.7. Переустановили 7.7.

    Теперь процесс создания сервера ОЛЕ идет долго и в результате появляется следующая ошибка:

    {Обработка.ЗагрузкаВБухгалтерию.Форма.Форма(8)}: Ошибка при вызове конструктора (COMОбъект): Ошибка при выполнении приложения-сервера

    V7 = Новый COMОбъект("V77.Application");

    по причине: Ошибка при выполнении приложения-сервера

    Проверил настройки протокола TCP/IP, использование DCOM, права на удаленный запуск – все стоит правильно.
    Я так понимаю что то мешает нормальной работе сервера ОЛЕ.
  4. TopicStarter Overlay
    Poleshenko
    Offline

    Poleshenko

    Регистрация:
    17 окт 2006
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    заключил создание COMОбъекта в "попытка - исключение ", описание ошибки выдает следующее:

    Ошибка при вызове конструктора (COMОбъект): Ошибка при выполнении приложения-сервера

    Какие мысли?
  5. TopicStarter Overlay
    Poleshenko
    Offline

    Poleshenko

    Регистрация:
    17 окт 2006
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    При этом Новый COMОбъект("Excel.Application"); отрабатывает без проблем
    :unsure:
  6. Amishechka
    Offline

    Amishechka Опытный в 1С

    Регистрация:
    8 сен 2006
    Сообщения:
    361
    Симпатии:
    1
    Баллы:
    26
    А может просто у них нет полных прав на локальную папку с 1с 7?
  7. TopicStarter Overlay
    Poleshenko
    Offline

    Poleshenko

    Регистрация:
    17 окт 2006
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    там FAT обычный
  8. net888
    Offline

    net888

    Регистрация:
    29 сен 2006
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    попытка
    V77 = New COMОбъект("V77.Application");
    Исключение
    сообщить(ОписаниеОшибки());
    Возврат;
    КонецПопытки;

    ОткрытаУспешно = V77.Initialize(V77.RMTrade,"","NO_SPLASH_WINDOW");
    Если Число(ОткрытаУспешно) = 0 Тогда
    Предупреждение("Не удалось подключиться к 77!",,"Ошибка");
    V77 = Неопределено;
    Возврат;
    КонецЕсли;
    Сообщить("Успешное соединение");
    // Вставить содержимое обработчика.
    Если V77 = неопределено Тогда
    Предупреждение("Нет соединения!");
    возврат;
    КонецЕсли;
    cпрФирмы = V77.CreateObject("Справочник.Фирмы");
    Если cпрФирмы.ВыбратьЭлементы() = 0 Тогда
    Сообщить("Ошибка выбора элементов");
    Иначе
    Пока cпрФирмы.ПолучитьЭлемент() = 1 Цикл
    ждитеОтвета();
    ЭлементыФормы.ПолеВыбораФирмы.СписокВыбора.Добавить(cпрФирмы.ТекущийЭлемент(),cпрФирмы.Наименование);
    КонецЦикла;
    КонецЕсли;

Поделиться этой страницей