7.7 ошибка: переменная не определена

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем toshkins, 7 июл 2008.

  1. TopicStarter Overlay
    toshkins
    Offline

    toshkins

    Регистрация:
    7 июл 2008
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    создала кнопку "поиск непроводимых". просто цикл в котором ищутся док-ты, кот не могут быть проведены (остаток на складе=0).

    Код:
    Процедура ПоискНеПроводимых(Конт) Экспорт
    Рег=СоздатьОбъект("Регистр.ОстаткиТоваров");
    Рег.Товар=Конт.Товар;
    Рег.Склад=Конт.Склад;
    Рег.ОстаткиПолучить();
    ОбщееКоличество=Конт.Количество*Конт.Коэффициент;
    Конт.ВыбратьСтроки();
    Пока( Конт.ПолучитьСтроку()>0) Цикл
    Если (Рег.ОстатокТовара =0)
    И (Константа.РазрешитьОтрицОстатки=Перечисление.Булево.Нет) Тогда
    Сообщить("На складе нет нужного количества товара "+Конт.Товар.Наименование);
    Сообщить(Конт,"На складе осталось "+Рег.ОстатокТовара+" "+Конт.Товар.БазоваяЕдиница);
    КонецЕсли;
    КонецЦикла;		
    КонецПроцедуры
    
    выдаётся ошибка:
    ПоискНеПроводимых(Конт<<?>>)
    Переменная не определена (Конт)
    если же определяю ее, то появляются другие ошибки типа
    Рег.Товар=Конт.Товар;
    {Глобальный модуль(138)}: Значение не представляет агрегатный объект (Товар)
    что я делаю не так? помогите плз
  2. Stado_adama
    Offline

    Stado_adama Модераторы Модератор

    Регистрация:
    27 ноя 2007
    Сообщения:
    1.086
    Симпатии:
    0
    Баллы:
    26
    где у тебя располагается эта кнопочка? ты вообще знаешь что такое конт?

Поделиться этой страницей