8.х Ошибка печати этикеток. 1С:Предприятие "Далион" Лайт 1.2

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем BIG_Maks, 25 июн 2013.

  1. TopicStarter Overlay
    BIG_Maks
    Offline

    BIG_Maks

    Регистрация:
    25 июн 2013
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Добрый день.
    Программа выдает ошибку при печати этикеток.
    {Обработка.ПечатьЦенниковЭтикеток(872)}: Ошибка при вызове метода контекста (Прочитать): Ошибка при выполнении файловой операции.
    Подскажите как решить эту проблему.
  2. n.s.gnedash
    Offline

    n.s.gnedash Опытный в 1С Команда форума

    Регистрация:
    15 авг 2010
    Сообщения:
    1.359
    Симпатии:
    5
    Баллы:
    29
    Так на вскидку - ХЗ, я бы посмотрел отладчиком, что он там "Прочитать" не может..
  3. TopicStarter Overlay
    BIG_Maks
    Offline

    BIG_Maks

    Регистрация:
    25 июн 2013
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    С этой проблемой разобрался. Пытаюсь настроить печать этикеток, жму печать и вылазит теперь другая ошибка: {Обработка.ПечатьЦенниковЭтикеток(869)}: Значение не является значением объектного типа (Записать).

    Вопрос ещё, так как я пользователь не опытный в плане 1С, как мне "показать" вам при помощи отладчика ошибку, если можно объясните по шагам.

    Доп. инфа: Используется 1С: Предприятие 8.1 Далион (управление магазином LIte)
  4. n.s.gnedash
    Offline

    n.s.gnedash Опытный в 1С Команда форума

    Регистрация:
    15 авг 2010
    Сообщения:
    1.359
    Симпатии:
    5
    Баллы:
    29
    Там где выскикивает ошибка(в предприятии), есть кнопка ПОДРОБНО, или что-то вроде того, в ней развернется текст в каком месте ошибка.. ее сюда скопируй. С помощью отладчика ты не сможешь показать ошибку, там только смотреть самому.
  5. TopicStarter Overlay
    BIG_Maks
    Offline

    BIG_Maks

    Регистрация:
    25 июн 2013
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Скинул снимок экрана. Нет там кнопки "подробно", вообще ничего по этому поводу.

    Вложения:

  6. n.s.gnedash
    Offline

    n.s.gnedash Опытный в 1С Команда форума

    Регистрация:
    15 авг 2010
    Сообщения:
    1.359
    Симпатии:
    5
    Баллы:
    29
    Тогда в модуле обработки нужно поискать место, в котором скорее всего будет примерно такая конструкция
    Попытка
    ///
    Исключение
    Сообщить("ОписаниеОшибки());
    КонецПопытки

    Программа пытается что-то сделать (в твоем случае что-то записать), а если не получилось сообщает причину ошибки
  7. TopicStarter Overlay
    BIG_Maks
    Offline

    BIG_Maks

    Регистрация:
    25 июн 2013
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Как мне вообще зайти в модуль обработки?
  8. SergeyB
    Offline

    SergeyB Модераторы Команда форума Модератор

    Регистрация:
    8 июн 2010
    Сообщения:
    621
    Симпатии:
    3
    Баллы:
    29
    через конфигуратор. Обработки-ПечатьЭтикеток . как то так.
  9. TopicStarter Overlay
    BIG_Maks
    Offline

    BIG_Maks

    Регистрация:
    25 июн 2013
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Добрый день. Зашел в конфигуратор - обработка ценников и этикеток, нашел макеты ценников и этикеток (кстати я не могу отредактировать макет, весит замок "только чтение", может как-то можно разблокировать, подскажите если что).
    Насчет описания ошибки ничего не могу там найти((.

    Снимок экрана.

    Вложения:

  10. SergeyB
    Offline

    SergeyB Модераторы Команда форума Модератор

    Регистрация:
    8 июн 2010
    Сообщения:
    621
    Симпатии:
    3
    Баллы:
    29
    В Конфигураторе. Конфигурация-Поддержка-Настройка поддержки.Кнопка Включить возможность изменения. Выставить Объект поставщика редактируется с сохранением поддержки. Ок. Открыть. На клавиатуре нажать F7.
  11. TopicStarter Overlay
    BIG_Maks
    Offline

    BIG_Maks

    Регистрация:
    25 июн 2013
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Добрый день. Я ранее пытался найти настройку поддержки, там где вы указали, но там этого пункта нет!!(. Есть только ...

    Вложения:

  12. n.s.gnedash
    Offline

    n.s.gnedash Опытный в 1С Команда форума

    Регистрация:
    15 авг 2010
    Сообщения:
    1.359
    Симпатии:
    5
    Баллы:
    29
    у тебя базовая, там дописывать ни чего нельзя. правой кнопкой нажми в списке на ПечатьЭтикеток - сохранить как внешнюю обработку\отчет.
  13. TopicStarter Overlay
    BIG_Maks
    Offline

    BIG_Maks

    Регистрация:
    25 июн 2013
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Наконец-то я нашел модуль обработки)), и вот эту процедуру...

    //Процедура - обработчик события "НачалоВыбораИзСписка" поля ввода ИмяПринтера.
    //
    Процедура ИмяПринтераНачалоВыбораИзСписка(Элемент, СтандартнаяОбработка)

    // Заполним список принтеров

    СписокПринтеров = Новый СписокЗначений();
    СписокПринтеров.Добавить("", "Принтер по умолчанию");

    Попытка

    WshNetwork = Новый COMОбъект("WScript.Network");
    массивПринтеров = WshNetwork.EnumPrinterConnections();
    КолПринтеров = массивПринтеров.length;

    Для Счетчик = 0 По КолПринтеров - 1 Цикл

    Если Счетчик % 2 = 1 Тогда

    СписокПринтеров.Добавить(массивПринтеров.Item(Счетчик));

    КонецЕсли;

    КонецЦикла;

    Исключение

    Сообщить("Ошибка WSH");
    Сообщить(ОписаниеОшибки());
    Возврат;

    КонецПопытки;

    Элемент.СписокВыбора = СписокПринтеров;

    КонецПроцедуры
  14. TopicStarter Overlay
    BIG_Maks
    Offline

    BIG_Maks

    Регистрация:
    25 июн 2013
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Добрый день. Я кажется начинаю понимать почему у меня не печатаются этикетки и ценники.
    Раньше, когда открывал окно печати этикеток и ценников, в строке "Макет по молчанию" стояло "значение по умолчанию", а теперь строка при открытии пустая.

    Подскажите, пожалуйста, как мне вернуть первоначальные настройки программы или создать правильно свой макет.

Поделиться этой страницей