7.7 Ошибка открытия. ПоступленийТМЦ

Тема в разделе "Общие вопросы "1С:Предприятие 7.7"", создана пользователем NeoSan, 22 июн 2012.

  1. TopicStarter Overlay
    NeoSan
    Offline

    NeoSan

    Регистрация:
    22 июн 2012
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Просьба помочь разобраться!!!
    Вылазит такая ошибка на скриншоте полное название:
    "Определения процедур и функций должны размещаться перед операторами основной программы"
    Так же прикрепил форму и модуль документа
    Как решить эту проблему?
    А то приходит новый товар, а добавит его в поступлениеТМЦ не получается :unsure:

    Вложения:

    • 1.txt
      Размер файла:
      10 КБ
      Просмотров:
      38
    • 2.txt
      Размер файла:
      58,2 КБ
      Просмотров:
      28
    • 0.jpg
      0.jpg
      Размер файла:
      45,8 КБ
      Просмотров:
      56
  2. volodya1122
    Offline

    volodya1122 Опытный в 1С

    Регистрация:
    25 фев 2011
    Сообщения:
    96
    Симпатии:
    1
    Баллы:
    26
    // Процедура ПриИзмененииНоменклатуры()
    Зачем закоментировали эту строку? и соответственно КонецПроцедуры.?
    Вот поэтому и ругается.
  3. TopicStarter Overlay
    NeoSan
    Offline

    NeoSan

    Регистрация:
    22 июн 2012
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Делал это все не я того работника уволили.\
    У меня нет опыта 1С, отладчиком не знаю как пользоваться!
    Мне бы краткую инструкцию как удалить или что там нужно добавить!
  4. volodya1122
    Offline

    volodya1122 Опытный в 1С

    Регистрация:
    25 фев 2011
    Сообщения:
    96
    Симпатии:
    1
    Баллы:
    26
    я уже написал что нужно сделать
    в строке
    //Процедура ПриИзмененииНоменклатуры()
    переелать на
    Процедура ПриИзмененииНоменклатуры()

    И ниже
    //КонецПроцедуры // ПриИзмененииНоменклатуры()
    переделать на
    КонецПроцедуры // ПриИзмененииНоменклатуры()

    Работника уволили и поэтому он сделал вам маленькие пакости. (значит уволили не по "соглашению сторон" )
  5. TopicStarter Overlay
    NeoSan
    Offline

    NeoSan

    Регистрация:
    22 июн 2012
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Так конечно не по соглашению, место то хорошее =)
  6. volodya1122
    Offline

    volodya1122 Опытный в 1С

    Регистрация:
    25 фев 2011
    Сообщения:
    96
    Симпатии:
    1
    Баллы:
    26
    тогда думаю это не последний "подарок" который он вам оставил...
  7. TopicStarter Overlay
    NeoSan
    Offline

    NeoSan

    Регистрация:
    22 июн 2012
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Спасибо все заработало, но появился столбик дополнительный Вид Товара! Ну ладно фиг с ним главное можно принимать товар! :yahoo:
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    "слабенько" отомстил...мог и наименования в справочниках номенклатуры/контрагентов почистить))))))))
  9. TopicStarter Overlay
    NeoSan
    Offline

    NeoSan

    Регистрация:
    22 июн 2012
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    А как так все работало работало, а потом перестало?
    Прошло три месяца после того как он уволился!
    Почему ошибка выявилась не сразу?
  10. volodya1122
    Offline

    volodya1122 Опытный в 1С

    Регистрация:
    25 фев 2011
    Сообщения:
    96
    Симпатии:
    1
    Баллы:
    26
    1. Или три месяца этим поступлением никто не пользовался.
    2. Или какой то сотрудник по пянке залез в конфигуратор и сделал эти изменения, а когда протверезел не вспомнил что делал
    3. Или какой то сотрудник страдает амнезией и не помнит что заходил в конфигуратор и чтото там исправлял.
    4. Сотрудник, которого уволили, настолько обиделся на вашу организацию, что имея удаленный доступ из дома залез в вашу конфигурацию и сделал эти нехитрые исправления.
    5. у вас на работе завелся умный домовой, и делает вам эти ошибки.
    6. ......
    7. ваши варианты......

Поделиться этой страницей